Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Samba setup error: unable to find a suitable server for domain <domainname>

  1. #1

    Default Samba setup error: unable to find a suitable server for domain <domainname>

    My first install of openSUSE so forgive me if I have missed something obvious.

    Summary of what I have done so far below:
    • fresh install of openSUSE 12.1 + 'File Server' software installed + others
    • Network services -> Swat: enabled
    • Services enabled:
      • nmb
      • smb
      • xinitd
      • cifs (smbfs not present appears to have been replaced by cifs)
    • Network services -> Samba Server
      • start-up: during boot
      • Identity - configure workgroup & NetBIOS hostname
      • Firewall - allow services
        • Samba server
        • Samba client
        • NetBIOS Server

    Problem is when I try and save the Samba Server configuration I get the error: 'unable to find a suitable server for domain <domainname>'

    Any suggestions what I might have done wrong?

    Thanks,
    Nick

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    14,048
    Blog Entries
    12

    Default Re: Samba setup error: unable to find a suitable server for domain <domainname>

    AFAIK this is caused by setting samba as the primary domain controller. Sure you need that?
    - Athlon X6 3.6 GHz, 16 GB DDR3, 30 GB SSD, 3 TB of disks, GT540, openSUSE 12.2 x86_64 + KDE 4.10 + GNOME 3
    - ASUS A73SD, Intel + GT610M Optimus, 6 GB, 120 GB SSD, openSUSE Tumbleweed

    Anything that can go wrong.... will teach us

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Samba setup error: unable to find a suitable server for domain <domainname>

    Didn't know I had, mind you I have been clicking around and looking so might have inadvertantly done something I shouldn't have. Where do I find the option to stop samba being a PDC?

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    14,048
    Blog Entries
    12

    Default Re: Samba setup error: unable to find a suitable server for domain <domainname>

    Quote Originally Posted by Nick_C View Post
    Didn't know I had, mind you I have been clicking around and looking so might have inadvertantly done something I shouldn't have. Where do I find the option to stop samba being a PDC?
    In Yast - Network services - Windows domain membership

    To check:
    Code:
    cat /etc/samba/smb.conf
    - Athlon X6 3.6 GHz, 16 GB DDR3, 30 GB SSD, 3 TB of disks, GT540, openSUSE 12.2 x86_64 + KDE 4.10 + GNOME 3
    - ASUS A73SD, Intel + GT610M Optimus, 6 GB, 120 GB SSD, openSUSE Tumbleweed

    Anything that can go wrong.... will teach us

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: Samba setup error: unable to find a suitable server for domain <domainname>

    Is there a backup copy of smb.conf laying around anywhere that I can restore from and start again?

  6. #6

    Default Re: Samba setup error: unable to find a suitable server for domain <domainname>

    Found it; smb.conf had the line
    security = domain
    Deleted that and error has gone away. Don't know how that got in there though.
    Thanks for your help Knurpt.

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    14,048
    Blog Entries
    12

    Default Re: Samba setup error: unable to find a suitable server for domain <domainname>

    AFAIK from memory there's three options for this param: domain, users, share.

    But, good it's working for you now.
    - Athlon X6 3.6 GHz, 16 GB DDR3, 30 GB SSD, 3 TB of disks, GT540, openSUSE 12.2 x86_64 + KDE 4.10 + GNOME 3
    - ASUS A73SD, Intel + GT610M Optimus, 6 GB, 120 GB SSD, openSUSE Tumbleweed

    Anything that can go wrong.... will teach us

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    10,951
    Blog Entries
    2

    Default Re: Samba setup error: unable to find a suitable server for domain <domainname>

    Here's an original for 12.1 if you want to start again:
    Code:
    # smb.conf is the main Samba configuration file. You find a full commented
    # version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
    # samba-doc package is installed.
    # Date: 2012-02-16
    [global]
    	workgroup = WORKGROUP
    	passdb backend = tdbsam
    	printing = cups
    	printcap name = cups
    	printcap cache time = 750
    	cups options = raw
    	map to guest = Bad User
    	include = /etc/samba/dhcp.conf
    	logon path = \\%L\profiles\.msprofile
    	logon home = \\%L\%U\.9xprofile
    	logon drive = P:
    	usershare allow guests = Yes
    [homes]
    	comment = Home Directories
    	valid users = %S, %D%w%S
    	browseable = No
    	read only = No
    	inherit acls = Yes
    [profiles]
    	comment = Network Profiles Service
    	path = %H
    	read only = No
    	store dos attributes = Yes
    	create mask = 0600
    	directory mask = 0700
    [users]
    	comment = All users
    	path = /home
    	read only = No
    	inherit acls = Yes
    	veto files = /aquota.user/groups/shares/
    [groups]
    	comment = All groups
    	path = /home/groups
    	read only = No
    	inherit acls = Yes
    [printers]
    	comment = All Printers
    	path = /var/tmp
    	printable = Yes
    	create mask = 0600
    	browseable = No
    [print$]
    	comment = Printer Drivers
    	path = /var/lib/samba/drivers
    	write list = @ntadmin root
    	force group = ntadmin
    	create mask = 0664
    	directory mask = 0775

  9. #9
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    10,951
    Blog Entries
    2

    Default Re: Samba setup error: unable to find a suitable server for domain <domainname>

    Also, very important to note this bug for openSUSE 12.1: http://forums.opensuse.org/english/g...e-systemd.html

  10. #10

    Default Re: Samba setup error: unable to find a suitable server for domain <domainname>

    All working now, thanks for your help.

    Only remaining issue is that I had to setup the user in Samba with:
    smbpasswd -a <username>
    which is ok for testing but not suitable for lots of users.

    Is there some way to get Samba to use the Windows ACLs to authenticate connections?

    Cheers,
    Nick

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •