Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: No Sound Using HDMI Cable TO HDTV

  1. #1
    Join Date
    Jun 2008
    Location
    Wildwood, New Jersey
    Posts
    133

    Default No Sound Using HDMI Cable TO HDTV

    Hi All,

    I've just come over from Linux Mint 12 KDE to openSuSE 12.1. The reason I dropped Mint was that the ATI/AMD drivers that were provided gave me display issues and although I could port my desktop to my HDTV using a HDMI cable there was no audio. This is a known issue and the recommendation was to download another driver, which I did. This worked at least for a short while and I could get audio ported to my HDTV. However, this was a fix that did not work well. Again, I had display issues and apps began to freeze.

    What I did do in Mint was to alter my sound settings to direct audio to HDMI output.

    This might be a simple fix, if I could find where I might be able to direct audio output to HDMI. Or, do I need to find another driver? I should mention I can get video ported to my TV just like with Mint. But, again no audio.

    Any assistance would be greatly appreciated!
    Regards,

    JJMacey
    Phoenix, Arizona - The Valley Of The Sun
    A Linux Web Site, And A Linux Blog. All Linux! I've been there, and done that!

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,989
    Blog Entries
    16

    Default Re: No Sound Using HDMI Cable TO HDTV

    A general recommendation for kde users ( at least by our sound guru @oldcpu ) is to use pavucontrol

    His general guide is here
    SDB:Audio troubleshooting - openSUSE
    Last edited by caf4926; 15-Mar-2012 at 03:43.
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,989
    Blog Entries
    16

    Default Re: No Sound Using HDMI Cable TO HDTV

    I should add. I don't use it
    But my audio setup is uncomplicated and just works.
    kmix does all I need.

    I'm not suggesting pavucontrol will solve your problem, but it may be a step in the right direction.
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

  4. #4
    Join Date
    Jun 2008
    Location
    Wildwood, New Jersey
    Posts
    133

    Default Re: No Sound Using HDMI Cable TO HDTV

    caf4926,

    I do have sound on my Notebook PC. Problem is getting my sound ported to my HDTV via HDMI cable. I'll go through the sound guru's article.

    Thanks for your response.
    Regards,

    JJMacey
    Phoenix, Arizona - The Valley Of The Sun
    A Linux Web Site, And A Linux Blog. All Linux! I've been there, and done that!

  5. #5

    Default Re: No Sound Using HDMI Cable TO HDTV

    Quote Originally Posted by jjmacey View Post
    caf4926,

    I do have sound on my Notebook PC. Problem is getting my sound ported to my HDTV via HDMI cable. I'll go through the sound guru's article.

    Thanks for your response.
    I am using HDMI with Nvidia and I have to configure it in /etc/pulse/default.pa to make the sound work
    I am not sure if it work the same with ATI cards.

    While waiting for the sound gurus why not post your output with the commands:
    Code:
    aplay -l
    Code:
    aplay -L
    People who do not break things first will never learn to create anything

  6. #6
    Join Date
    Jun 2008
    Location
    Wildwood, New Jersey
    Posts
    133

    Default Re: No Sound Using HDMI Cable TO HDTV

    conram,

    Thanks for the post,

    Per your suggestion:

    ey@linux-5zoo:~> su -
    Password:
    linux-5zoo:~ # aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 0: SB [HDA ATI SB], device 1: STAC92xx Digital [STAC92xx Digital]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    linux-5zoo:~ #
    linux-5zoo:~ #
    linux-5zoo:~ # aplay -L
    null
    Discard all samples (playback) or generate zero samples (capture)
    default
    Default ALSA Output (currently PulseAudio Sound Server)
    sysdefault:CARD=SB
    HDA ATI SB, STAC92xx Analog
    Default Audio Device
    front:CARD=SB,DEV=0
    HDA ATI SB, STAC92xx Analog
    Front speakers
    surround40:CARD=SB,DEV=0
    HDA ATI SB, STAC92xx Analog
    4.0 Surround output to Front and Rear speakers
    surround41:CARD=SB,DEV=0
    HDA ATI SB, STAC92xx Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
    surround50:CARD=SB,DEV=0
    HDA ATI SB, STAC92xx Analog
    5.0 Surround output to Front, Center and Rear speakers
    surround51:CARD=SB,DEV=0
    HDA ATI SB, STAC92xx Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    surround71:CARD=SB,DEV=0
    HDA ATI SB, STAC92xx Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    iec958:CARD=SB,DEV=0
    HDA ATI SB, STAC92xx Digital
    IEC958 (S/PDIF) Digital Audio Output
    hdmi:CARD=HDMI,DEV=0
    HDA ATI HDMI, HDMI 0
    HDMI Audio Output
    linux-5zoo:~ #
    Regards,

    JJMacey
    Phoenix, Arizona - The Valley Of The Sun
    A Linux Web Site, And A Linux Blog. All Linux! I've been there, and done that!

  7. #7

    Default Re: No Sound Using HDMI Cable TO HDTV

    Looks like pulseaudio failed to start in your sound setting
    Looking at this:
    Default ALSA Output (currently PulseAudio Sound Server)
    When pulseaudio failed to load several times on my machine I usually just delete
    my /home/user/.pulse and restart x.

    Looking at your aplay -l this is your HDMI
    card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
    We will attempt to have a simultaneous output from both of your sound controllers
    meaning both sounds from your devices will have an ouput sound to their respective speakers.
    We will try to add it in your /etc/pulse/default.pa as su like this:

    Code:
    ### Load HDMI device
    load-module module-alsa-sink device=hw:1,3
    load-module module-combine sink_name=combined
    set-default-sink combined
    After the changes reboot your system and keep your fingers cross.
    This is how I always do on my machine but take note it is an nvidia card.
    So I am not really sure if it will work.

    Note:
    If you haven't installed the pavucontrol, please do so because it is the
    place where it is easy to figure your sound config.
    Please have a look also if all the pulseaudio requirements are already installed
    on your machine.

    Lastly you can run aplay command without being su

    Edit:

    Play with this two when you modify the default.pa
    load-module module-alsa-sink device=hw:1,3
    load-module module-alsa-sink device=hw:0,3
    People who do not break things first will never learn to create anything

  8. #8
    Join Date
    Jun 2008
    Location
    Wildwood, New Jersey
    Posts
    133

    Default Re: No Sound Using HDMI Cable TO HDTV

    conram,

    I have been digging around the Forum myself and ran across the quote below from here.

    Pulse Audio Volume Control

    Since openSUSE-11.4 KDE has had pulse audio installed and active by default. Gnome has had pulse audio even before then. In such a case, it can be useful for KDE users to install the application pulse audio volume control (pavucontrol) and use that application to tune one's audio for each multimedia application. Gnome users may find pauvcontrol installed already by default. LXDE users will find they will first need to install pulse audio (as pulse audio was not automatically installed in LXDE as of openSUSE-12.1 and earlier) and only then install pavucontrol.

    On openSUSE-11.4 and newer, to install pavucontrol, type "su" (without quotes) followed by root password to get root permissions in a konsole/xterm, and then to install pavucontrol type:
    zypper in pavucontrol

    then after it is installed, type "exit" to get rid of root permissions, and then to run pavucontrol, just type "pavucontrol". The 1st time you run each application, tune pulse audio for that application, ensuring you have the each application tuned to use the correct audio device.
    I have installed pavucontrol and running the app I have this as Audio Output:




    As you can see both my internal and HDMI outputs are muted. This is not the case with my internal PC speakers. I do get sound.

    Thanks for the guidance so far. Any more suggestions? BTW, thanks for your post.
    Regards,

    JJMacey
    Phoenix, Arizona - The Valley Of The Sun
    A Linux Web Site, And A Linux Blog. All Linux! I've been there, and done that!

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    10,115

    Default Re: No Sound Using HDMI Cable TO HDTV

    As you can see both my internal and HDMI outputs are muted. This is not the case with my internal PC speakers. I do get sound.
    Maybe this blog on the same topic will help

    How to make PulseAudio work with Nvidia HDMI audio outputs under Fedora and Ubuntu | piggott.me.uk

    As conram mentioned, you may need to edit /etc/pulse/default.pa (as also outlined in the blog) with the appropriate 'load-module module-alsa-sink device=hw:1,...' entries specific to your HDMI devices.

  10. #10
    Join Date
    Jun 2008
    Location
    Wildwood, New Jersey
    Posts
    133

    Default Re: No Sound Using HDMI Cable TO HDTV

    deano_ferrari,

    Thanks for the post. I'll read the article, but I should mention that I run ATI/AMD.
    Regards,

    JJMacey
    Phoenix, Arizona - The Valley Of The Sun
    A Linux Web Site, And A Linux Blog. All Linux! I've been there, and done that!

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •