Results 1 to 9 of 9

Thread: VLC won't play videos

  1. #1

    Default VLC won't play videos

    I'm new to openSuse. I'm a avid fan of Debian and Debian based distros... My previous experiences with .rpm packages & all were with Redhat and Fedora about a couple of years ago and I wasn't a fan of them.
    So far my experience with Opensuse has been quite good until the point when I installed VLC and tried to play a video. VLC plays the videos just fine on Debian, but not on OpenSuse. Am I missing something??? I installed it correctly as the VLC site suggested for opensuse.

    Any ideas???

  2. #2
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,518

    Default Re: VLC won't play videos

    Quote Originally Posted by knightjp View Post
    I'm new to openSuse. I'm a avid fan of Debian and Debian based distros... My previous experiences with .rpm packages & all were with Redhat and Fedora about a couple of years ago and I wasn't a fan of them.
    So far my experience with Opensuse has been quite good until the point when I installed VLC and tried to play a video. VLC plays the videos just fine on Debian, but not on OpenSuse. Am I missing something??? I installed it correctly as the VLC site suggested for opensuse.

    Any ideas???
    Follow the directions in the multimedia forum to get started playing your videos.

    http://forums.opensuse.org/english/g...one-click.html

    You can remove the VLC repository. This is available in the Packman repo and having both can lead to conflicts.

  3. #3

    Default Re: VLC won't play videos

    Quote Originally Posted by chief_sealth View Post
    Follow the directions in the multimedia forum to get started playing your videos.

    http://forums.opensuse.org/english/g...one-click.html

    You can remove the VLC repository. This is available in the Packman repo and having both can lead to conflicts.
    Thanks for this.... I wanted to like OpenSuse so much but couldn't enjoy my fav movies with it..
    Now I can enjoy the distro. So far its been pretty amazing. I wonder why it isn't as high up as Ubuntu. Certainly better than Fedora and Ubuntu.

  4. #4
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,518

    Default Re: VLC won't play videos

    I'm glad it's going well for you. openSUSE by my experience is the best distro out there, and I think you will continue to enjoy yours. Keep asking questions here if you need help. You sound like an experienced Linux user but there will be subtle differences.

  5. #5

    Default Re: VLC won't play videos

    Well I think you're over estimating my knowledge of Linux. Most of my experience comes with Ubuntu and Debian which means the installations were done using 'apt-get' packages, etc.. which makes it as easy as clicking next on a Windows installation.
    Recently though when I installed Debian and installed Google Chrome, for some reason it never appeared in the main menu, making it impossible for me to launch the program. I thought it was a problem with my installation, but after reinstalling it a couple of times, I was ready to try something else. Tried Fedora, but didn't like the Gnome3.. Tried the Gnome3 version of opensuse and found it slow.
    I came in from a Mac... And I'm desperate to go back, but for as long as I'm using a PC, I'm determined not to use Windows (too many bad memories); even though Windows7 has proven to be extremely stable.

    Anyways, so far with all the Debian and Ubuntu installations, I never had to install codecs, etc... VLC was all I needed and frankly should be the case since VLC claims that its player can play most vids without needing codecs. I sincerely hope this helps VLC play the videos...

  6. #6

    Default Re: VLC won't play videos

    The Codecs dont work... VLC still doesn't play the videos. However KDE's own player does play them, except for the .mkv files. Is there anything else I'm missing???

  7. #7
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,702
    Blog Entries
    29

    Default Re: VLC won't play videos

    Quote Originally Posted by knightjp View Post
    The Codecs dont work... VLC still doesn't play the videos. However KDE's own player does play them, except for the .mkv files. Is there anything else I'm missing???
    What codecs are needed ?

    Can you either (1) put a short clip from the video that won't play on the web where it can be downloaded and tested, and/or (2) download and install (from the packman packager repository) the application 'mediainfo' and then send the command from a terminal
    Code:
    mediainfo yourvideo.something
    where you need to substitute the exact name of your video for 'video.something' in my example. That will give you a terminal output, such as:
    Code:
    oldcpu@corei7:~> mediainfo hugo-trailer.mp4 
    General
    Complete name                    : hugo-trailer.mp4
    Format                           : MPEG-4
    Format profile                   : Base Media
    Codec ID                         : isom
    File size                        : 43.7 MiB
    Duration                         : 1mn 58s
    Overall bit rate                 : 3 103 Kbps
    Encoded date                     : UTC 2011-10-25 19:41:10
    Tagged date                      : UTC 2011-10-25 19:41:10
    Writing application              : Lavf52.62.0
    Comment                          : FlixEngineLinux_8.0.17.2 (www.on2.com)
    
    Video
    ID                               : 1
    Format                           : AVC
    Format/Info                      : Advanced Video Codec
    Format profile                   : Baseline@L3.1
    Format settings, CABAC           : No
    Format settings, ReFrames        : 1 frame
    Codec ID                         : avc1
    Codec ID/Info                    : Advanced Video Coding
    Duration                         : 1mn 58s
    Bit rate mode                    : Variable
    Bit rate                         : 2 972 Kbps
    Width                            : 1 280 pixels
    Height                           : 692 pixels
    Display aspect ratio             : 1.850
    Frame rate mode                  : Variable
    Frame rate                       : 24.000 fps
    Minimum frame rate               : 23.810 fps
    Maximum frame rate               : 24.390 fps
    Color space                      : YUV
    Chroma subsampling               : 4:2:0
    Bit depth                        : 8 bits
    Scan type                        : Progressive
    Bits/(Pixel*Frame)               : 0.140
    Stream size                      : 41.8 MiB (96%)
    Encoded date                     : UTC 2011-10-25 19:41:10
    Tagged date                      : UTC 2011-10-25 19:41:10
    
    Audio
    ID                               : 2
    Format                           : AAC
    Format/Info                      : Advanced Audio Codec
    Format version                   : Version 4
    Format profile                   : LC
    Format settings, SBR             : No
    Codec ID                         : 40
    Duration                         : 1mn 58s
    Bit rate mode                    : Variable
    Bit rate                         : 128 Kbps
    Channel(s)                       : 2 channels
    Channel positions                : Front: L R
    Sampling rate                    : 48.0 KHz
    Stream size                      : 1.80 MiB (4%)
    Encoded date                     : UTC 2011-10-25 19:41:10
    Tagged date                      : UTC 2011-10-25 19:41:10
    Copy and paste what you get for the video you are trying to play.

    also so that we can check the version of vlc that you have installed, send the command in a terminal
    Code:
    rpm -qa vlc
    and post here the output.

    for example, on my 64-bit openSUSE-11.4 PC I get:
    Code:
    oldcpu@corei7:~> rpm -qa '*vlc*'
    vlc-aout-pulse-1.1.13-13.5.x86_64
    libvlccore4-1.1.13-13.5.x86_64
    vlc-1.1.13-13.5.x86_64
    vlc-qt-1.1.13-13.5.x86_64
    libvlc5-1.1.13-13.5.x86_64
    phonon-backend-vlc-0.3.2-1.2.x86_64
    vlc-noX-1.1.13-13.5.x86_64
    Last edited by oldcpu; 04-Mar-2012 at 23:30.

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,991
    Blog Entries
    16

    Default Re: VLC won't play videos

    You might want to run the more comprehensive multi-media
    http://forums.opensuse.org/content/1...ion-guide.html
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

  9. #9

    Default Re: VLC won't play videos

    Thanks guys. I had just figured it out that I may have to do just that; when I saw the replies. The information on the link is fairly comprehensive and easy to understand. I'm sure I can get through. Will let you know how it goes.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •