Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Tout nouveau avec linux

  1. #1

    Default Tout nouveau avec linux

    Bonjour,

    Je viens juste d'installer OpenSUSE dernière version via une image iso que j'ai gravée.
    J'ai donc désormais accès à mon, bureau gnome, mais j'ai un problème.

    J'ai configuré mon accès wifi, entré la clef WPA etc, dans la barre en haut, mon pc semble être connecté au réseau (il y a même eu un popup disant que j'étais connectéà, mais je ne peux afficher aucune page sous firefox ou rechercher un logiciel.

    Que faire pour sésoudre ce problème ?

    Merci d'avance

  2. #2

    Default Re: Tout nouveau avec linux

    Est-ce que tu vois une page si tu tapes l'IP au lieu du nom dans FF:
    Example (Google):

    Code:
    http://173.194.33.39

  3. #3

    Default Re: Tout nouveau avec linux

    Quote Originally Posted by please_try_again View Post
    Est-ce que tu vois une page si tu tapes l'IP au lieu du nom dans FF:
    Example (Google):

    Code:
    http://173.194.33.39
    Effectivement, en entrant l'ip ca marche. Comment puis-je régler le problème donc ?

    Merci

  4. #4

    Default Re: Tout nouveau avec linux

    C'est un problème de DNS (Domaine Name server). La résolution du nom ne se fait pas. En principe, ton router devrait passer automatiquement le DNS de ton fournisseur d'accès à ta connection. Est-ce qu'il y a d'autres ordis ou d'autres systèmes dans la maison qui se connectent normalement? Est-ce que ça marche si tu bootes avec un live CD d'openSUSE? (tu peux aller où tu veux sur Internet?) Si ça ne marche pas avec les autres, le routeur a un problème ... ou le DNS de ton fournisseur d'accès est en panne. Mais en principe , ils en ont plusieurs. Si ça marche avec les autres, je ne sais pas trop, car je n'utilise pas le WIFI ni le network manager avec openSUSE. Normalement, il ne devrait rien y avoir à faire. Mais tu peux à tout moment éditer ta connection et ajouter des DNS servers. 8.8.8.8 (Google) et 208.67.222.222 (openDNS) sont libres. Cependant, celui de ton fournisseur d'accès devrait être plus rapide (enfin, ce n'est pas prouvé).

    Est-ce que ça marche si tu bootes en system V? Au moment de booter, presse F5 et choisis "system V" au lieu du défaut systemd.

    Qu'est-ce qu'il y a dans le fichier /etc/resolv.conf ?
    Ouvre un terminal et tape:

    Code:
    sudo cat /etc/resolv.conf
    Le moyen le plus rapide d'ajouter un DNS est de l'écrire dans le fichier /etc/resolv.conf. Il faut l'éditer en tant que root .. ou plus simplement taper:

    sudo echo "nameserver 8.8.8.8" >> /etc/resolv.conf
    sudo echo "nameserver 208.67.222.222" >> /etc/resolv.conf


    Ou d'autres ips de DNS bien sûr. Ça marche immédiatement. Pas besoin de rebooter. En revanche, il est probable que ça ne marche plus quand tu rebootes ... mais essaye déjà ça.

  5. #5

    Default Re: Tout nouveau avec linux

    Chaud tout ça.

    Alors, déjà j'ai environ 9 appareils qui se connectent en wifi sur le routeur, j'ai jamais eu de problème. Je suis actuellement sous Windows 7 64bits, sur le PC même où j'ai installé openSuSE, et je n'ai pas de soucis.

    Pour le live CD, j'ai hier effacé le CD d'installation car j'avais fini l'installation et j'avais besoin d'un DVD, donc bon...

    Je vais essayer de booter differement et de regarder le fichier où sont stockés les DNS et je te tiendrais au courant (c'est un peu énervant je dois booter, rebooter, et re rebooter pour poster ).

    Merci encore

  6. #6

    Default Re: Tout nouveau avec linux

    Ok impeccable, je suis actuellement sous openSuse . Le fichier resolv.conf était vide, j'ai ajouté les ips que tu as donné, et c'est bon tout semble marcher. Je verrais si ca marche encore une fois que j'aurais rebooté.

    Ca fait drôle quand même de surfer sur un autre OS, y'a tout qui change, et pour le moment la police linux par défaut me fait un peu mal aux yeux.

    J'aurais désormais quelques questions supplémentaires, plus de type débutant (et je m'en excuse d'avance) :
    - Pour installer des nouveaux paquets il faut obligatoirement passer par YaST ?
    - Comment fonctionne le pare-feu par rapport à iptables ?
    - Au niveau personnalisation du bureau, je pourrais savoir comment ajouter des widgets style consommation de RAM, de DDR5 et de CPU, ainsi qu'une barre d'accès rapide aux programmes genre celle de ubuntu?

    Merci

    PS : J'ai plein de bug assez énervants qui surviennent tout le temps, genre quand j'agrandis une fenêtre, ça provoque ça : http://www.toopix.eu/userfiles/b512a...d81bd46f31.png
    J'ai pourtant 8Go de RAM, un i5 et une très bonne carte graphique...

  7. #7

    Default Re: Tout nouveau avec linux

    Quote Originally Posted by teol91 View Post
    Ok impeccable, je suis actuellement sous openSuse . Le fichier resolv.conf était vide, j'ai ajouté les ips que tu as donné, et c'est bon tout semble marcher. Je verrais si ca marche encore une fois que j'aurais rebooté.
    En général /etc/resolv.conf est effacé quand tu rebootes. Si ça se produit, je te dirai où mettre les DNS "statiques" , tout en sachant que ce n'est pas la solution. En principe, tu devrais recevoir le DNS de ton router. Peut-être que quelqu'un qui utilise network manager et une connection wifi pourrait te renseigner. Il est possible qu'un truc soit mal configuré.

    Quote Originally Posted by teol91 View Post
    Ca fait drôle quand même de surfer sur un autre OS, y'a tout qui change, et pour le moment la police linux par défaut me fait un peu mal aux yeux.
    Je ne fais pas trop gaffe, mais il y a de nombreux posts qui expliquent comment installer et utiliser la police d'Ubuntu. Beaucoup de gens ont eu en effet ce problème.

    Quote Originally Posted by teol91 View Post
    J'aurais désormais quelques questions supplémentaires, plus de type débutant (et je m'en excuse d'avance) :
    Si tu as une question ou un problème particulier, essaye d'ouvrir un nouveau fil de discussion en décrivant le problème le plus précisément possible dans le titre. Un titre comme "Tout nouveau avec Linux" ne donne aucun renseignement sur le type de problème et n'aide ni ceux qui peuvent t'aider, ni ceux qui ont le même problème à trouver la solution.


    Quote Originally Posted by teol91 View Post
    - Pour installer des nouveaux paquets il faut obligatoirement passer par YaST ?
    Non. Mais il vaut mieux passer par le système de gestions des paquets de la distribution, en l'occurence "zypper". La commande "zypper" permet d'installer ou de désinstaller des paquets et des dépôts, de faire des mises à jour, etc. zypper a une page de manuel qui explique toute la syntaxe. Rapidement, pour installer un package, par exemple, Midnight Commander (mc) :

    Code:
    zypper in mc
    Pour l'effacer:

    Code:
    zypper rm mc

    zypper in est léquivalent de apt-get install sur Ubuntu.


    On peut aussi installer un paquet directement avec la commande rpm, mais il n'y a aucune raison de faire comme ça, car les dépendences ne sont pas installées automatiquement par cette commande.


    Quote Originally Posted by teol91 View Post
    - Comment fonctionne le pare-feu par rapport à iptables ?
    J'en sais trop rien. J'imagine que le pare-feu crée des 'rules' de iptables, si tu veux parler de l'interface.

    Quote Originally Posted by teol91 View Post
    - Au niveau personnalisation du bureau, je pourrais savoir comment ajouter des widgets style consommation de RAM, de DDR5 et de CPU, ainsi qu'une barre d'accès rapide aux programmes genre celle de ubuntu?
    Oui, mais il faut savoir de quel bureau tu parles. Si tu parles de Gnome, Ubuntu utilise par défaut Unity. openSUSE et Fedora utilise Gnome Shell. Si tu parles de KDE, c'est à peu près la même chose.


    Quote Originally Posted by teol91 View Post
    PS : J'ai plein de bug assez énervants qui surviennent tout le temps, genre quand j'agrandis une fenêtre, ça provoque ça : http://www.toopix.eu/userfiles/b512a...d81bd46f31.png
    J'ai pourtant 8Go de RAM, un i5 et une très bonne carte graphique...
    openSUSE n'installe pas les pilotes propriétaires par défault (contrairement à Ubuntu), probablement pour de banales histoires de droits. Si ta carte graphique est une nvidia ou ATI, il faut installer le pilote propriétaire. Donc, quel est le modèle de ta carte graphique?

    Code:
    hwinfo --gfxcard

  8. #8

    Default Re: Tout nouveau avec linux

    Ok merci pour les commandes, je vais essayer de m'y faire, je suis habitué à mon serveur sous debian. Pour ce qui est de la police, c'est bon il faut juste que je m'y habitue.

    Pour ce qui est des DNS, je viens de booter, je n'ai rien changé et tout marche.

    Pour le bureau, j'ai choisi Gnome.

    Et pour la carte graphique, j'ai une Nvidia Geforce GTX 560, j'ai d'ailleurs tapé ce que tu m'as demandé dans le terminal :
    Code:
    linux-zvf0:/home/teo # hwinfo --gfxcard
    21: PCI 100.0: 0300 VGA compatible controller (VGA)             
      [Created at pci.319]
      Unique ID: VCu0._aCrF4FxLQ3
      Parent ID: vSkL.yZkDfczy2D3
      SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
      SysFS BusID: 0000:01:00.0
      Hardware Class: graphics card
      Model: "nVidia VGA compatible controller"
      Vendor: pci 0x10de "nVidia Corporation"
      Device: pci 0x1251 
      SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
      SubDevice: pci 0x13b7 
      Revision: 0xa1
      Driver: "nouveau"
      Driver Modules: "drm"
      Memory Range: 0xda000000-0xdbffffff (rw,non-prefetchable)
      Memory Range: 0xc8000000-0xcfffffff (ro,non-prefetchable)
      Memory Range: 0xd0000000-0xd3ffffff (ro,non-prefetchable)
      I/O Ports: 0xd000-0xdfff (rw)
      Memory Range: 0xdc000000-0xdc07ffff (ro,non-prefetchable,disabled)
      IRQ: 16 (479 events)
      I/O Ports: 0x3c0-0x3df (rw)
      Module Alias: "pci:v000010DEd00001251sv00001043sd000013B7bc03sc00i00"
      Driver Info #0:
        Driver Status: nvidiafb is not active
        Driver Activation Cmd: "modprobe nvidiafb"
      Driver Info #1:
        Driver Status: nouveau is active
        Driver Activation Cmd: "modprobe nouveau"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
      Attached to: #9 (PCI bridge)
    
    Primary display adapter: #21

  9. #9

    Default Re: Tout nouveau avec linux

    Quote Originally Posted by teol91 View Post
    Ok merci pour les commandes, je vais essayer de m'y faire, je suis habitué à mon serveur sous debian.
    "Un bon guerrier n'a pas d'habitude" . comme disait Castaneda. Cela dit, tu n'es pas si nouveau que ça avec Linux.

    Quote Originally Posted by teol91 View Post
    Pour ce qui est des DNS, je viens de booter, je n'ai rien changé et tout marche.
    Oui, il me semblait aussi que /etc/resolv.conf n'était plus effacé depuis un certain temps. Ils ont dû changé un truc. Si tu as un autre Linux, tape la commande "dig". Ça devrait te donner le nom et le temps de réponse de ton DNS (donc celui de ton provider). Ajoute ce DNS en première position de /etc/resolv.conf. Il est probablement plus rapide ... Enfin tu peux le savoir en appliquant la commande "dig" à chaque DNS.


    Quote Originally Posted by teol91 View Post
    Pour le bureau, j'ai choisi Gnome.
    J'adhère. Tu as le fallback ou le Gnome shell avec le pilote "nouveau"? Bon, tu verras quand tu auras changé le pilote (lire la suite).


    Quote Originally Posted by teol91 View Post
    Et pour la carte graphique, j'ai une Nvidia Geforce GTX 560, j'ai d'ailleurs tapé ce que tu m'as demandé dans le terminal :
    Et ça montre que tu utilises le pilote open source ("nouveau"), le seul disponible à ce stade:

    Quote Originally Posted by teol91 View Post
    Code:
    linux-zvf0:/home/teo # hwinfo --gfxcard
    21: PCI 100.0: 0300 VGA compatible controller (VGA)             
    ...
      Driver: "nouveau"
    ...
      Driver Info #1:
        Driver Status: nouveau is active
        Driver Activation Cmd: "modprobe nouveau"
    ...
    Donc, installe le pilote nvidia pour une meilleure performance. Ouvre un terminal et tape ces commandes:

    Code:
    su -l
    zypper ar ftp://download.nvidia.com/opensuse/12.1/  nvidia
    zypper refresh
    zypper install x11-video-nvidiaG02
    * à la deuxième ligne, il y a un expace avant "nvidia" !

    Ensuite, tu rebootes. Ça devrait aller mieux.
    Lorsque tu es en Gnome Shell, clique sur "Activities" en haut à gauche. Ça affiche la barre d'activité avec les icônes des applications ouvertes. Pour créer un raccourci dans la barre pour une application, right cick sur l'icône de cette application et "Add to Favorites". Enfin, tu vois ce que je veux dire.

  10. #10

    Default Re: Tout nouveau avec linux

    Quote Originally Posted by please_try_again View Post
    "Un bon guerrier n'a pas d'habitude" . comme disait Castaneda. Cela dit, tu n'es pas si nouveau que ça avec Linux.
    Si, je débute quand même pas mal, surtout sur une version desktop.

    Quote Originally Posted by please_try_again View Post
    Oui, il me semblait aussi que /etc/resolv.conf n'était plus effacé depuis un certain temps. Ils ont dû changé un truc. Si tu as un autre Linux, tape la commande "dig". Ça devrait te donner le nom et le temps de réponse de ton DNS (donc celui de ton provider). Ajoute ce DNS en première position de /etc/resolv.conf. Il est probablement plus rapide ... Enfin tu peux le savoir en appliquant la commande "dig" à chaque DNS.
    Je n'ai pas d'autre Linux, il n'y a pas une manip sous windows 7 ?

    Quote Originally Posted by please_try_again View Post
    J'adhère. Tu as le fallback ou le Gnome shell avec le pilote "nouveau"? Bon, tu verras quand tu auras changé le pilote (lire la suite).
    Au début je comptais installer Kubuntu (KDE, donc), après j'ai hésité avec Ubuntu (Gnome), et puis après j'ai hésité entre Fedora et SuSE, j'ai opté pour SuSE, car on m'a dit qu'il y avait plus d'utilitaires de developpement, style mono et Qt. Enfin bref, booterais sur OpenSuSE ce soir pour essayer tes manips et je te tiendrais au courant.

    Merci

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •