Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Can't reach internet directly, can via ssh to another 'puter on my net.

  1. #1
    josephkk NNTP User

    Default Can't reach internet directly, can via ssh to another 'puter on my net.

    Problem box:
    Has 2 realtek rtl8168/8111 gigabit nic on mainboard (yes, that troubled
    one), added an Intel gigabit nic. Connect (cable) only Intel nic.
    Cannot see outside my net, no ping, nothing. This is a fresh install of
    OS 11.4 LXDE.

    Can ping and ssh local machines. I can browse the internet with ssh to
    firefox on another machine.

    I have rebooted my router (WRVS4400N) and updated its DHCP assignment
    tables. No change.

    Any ideas on what is going on?

    ?-)

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    5,305
    Blog Entries
    3

    Default Re: Can't reach internet directly, can via ssh to another 'puter on my net.

    Your problem is that you don't have a default route.

    This will probably work:

    Yast --> Network Devices --> Network Settings

    Select the realtek adaptor. Click on EDIT. Go to the "General" tab.

    Look at the selections for "Activate Device". It is probably set to "At Boot Time" or similar. Change that to "On Cable Connect."

    Do the same for your Intel adapter.

    Explanation. You have multiple adapters. The standard network setup is to give a default route to one of those adapters, and only a local LAN route to the others. When you have the realtek configured at boot time, it gets the default route. Since you aren't actually using that, the default route doesn't work. By switching to "cable connect" a default route will not be assigned until a connected cable is found. The default route will go to the first device found with a connected cable.

    At least, that seems to be how it works, based on my experience. Give it a try and see if it helps.
    opensuse factory; KDE 4.14.1 (main desktop);
    opensuse 13.1, KDE 4.11.5 (laptop);

  3. #3
    josephkk NNTP User

    Default Re: Can't reach internet directly, can via ssh to another 'puter on my net.

    On Sat, 28 Jan 2012 20:56:03 GMT, nrickert
    <nrickert@no-mx.forums.opensuse.org> wrote:

    >
    >Look at the selections for "Activate Device". It is probably set to
    >"At Boot Time" or similar. Change that to "On Cable Connect."
    >
    >Do the same for your Intel adapter.


    Did that for all adapters. Rebooted. Only the Intel has a cable at
    reboot. No change. R&R cable, still no change.

    Sounded reasonable. I tried deconfiguring the realtek adapters as well.
    No help.

    Any other contributions, anybody?

    ?-)

  4. #4
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,743

    Default Re: Can't reach internet directly, can via ssh to another 'puter on my net.

    Quote Originally Posted by josephkk View Post
    Problem box:
    Has 2 realtek rtl8168/8111 gigabit nic on mainboard (yes, that troubled
    one), added an Intel gigabit nic. Connect (cable) only Intel nic.
    Cannot see outside my net, no ping, nothing. This is a fresh install of
    OS 11.4 LXDE.

    Can ping and ssh local machines. I can browse the internet with ssh to
    firefox on another machine.

    I have rebooted my router (WRVS4400N) and updated its DHCP assignment
    tables. No change.

    Any ideas on what is going on?

    ?-)
    Most likely your default gateway is incorrectly set up. Check with
    Code:
    /sbin/route -n
    or
    Code:
    ip route
    or compare outputs from
    Code:
    traceroute 8.8.8.8
    from the machine that internet doesn't work and the machine from which you run firefox with ssh.

    Best regards,
    Greg
    Best regards,
    Greg
    Box: Windows 7 / Windows XP | Intel Dual-Core E5200 | ATI Radeon HD4850 | 4GB RAM
    Lap: openSUSE 12.3 / Windows 7 | Intel U7300 | KDE | Intel GMA 4500 | Asus UL80A | 3GB RAM

  5. #5
    josephkk NNTP User

    Default Re: Can't reach internet directly, can via ssh to another 'puter on my net.

    On Mon, 30 Jan 2012 07:56:02 GMT, glistwan
    <glistwan@no-mx.forums.opensuse.org> wrote:

    >
    >josephkk;2435001 Wrote:
    >> Problem box:
    >> Has 2 realtek rtl8168/8111 gigabit nic on mainboard (yes, that troubled
    >> one), added an Intel gigabit nic. Connect (cable) only Intel nic.
    >> Cannot see outside my net, no ping, nothing. This is a fresh install
    >> of
    >> OS 11.4 LXDE.
    >>
    >> Can ping and ssh local machines. I can browse the internet with ssh to
    >> firefox on another machine.
    >>
    >> I have rebooted my router (WRVS4400N) and updated its DHCP assignment
    >> tables. No change.
    >>
    >> Any ideas on what is going on?
    >>
    >> ?-)

    >Most likely your default gateway is incorrectly set up. Check with
    >
    >Code:
    >--------------------
    > /sbin/route -n
    >--------------------
    >
    >or
    >
    >Code:
    >--------------------
    > ip route
    >--------------------
    >
    >or compare outputs from
    >
    >Code:
    >--------------------
    > traceroute 8.8.8.8
    >--------------------
    > from the machine that internet doesn't work and the machine from which
    >you run firefox with ssh.
    >
    >Best regards,
    >Greg


    On the bad machine the only visible NIC is eth1, the others (mainboard
    realtek rtl8111/8169) are de-configured.

    Bad machine results:

    /sbin/route -n
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use
    Iface
    192.168.0.0 0.0.0.0 255.255.254.0 U 0 0 0
    eth1
    169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0
    eth1
    127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo

    ip route
    192.168.0.0/23 dev eth1 proto kernel scope link src 192.168.1.120
    169.254.0.0/16 dev eth1 scope link
    127.0.0.0/8 dev lo scope link

    /sbin/traceroute
    traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 40 byte packets using UDP

    and an error message of no network, sorry i didn't capture it.

    Good machine has two configured NICs, i don't remember the make/model.

    Good machine results:

    /sbin/route -n
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use
    Iface
    192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0
    eth0
    192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0
    eth1
    169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0
    eth0
    192.168.0.0 0.0.0.0 255.255.0.0 U 0 0 0
    eth0
    127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
    0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0
    eth0

    ip route
    192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.111
    192.168.1.0/24 dev eth1 proto kernel scope link src 192.168.1.112
    169.254.0.0/16 dev eth0 scope link
    192.168.0.0/16 dev eth0 proto kernel scope link src 192.168.1.102
    127.0.0.0/8 dev lo scope link
    default via 192.168.1.1 dev eth0

    /sbin/traceroute
    traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 40 byte packets using UDP
    1 WRVS4400N-Cisco-linksys (192.168.1.1) 1.307 ms 0.717 ms 0.666 ms
    2 SpeedStream5100-DSL-modem (192.168.0.1) 1.555 ms 1.290 ms 1.782
    ms
    3 bras1-l0.scrm01.sbcglobal.net (151.164.185.12) 11.215 ms 10.257 ms
    9.681 ms
    4 dist1-vlan50.scrm01.pbi.net (64.171.152.66) 11.077 ms 9.394 ms
    9.397 ms
    5 151.164.93.212 (151.164.93.212) 8.881 ms 10.830 ms 8.231 ms
    6 12.122.114.21 (12.122.114.21) 12.035 ms 14.367 ms 12.422 ms
    7 12.249.231.14 (12.249.231.14) 63.112 ms 64.238 ms 63.046 ms
    8 64.233.175.223 (64.233.175.223) 13.639 ms 13.127 ms 12.849 ms
    9 google-public-dns-a.google.com (8.8.8.8) 12.369 ms 13.751 ms 12.953
    ms

    ==================================

    OK i am seeing some differences. How do i set the default gateway
    (192.168.1.1 it seems).?

    ?-)

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    22,779

    Default Re: Can't reach internet directly, can via ssh to another 'puteron my net.

    On 2012-02-02 04:44, josephkk wrote:

    > Bad machine results:


    Please use code tags to post computer text.

    Code:
    
    >
    > /sbin/route -n
    > Kernel IP routing table
    > Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    > 192.168.0.0     0.0.0.0         255.255.254.0   U     0      0        0 eth1
    > 169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 eth1
    > 127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
    You don't have defined a default gateway. A line that starts with 0.0.0.0

    >
    > OK i am seeing some differences. How do i set the default gateway
    > (192.168.1.1 it seems).?


    You are using DHCP. Revise the configuration of your router, it should tell
    your computer the correct gateway to write. If that fails, use manual
    configuration of your computer, not automatic, and define the values.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  7. #7
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,743

    Default Re: Can't reach internet directly, can via ssh to another 'puteron my net.

    To manually add default gateway You can use this command :
    Code:
    # /sbin/route add default gw 192.168.1.1 eth1
    and You should immediately get internet access. To make it permanent do as Carlos says. You can configure static IP addressing using YaST or NetworkManager applet You're using. Anyway the best solution IMHO would be to figure out why You don't get the default gateway from DHCP.

    Best regards,
    Greg
    Best regards,
    Greg
    Box: Windows 7 / Windows XP | Intel Dual-Core E5200 | ATI Radeon HD4850 | 4GB RAM
    Lap: openSUSE 12.3 / Windows 7 | Intel U7300 | KDE | Intel GMA 4500 | Asus UL80A | 3GB RAM

  8. #8

    Default Re: Can't reach internet directly, can via ssh to another 'puteron my net.

    Hi... I have two of those realtek nics that I just upgraded to (gigabit adapters). What I noticed is that DHCP did not like them. However, the drivers are fine. Many of the stories I read about them talked about the driver... they are fine. You will have to enable them at boot, set them to ethernet just below that (in a dropdown), set your default gateway and DNS to the router IP, I believe enable IP forwarding (if I'm not mistaken), and if necessary switch to KNetworkManager then back to ifup (seemed to stimulate them). I am running iSCSI, internet, and updater. I have all three nics connected (2 8111's) and an onboard 10/100. One card was claimed by iSCSI, the other by updater/the system, and the last was issued to surfing. Works great!

  9. #9

    Default Re: Can't reach internet directly, can via ssh to another 'puteron my net.

    Also, I disabled IPV6 addressing. Some hardware isn't equipped to handle it, so I was just being on the safe wide. And, I know it shouldn't matter, but before you set them to static, set the DHCP to IPV4 only, then to static. I noticed the system card throwing IPV6 address even after the main IPV6 addressing was disabled... (but the greyed out DHCP setting said 'both 4 & 6' ... the only thing that could have stated it was ok to do. It was kind of like a redundancy thing, I guess.

    So, with so many variables in the settings, it's easy to not have everything just right. It's not the cards, or driver!! :-)

  10. #10
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,381

    Default Re: Can't reach internet directly, can via ssh to another 'puteron my net.

    On 02/03/2012 01:46 AM, surgie2 wrote:
    >
    > Also, I disabled IPV6 addressing. Some hardware isn't equipped to handle
    > it, so I was just being on the safe wide. And, I know it shouldn't
    > matter, but before you set them to static, set the DHCP to IPV4 only,
    > then to static. I noticed the system card throwing IPV6 address even
    > after the main IPV6 addressing was disabled... (but the greyed out DHCP
    > setting said 'both 4& 6' ... the only thing that could have stated it
    > was ok to do. It was kind of like a redundancy thing, I guess.
    >
    > So, with so many variables in the settings, it's easy to not have
    > everything just right. It's not the cards, or driver!! :-)


    Be careful before following this advice, which I consider to be wrong.

    All HARDWARE can handle IPv6. To the hardware, it is just a string of bits. In
    addition, everything in later versions of openSUSE is fully IPv6 compatible.
    Anyone that is having trouble has a brain-dead ISP whose DNS servers claim to
    support IPv6 and then fail to do so correctly! That causes the timeouts on every
    DNS lookup.

    To me, the correct way to solve the problem is to edit /etc/resolv.conf and
    change the nameserver entries to 8.8.8.8 and 8.8.4.4, or some other public name
    server site. The ones I quote above are Google's public servers.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •