Results 1 to 6 of 6

Thread: Echo Amarok

  1. #1

    Default Echo Amarok

    Hi all

    After my box being in storage for a few months, when I set it back up I stupidly selected kpackage updates thinking my existing stable system 11.4, Kde 4 would be fine.

    Result - Firefox unstable - but now fixed. but now major issues with sound.

    Amarok - very poor sound, vocals have heavy echo, and over powered by instruments. Pulseaudio is installed and I can't recall this being on my system originally. The backend preference as either gstreamer, xine makes no difference.

    Repos are:

    # | Alias | Name | Enabled | Refresh
    --+-------------------+-----------------------+---------+--------
    1 | KDE:Extra | KDE:Extra | Yes | No
    2 | libdvdcss | libdvdcss | Yes | Yes
    3 | packman | packman | Yes | Yes
    4 | repo-11.4-non-oss | openSUSE-11.4 Non-OSS | Yes | No
    5 | repo-11.4-oss | openSUSE-11.4 OSS | Yes | No
    6 | repo-11.4-update | openSUSE-11.4 Updates | Yes | No

    all repos are upto date via MMCheck. I have not enabled refresh on 4-6 due to existing issues. On the other MMCHECKs all appears fine in terms of the audio checks, except for xine-ui is coming from Opensuse and not as recommended from packman. I have uninstalled xine-ui and zypperd in packman xine-ui but it doesn't pick this up and instead goes to opensuse. Ditto in yast. no xine-ui in packman.

    I also have libavcodec53 and libavdevice53 installed - alongside the 52 version. MMCHECK picks this up as an issue. I am hesitant about removing these as

    zypper rm libavcodec53 ...

    The following packages are going to be REMOVED:
    ffmpeg libavcodec53 libavdevice53 libavfilter2 libavformat53 libopencv2_3 libxine1-codecs
    phonon-backend-vlc vlc vlc-mozillaplugin vlc-noX vlc-qt

    The following package is going to be downgraded:
    sox

    The following package is going to change vendor:
    sox PackMan :: Startseite -> openSUSE

    1 package to downgrade, 12 to remove, 1 to change vendor.
    Overall download size: 362.0 KiB. After the operation, 55.9 MiB will be freed.
    Continue? [y/n/p/?] (y): n

    This doesn't look like a good way to go unless advised otherwise.

    I have thought about reinstalling amarok but sound issue also in Kplayer for CD's and VLC so obviously issue with codecs somewhere.

    Any help appreciated. Frustrated as system was working perfectly before update.

    sorry for the length of this probably something really obvious and simple. I hope.

    thank Ben

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,500
    Blog Entries
    48

    Smile Re: Echo Amarok

    Quote Originally Posted by waveheadwales View Post
    Hi all

    After my box being in storage for a few months, when I set it back up I stupidly selected kpackage updates thinking my existing stable system 11.4, Kde 4 would be fine.

    Result - Firefox unstable - but now fixed. but now major issues with sound.

    Amarok - very poor sound, vocals have heavy echo, and over powered by instruments. Pulseaudio is installed and I can't recall this being on my system originally. The backend preference as either gstreamer, xine makes no difference.

    Repos are:

    # | Alias | Name | Enabled | Refresh
    --+-------------------+-----------------------+---------+--------
    1 | KDE:Extra | KDE:Extra | Yes | No
    2 | libdvdcss | libdvdcss | Yes | Yes
    3 | packman | packman | Yes | Yes
    4 | repo-11.4-non-oss | openSUSE-11.4 Non-OSS | Yes | No
    5 | repo-11.4-oss | openSUSE-11.4 OSS | Yes | No
    6 | repo-11.4-update | openSUSE-11.4 Updates | Yes | No

    all repos are upto date via MMCheck. I have not enabled refresh on 4-6 due to existing issues. On the other MMCHECKs all appears fine in terms of the audio checks, except for xine-ui is coming from Opensuse and not as recommended from packman. I have uninstalled xine-ui and zypperd in packman xine-ui but it doesn't pick this up and instead goes to opensuse. Ditto in yast. no xine-ui in packman.

    I also have libavcodec53 and libavdevice53 installed - alongside the 52 version. MMCHECK picks this up as an issue. I am hesitant about removing these as

    zypper rm libavcodec53 ...

    The following packages are going to be REMOVED:
    ffmpeg libavcodec53 libavdevice53 libavfilter2 libavformat53 libopencv2_3 libxine1-codecs
    phonon-backend-vlc vlc vlc-mozillaplugin vlc-noX vlc-qt

    The following package is going to be downgraded:
    sox

    The following package is going to change vendor:
    sox PackMan :: Startseite -> openSUSE

    1 package to downgrade, 12 to remove, 1 to change vendor.
    Overall download size: 362.0 KiB. After the operation, 55.9 MiB will be freed.
    Continue? [y/n/p/?] (y): n

    This doesn't look like a good way to go unless advised otherwise.

    I have thought about reinstalling amarok but sound issue also in Kplayer for CD's and VLC so obviously issue with codecs somewhere.

    Any help appreciated. Frustrated as system was working perfectly before update.

    sorry for the length of this probably something really obvious and simple. I hope.

    thank Ben
    Not sure what has happened to you but openSUSE 11.4 always had Pulse Audio installed. You can try a few more things:

    1) Now consider that you can just disable Pulse, no need to remove it just in case.

    Code:
    sudo setup-pulseaudio --disable
    2) Even with Pulse running, you can get Kmix to give back alsa control by:

    Code:
    Add the this line to your ~/.bashrc
    
    export KMIX_PULSEAUDIO_DISABLE=1
    3) Place Xine Ahead of Gstremer as your Backend in Menu / Personnel Settings / Multimedia / Phonon / Backend

    See if these suggestions might help.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    37,194
    Blog Entries
    17

    Default Re: Echo Amarok

    13.2_Laptop_Spec
    My Articles
    Was I any help? If yes: Click the star below

  4. #4
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,934
    Blog Entries
    30

    Default Re: Echo Amarok

    Quote Originally Posted by waveheadwales View Post
    Amarok - very poor sound, vocals have heavy echo, and over powered by instruments. Pulseaudio is installed and I can't recall this being on my system originally. The backend preference as either gstreamer, xine makes no difference.
    For KDE users, pulse audio was introduced starting with openSUSE-11.4 , I believe.

    I find a couple of applications can be very useful in tuning pulse audio. One is pulse audio volume control (pavucontrol) which KDE users need to install from the official OSS repository. Ensure that one has SHOW all Output Devices (in the Output Device Tab) selected and has SHOW all streams (in the Playback Tab) selected.

    pavucontrol Configuration Tab


    pavucontrol Output Devices Tab


    pavucontrol Playback Tab playing audio from Amarok and also (Virtual Box) in this example


    The other application is a system wide equalizer that one can download from Packman repository called 'pulseaudio-equalizer'. The packman link noting their packaging is here: PackMan :: Informationen zum Paket pulseaudio-equalizer and an example of the GUI is here:

  5. #5

    Default Re: Echo Amarok

    Hi guys, thanks for this. I tried:

    James' approach and run the disable command and .bashrc edit .... no joy.
    I also refreshed the Update repo and did the switch from system to packman as per Caf.

    I also think I restored pulseaudio by enable command and removed bashrc edit as well.

    A load of updates from pacman loaded in today. Something sorted it there :-)

    Sound now fixed... wife no longer complaining that Windows is better...

    thanks all :-)

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    37,194
    Blog Entries
    17

    Default Re: Echo Amarok

    Quote Originally Posted by waveheadwales View Post
    Hi guys, thanks for this. I tried:

    James' approach and run the disable command and .bashrc edit .... no joy.
    I also refreshed the Update repo and did the switch from system to packman as per Caf.

    I also think I restored pulseaudio by enable command and removed bashrc edit as well.

    A load of updates from pacman loaded in today. Something sorted it there :-)

    Sound now fixed... wife no longer complaining that Windows is better...

    thanks all :-)
    Good to hear
    Well done
    13.2_Laptop_Spec
    My Articles
    Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •