Results 1 to 3 of 3

Thread: ALSA Default Device

  1. #1

    Default ALSA Default Device

    So I was running into a few issues after doing an DUP to 12.1, this was the third or 4th update I did like that and I just kept running into annoyance to the point I decided to start fresh. With that being said I am getting my sound setup like I want, which has always been a pain since I use digital passthrough (coax connection) and pulse audio has never handled it correctly. So once again no shock couldnt get pulse working, so I uninstalled it and went back to the good old alsa. Now I am running into some issues, but for the time being I have xine working properly, but defaulting everything is where I want to get to.

    Code:
    baaldesk:~> aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: CMI8768 [C-Media CMI8768], device 0: CMI8738-MC8 [C-Media PCI DAC/ADC]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: CMI8768 [C-Media CMI8768], device 1: CMI8738-MC8 [C-Media PCI 2nd DAC]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: CMI8768 [C-Media CMI8768], device 2: CMI8738-MC8 [C-Media PCI IEC958]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    Code:
    baaldesk:~> aplay -L
    null
        Discard all samples (playback) or generate zero samples (capture)
    pulse
        PulseAudio Sound Server
    sysdefault:CARD=CMI8768
        C-Media CMI8768, C-Media PCI DAC/ADC
        Default Audio Device
    front:CARD=CMI8768,DEV=0
        C-Media CMI8768, C-Media PCI DAC/ADC
        Front speakers
    rear:CARD=CMI8768,DEV=0
        C-Media CMI8768, C-Media PCI 2nd DAC
        Rear speakers
    surround40:CARD=CMI8768,DEV=0
        C-Media CMI8768, C-Media PCI 2nd DAC
        4.0 Surround output to Front and Rear speakers
    surround41:CARD=CMI8768,DEV=0
        C-Media CMI8768, C-Media PCI 2nd DAC
        4.1 Surround output to Front, Rear and Subwoofer speakers
    surround50:CARD=CMI8768,DEV=0
        C-Media CMI8768, C-Media PCI 2nd DAC
        5.0 Surround output to Front, Center and Rear speakers
    surround51:CARD=CMI8768,DEV=0
        C-Media CMI8768, C-Media PCI 2nd DAC
        5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    surround71:CARD=CMI8768,DEV=0
        C-Media CMI8768, C-Media PCI 2nd DAC
        7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    iec958:CARD=CMI8768,DEV=0
        C-Media CMI8768, C-Media PCI DAC/ADC
        IEC958 (S/PDIF) Digital Audio Output
    So from 11.3 and on, including my 12.1 system before I went with a fresh install i was able to use hw:0,2 to play through my coax, which shouldnt have changed because that is hardware specific but it has. I test this with a surround file using aplay -D hw:0,2 which no longer pushes the audio through the coax on the card (additionally selecting hw:0,0 or hw:0,1 has the same effect), however I can still use iec958:CARD=CMI8768,DEV=0 which is how I got xine working. But that doesn't default everything, so before this I created an /etc/asound.conf file and gave a default

    Code:
    pcm.!default{
            type hw
            card 0
            device 2 
    }
    But with that not playing through the coax I can no longer do that. In kde under Configure Desktop->Multimedia->Phonon->Audio Playback I have setup C-Media CMI8768, C-Media PCI DAC/ADC (IEC958(S/PDIF) Digial Audio Output) as the primary under all playback options, and under the backend I have xine selected as the default.

    Im coming here first, though if you think this would be better in an alsa forum I can go pose the question somewhere else. I know it works under 12.1, because I had it working, but cant for the life of me get it to work now. Any help would be much appreciated.

    Thanks

  2. #2

    Default Re: ALSA Default Device

    Alright so Ive managed to resolve this myself and figured I would post what I had to do to get things working.

    So based on some site I found it showed my default config should look like:
    Code:
    pcm.!default iec958:CMI8768
    However that didnt work, and removed the one option from the multimedia->phonon settings that actually outputted through my digital out. So I tweaked it to include the device to be

    Code:
    pcm.!default iec958:CMI8768,0
    With that change in place I lost all of the devices listed under multimedia->phonon except for ALSA Default and OSS Default, however the ALSA default is now my digital output so it works as I want.

  3. #3
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,500
    Blog Entries
    48

    Smile Re: ALSA Default Device

    Happy to hear you got your setup working baaldemon and interesting to hear what you did.

    1) Now consider that you can just disable Pulse, no need to remove it just in case.

    Code:
    sudo setup-pulseaudio --disable
    2) Even with Pulse running, you can get Kmix to give back alsa control by:

    Code:
    Add the this line to your ~/.bashrc
    
    export KMIX_PULSEAUDIO_DISABLE=1
    Now I have two PC's that use Digital Audio, both are Optical connections to (separate) receivers. On PC1, I have a very old Creative Audigy Card with I/O card and using only option two, leaving Pulse enabled allowed me to use Xine in playing AC3 audio for DVD's and standard stereo for everything else using Pulse. In PC2, I had to also disable Pulse as well using both options, and place Xine above Gstremer as my Backend to get it to work the same with an Creative X-Fi sound card. I use Kaffeine-KDE3 for DVD playback on both PC's but VLC works OK as well. In normal mode I set the receivers for multi-stereo mode, meaning all left speakers play left and all right speakers play right and the center channel is mono, all a function of the receiver and not my PC setup. Playing CD's really kick butt with lots of sound and full Dolby Digital with movies, even in ES on one receiver. Just so you know you are not the only one trying to make this work. PC2 has a C-Media audio chip built-in and it worked fine for movies, but I could never get Totem to work with it for some reason. I use Totem to play iTunes movie trailers on this second PC as its my HTPC in the living room. When I switched to the Creative X-Fi card, I could get everything to work right.

    Thank You,
    Last edited by jdmcdaniel3; 03-Jan-2012 at 19:48.
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •