Results 1 to 6 of 6

Thread: Wireless Problems after upgrade to 12.1

  1. #1

    Default Wireless Problems after upgrade to 12.1

    Hi everyone. I just updated my opensuse installation to 12.1 and I gotta say I already like it. Most of the things are working immediatly, however my wireless is somewhat more of a problem since its a broadcom.

    lspci gives the following:
    02:00.0 Network controller: Broadcom Corporation BCM43224 802.11a/b/g/n (rev 01)

    so i added the pacman repository and installed b43-firmware. Afterwards I ran some command in /usr/sbin to install the correct broadcom drivers (forgot the name). This completed succesfully. grepping dmesg for Broadcom gives

    [ 18.377104] b43-phy1: Broadcom 43224 WLAN found (core revision 23)
    [ 18.380488] Broadcom 43xx driver loaded [ Features: PMNLS, Firmware-ID: FW13 ]

    When performing iwlist scan I get the following:
    lo Interface doesn't support scanning.

    eth0 Interface doesn't support scanning.

    wlan0 Interface doesn't support scanning : Network is down

    So i brought it up using ifconfig (however this should not be necessairy as I'm using network manager??) and it turns on my wireless led. iwscan than discovers my network. However a scan in networkmanager gives me nothing, however wlan0 now shows up in ifconfig
    wlan0 Link encap:Ethernet HWaddr C0:CB:38:77:ED:C5
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    Basically I think my hardware drivers are ok, but how do I get network manager to manage my wireless interface?

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,381

    Default Re: Wireless Problems after upgrade to 12.1

    On 11/21/2011 05:16 PM, Xeon vl wrote:
    >
    > Hi everyone. I just updated my opensuse installation to 12.1 and I gotta
    > say I already like it. Most of the things are working immediatly,
    > however my wireless is somewhat more of a problem since its a broadcom.
    >
    > lspci gives the following:
    > 02:00.0 Network controller: Broadcom Corporation BCM43224 802.11a/b/g/n
    > (rev 01)
    >
    > so i added the pacman repository and installed b43-firmware. Afterwards
    > I ran some command in /usr/sbin to install the correct broadcom drivers
    > (forgot the name). This completed succesfully. grepping dmesg for
    > Broadcom gives
    >
    > [ 18.377104] b43-phy1: Broadcom 43224 WLAN found (core revision 23)
    > [ 18.380488] Broadcom 43xx driver loaded [ Features: PMNLS,
    > Firmware-ID: FW13 ]
    >
    > When performing iwlist scan I get the following:
    > lo Interface doesn't support scanning.
    >
    > eth0 Interface doesn't support scanning.
    >
    > wlan0 Interface doesn't support scanning : Network is down
    >
    > So i brought it up using ifconfig (however this should not be
    > necessairy as I'm using network manager??) and it turns on my wireless
    > led. iwscan than discovers my network. However a scan in networkmanager
    > gives me nothing, however wlan0 now shows up in ifconfig
    > wlan0 Link encap:Ethernet HWaddr C0:CB:38:77:ED:C5
    > UP BROADCAST MULTICAST MTU:1500 Metric:1
    > RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    > TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    > collisions:0 txqueuelen:1000
    > RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    >
    > Basically I think my hardware drivers are ok, but how do I get network
    > manager to manage my wireless interface?


    If wlan0 is created, you have the firmware available - it was a result of that
    command in /usr/sbin. Fortunately, we know the one you mean, but please be a
    little more accurate in the future. It greatly helps us in debugging, and
    sometimes in repairing the damage done when you ran the wrong command.

    You need to install the rfkill package and then run the command
    '/usr/sbin/rfkill list'. You may have a "hard" block, which is due to your radio
    switch in the wrong position, or a "soft" block due to an incorrect wmi
    implementation.



  3. #3

    Default Re: Wireless Problems after upgrade to 12.1

    hi, Sorry, the command was several reboots away. Anyway it was /usr/sbin/install_bcm43xx_firmware

    I ran the rfkill it gave me the following:
    0: dell-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    1: phy1: Wireless LAN
    Soft blocked: no
    Hard blocked: no

    so it doesn't seem to be blocked...

    Also, after a boot, my wlan interface is down again until i start it with ifconfig so it doesn't seem to be coming up automatically :/

  4. #4
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,151

    Default Re: Wireless Problems after upgrade to 12.1

    My Wireless details are as follows
    Code:
    linux-x15t:~ # lspci -vnn | grep 14e4
    06:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
    linux-x15t:~ #
    
    linux-x15t:~ # lspci -vnn | grep brcmsmac
            Kernel driver in use: brcmsmac
    linux-x15t:~ #
    I renamed directory /home/myname/.kde4 to /home/myname/x.kde4.

    After powering down and doing a cold boot the wireless network connected without intervention.

    All appears now to be in order.

  5. #5
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,381

    Default Re: Wireless Problems after upgrade to 12.1

    On 11/22/2011 09:56 AM, Xeon vl wrote:

    > so it doesn't seem to be blocked...


    Good.

    > Also, after a boot, my wlan interface is down again until i start it
    > with ifconfig so it doesn't seem to be coming up automatically :/


    That indicates that you are using ifup. If so, check the "STARTMODE=" line in
    directory /etc/sysconfig/network/ and file ifcfg-eth0. That should have
    "ifplugd". In the ifcfg-wlan0 file in the same directory, the STARTMODE should
    be "auto". Those changes will start rth0 if the wire is plugged in, and wlan0 if
    not.

  6. #6

    Default Re: Wireless Problems after upgrade to 12.1

    Yast indicated i'm not using ifplugd but the networkmanager.
    STARTMODE of eth0 is onboot, STARTMODE of wlan0 is ifplugd. I changed it to 'auto' for wlan0 and disconnected the cable. After a reboot the interface is still down

    I got rid of my entire kde profile. This brought back the networkmanager icon to the system tray, and I was able to enable the interface and configure networks. Seems it's solved now, thx!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •