Results 1 to 6 of 6

Thread: Howto question: prevent Linux (or KDE) from changing the clock for daylight savings time

  1. #1

    Default Howto question: prevent Linux (or KDE) from changing the clock for daylight savings time

    Running 11.2 with KDE. I multiboot so I don't want ANY of the partitions changing the clock for daylight savings time. I can do it myself and know when/if it's done, thank you very much. This change, I made what turned out to be the MISTAKE of allowing opensuse 11.2 to be running during the change and the clock got changed. Well, "fool me once, shame on me". I can't find a configuration setting to control daylight savings time. What I want to do is set Linux/KDE so it DOES NOT change the clock. Can someone tell me where it is?

  2. #2
    Join Date
    Oct 2008
    Location
    near Munich
    Posts
    514

    Default Re: Howto question: prevent Linux (or KDE) from changing the clock for daylight savings time

    Maybe you can set the hardware clock to UTC. This way the hardware clock is
    not changed for daylight saving time.

    Linux supports this (can be configured in Yast) and looks like Windows
    supports it:
    http://weblogs.asp.net/dfindley/arch...ware-clock-to-
    UTC-on-Windows-_2800_or-how-to-make-the-clock-work-on-a-Mac-Book-
    Pro_2900_.aspx

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    21,630

    Default Re: Howto question: prevent Linux (or KDE) from changing the clockfor daylight savings time

    On 2011-11-06 11:06, nospam990 wrote:
    >
    > Running 11.2 with KDE.


    Then ask in the BETA forum.

    I'll answer guessing it behaves like any stable openSUSE.

    > I multiboot so I don't want ANY of the
    > partitions changing the clock for daylight savings time. I can do it
    > myself and know when/if it's done, thank you very much. This change, I
    > made what turned out to be the MISTAKE of allowing opensuse 11.2 to be
    > running during the change and the clock got changed. Well, "fool me
    > once, shame on me". I can't find a configuration setting to control
    > daylight savings time. What I want to do is set Linux/KDE so it DOES
    > NOT change the clock. Can someone tell me where it is?


    You can not find it because Linux DOES NOT change the clock.

    Linux runs internally in what "looks" like UTC, Universal Time Coordinated.
    Then it uses tables to convert the time to local time for displaying
    whatever is the correct local time for each user. If the locale specifies
    that there is a daylight time change to apply, it is applied for that user
    for display only. The real clock does not change.

    If the locale change is incorrect, like happening in the wrong day, or in a
    country that does not have it, then it is a bug you have to report, with
    proofs, on bugzilla.


    Now, there is another clock in the system, the CMOS clock. This clock can
    be set to run using local time or UTC time. Your mistake was telling it to
    use local time, which is adjusted. Change it. Yast.

    However, if one of your systems is Windows, use local time, and on daylight
    change, live with it and change the clocks back. Or use UTC and adjust
    windows instead. Several linux systems can live together if the cmos clock
    uses UTC time, but with windows in the mixture it is not possible. If local
    time is used there, hell breaks loose.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    4,819
    Blog Entries
    3

    Default Re: Howto question: prevent Linux (or KDE) from changing the clock for daylight savings time

    Quote Originally Posted by nospam990 View Post
    Running 11.2 with KDE. I multiboot so I don't want ANY of the partitions changing the clock for daylight savings time.
    If you are multibooting with Windows, and your Windows versions are Vista or Windows 7, then try setting the cmos clock to UTC. For a guide on how to do that, see BIOS clock setup with dual boot
    opensuse factory; KDE 4.13.80 (main desktop);
    opensuse 13.1, KDE 4.11.5 (laptop);

  5. #5
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,017

    Default Re: Howto question: prevent Linux (or KDE) from changing the clock for daylight savings time

    If you set the hardware clock to UTC, daylight saving is automatically enabled because the time that appears on screen is the locale time which supports daylight saving where appropriate.

    If you do not want Linux to handle the daylight saving, leave the hardware clock to the locale setting. What happens will then depend on whatever OS you have installed. If, on a dual-boot Windows machine, Windows changes the hardware clock then the change will appear in Linux. You may have to check the appropriate combinations for the OS you are running.

  6. #6
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    11,210

    Default Re: Howto question: prevent Linux (or KDE) from changing the clockfor daylight savings time

    On 11/06/2011 11:06 AM, nospam990 wrote:
    >
    > Running 11.2 with KDE.


    11.2 past its end of life already (cite: http://en.opensuse.org/Lifetime
    ) and you should either upgrade to a supported version or alternatively
    join project Evergreen http://tinyurl.com/4aflkpy and join the mail list
    listed on that page for your support questions..

    --
    DD
    http://tinyurl.com/DD-Caveat
    openSUSE®, the "German Automobiles" of operating systems

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •