Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Error 23 at boot: Error while parsing number

  1. #1

    Default Error 23 at boot: Error while parsing number

    dear helping hand,

    since two days i notice an error (error 23) at boot which forces me to start up in Failsafe mode (desktop mode does no longer work)
    Fortunately the failsafe mode lets me do most or all the things i normally do, however, i'd like to have thigs running without errors if possible...

    just before the error appeared I had installed the qt UI for Gnome's Yast, becasue the gtk one got me stuck without possibilty of confirming a necessary confirmation screen for upgrades/downloads/replacement.

    The install seemed to go wrong (error message at final install: System management is blocked by app. id.8780 (YAST2/bin/y2base (dutch: Systeembeheer is geblokkeerd door de applicatie met pid 8780 (/usr/lib/YaST2/bin/y2base)
    However, afterwards the QT UI seemed to be succesfully installed.

    Also, i have been running an external HardDisk with a RAID option/function, for some time prior to the appearance of Error 23.

    I tried running YAST-> System -> bootloader (with the Desktop mode set to default.)
    It seemed to (re)install the bootloader, but had no effect on the error last time i checked.

    Thanks for your help

    Tom

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    22,450

    Default Re: Error 23 at boot: Error while parsing number

    On 2011-10-19 23:46, tmoonen wrote:
    >
    > dear helping hand,
    >
    > since two days i notice an error (error 23) at boot which forces me to
    > start up in Failsafe mode (desktop mode does no longer work)


    23 : Error while parsing number
    This error is returned if GRUB was expecting to read a number and
    encountered bad data.

    You have to edit /boot/grub/menu.lst and correct the error.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  3. #3

    Default Re: Error 23 at boot: Error while parsing number

    Quote Originally Posted by robin_listas View Post
    On 2011-10-19 23:46, tmoonen wrote:[color=blue]


    23 : Error while parsing number
    This error is returned if GRUB was expecting to read a number and
    encountered bad data.

    You have to edit /boot/grub/menu.lst and correct the error.

    (from 11.4 x86_64 "Celadon" at Telcontar)
    Thanks Carlos

    I found the file, made a copy and opened it to study, but i don't know what to change.
    it's printed below.
    When booting was going a status message ' did not succeed in making an image for next boot' was shown. I didn't note it down as i had activated a boot logger just before... couldn't find this message though in the bootlog (which i could not attached due to forum policy). I'll take note next boot.

    Please tell me if you see anything obviously wrong, so i could correct it.
    Thanks again!
    Tom


    # Modified by YaST2. Last modification on wo okt 19 23:46:07 CEST 2011
    # THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
    # Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

    default 0
    timeout 5
    ##YaST - generic_mbr
    gfxmenu (hd0,1)/boot/message
    ##YaST - activate

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title Desktop -- openSUSE 11.4 - 2.6.37.6-0.7
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.37.6-0.7-desktop root=/dev/disk/by-id/ata-HTS541080G9AT00_MP28XBXBH2WZES-part2 devfs=mount,dall resume=/dev/disk/by-id/ata-HTS541080G9AT00_MP28XBXBH2WZES-part1 splash=silent quiet showopts vga=none
    initrd /boot/initrd-2.6.37.6-0.7-desktop

    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.4 - 2.6.37.6-0.7
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.37.6-0.7-desktop root=/dev/disk/by-id/ata-HTS541080G9AT00_MP28XBXBH2WZES-part2 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x31A
    initrd /boot/initrd-2.6.37.6-0.7-desktop

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    22,450

    Default Re: Error 23 at boot: Error while parsing number

    On 2011-10-20 17:56, tmoonen wrote:

    > I found the file, made a copy and opened it to study, but i don't know
    > what to change.
    > it's printed below.


    But you did not use code tags, so it makes it difficult to read.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  5. #5

    Default Bootlog Re: Error 23 at boot: Error while parsing number

    a link too my bootlog: (too big to fit on the blog):
    https://docs.google.com/document/d/1.../edit?hl=en_US

    will put the above message within codeblocks next...
    Last edited by tmoonen; 24-Oct-2011 at 12:30. Reason: url end tag missing

  6. #6

    Default Re: Error 23 at boot: Error while parsing number

    Quote Originally Posted by robin_listas View Post
    On 2011-10-19 23:46, tmoonen wrote:
    >
    > dear helping hand,
    >
    > since two days i notice an error (error 23) at boot which forces me to
    > start up in Failsafe mode (desktop mode does no longer work)


    23 : Error while parsing number
    This error is returned if GRUB was expecting to read a number and
    encountered bad data.

    You have to edit /boot/grub/menu.lst and correct the error.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)
    thanks again Carlos,

    here's the file, this time within CODE tags... please, anyone with the knowledge, tell me if you see anything that should be changed.
    Thanks!

    Code:
    # Modified by YaST2. Last modification on wo okt 19 23:46:07 CEST 2011
    # THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
    # Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader
    
    default 0
    timeout 5
    ##YaST - generic_mbr
    gfxmenu (hd0,1)/boot/message
    ##YaST - activate
    
    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title Desktop -- openSUSE 11.4 - 2.6.37.6-0.7
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.37.6-0.7-desktop root=/dev/disk/by-id/ata-HTS541080G9AT00_MP28XBXBH2WZES-part2 devfs=mount,dall resume=/dev/disk/by-id/ata-HTS541080G9AT00_MP28XBXBH2WZES-part1 splash=silent quiet showopts vga=none
    initrd /boot/initrd-2.6.37.6-0.7-desktop
    
    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.4 - 2.6.37.6-0.7
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.37.6-0.7-desktop root=/dev/disk/by-id/ata-HTS541080G9AT00_MP28XBXBH2WZES-part2 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x31A
    initrd /boot/initrd-2.6.37.6-0.7-desktop

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    14,054
    Blog Entries
    12

    Default Re: Error 23 at boot: Error while parsing number

    Could it be the "vga=none", AFAIK this should be 0xhex number, in your case (see Failsafe bootline) "vga=0x31a". Also AFAIK "vga=normal" is another non numeric option.

    Sorry, Carlos, if I gave away your secret...
    - Athlon X6 3.6 GHz, 16 GB DDR3, 30 GB SSD, 3 TB of disks, GT540, openSUSE 12.2 x86_64 + KDE 4.10 + GNOME 3
    - ASUS A73SD, Intel + GT610M Optimus, 6 GB, 120 GB SSD, openSUSE Tumbleweed

    Anything that can go wrong.... will teach us

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    22,450

    Default Re: Error 23 at boot: Error while parsing number

    On 2011-10-24 21:36, tmoonen wrote:

    > here's the file, this time within CODE tags... please, anyone with the
    > knowledge, tell me if you see anything that should be changed.
    > Thanks!
    >
    >
    > Code:
    > --------------------
    > # Modified by YaST2. Last modification on wo okt 19 23:46:07 CEST 2011
    > # THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
    > # Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader
    >
    > default 0
    > timeout 5
    > ##YaST - generic_mbr
    > gfxmenu (hd0,1)/boot/message
    > ##YaST - activate
    >
    > ###Don't change this comment - YaST2 identifier: Original name: linux###
    > title Desktop -- openSUSE 11.4 - 2.6.37.6-0.7
    > root (hd0,1)
    > kernel /boot/vmlinuz-2.6.37.6-0.7-desktop root=/dev/disk/by-id/ata-HTS541080G9AT00_MP28XBXBH2WZES-part2 devfs=mount,dall resume=/dev/disk/by-id/ata-HTS541080G9AT00_MP28XBXBH2WZES-part1 splash=silent quiet showopts vga=none
    > initrd /boot/initrd-2.6.37.6-0.7-desktop
    >
    > ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    > title Failsafe -- openSUSE 11.4 - 2.6.37.6-0.7
    > root (hd0,1)
    > kernel /boot/vmlinuz-2.6.37.6-0.7-desktop root=/dev/disk/by-id/ata-HTS541080G9AT00_MP28XBXBH2WZES-part2 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x31A
    > initrd /boot/initrd-2.6.37.6-0.7-desktop
    > --------------------


    The problem is that I do not see what could be causing that error 23.
    Unless there is another grub installed somewhere and this is the wrong file.

    The only strange thing is the "devfs=mount,dall" parameter. It's new for me.

    About the boot log, it is useless, because it comes from the failsafe
    entry. There is no problem there.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    22,450

    Default Re: Error 23 at boot: Error while parsing number

    On 2011-10-24 22:46, Knurpht wrote:
    >
    > Could it be the "vga=none", AFAIK this should be 0xhex number, in your
    > case (see Failsafe bootline) "vga=0x31a". Also AFAIK "vga=normal" is
    > another non numeric option.
    >
    > Sorry, Carlos, if I gave away your secret...


    But grub doesn't parse that part of the line, it passes it to the kernel.
    Everything that is behind the "kernel" token is passed as is.

    The error 23 typically goes for the "(hd0,1)" part, that misses a part. For
    example "(hd0,hd1)".

    It is a pain that grub is not more explicit with what it doesn't
    understand, it could print the exact line and mark the bad word.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  10. #10

    Default Re: Error 23 at boot: Error while parsing number

    The error message has gone, apparently it accepted the VGA changes I made...

    It still mentions a ' set up Grub entry for next boot cycle: FAILED' in the startup status reports though...

    thanks everybody for your ideas and help.:-)

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •