Results 1 to 8 of 8

Thread: [Solved] How to disable tracker-store processes that eat 100% CPU

  1. #1

    Default [Solved] How to disable tracker-store processes that eat 100% CPU

    I use KDE almost always, but on my main laptop I always install GNOME in the Opensuse installation, just in case I want to take it for a spin. Unfortunately this seems to have also installed something called 'tracker' that is meant to be a desktop indexing and search service for GNOME. Even when I login to KDE this tracker thing starts up and spends ages eating 100% CPU time of one of the laptop's cores, not to mention thrashing the disk.

    Luckily the fix is simple:
    Edit /etc/xdg/autostart and add the following line to the tracker-*.desktop files:
    Hidden=true
    See https://wiki.ubuntu.com/Tracker

    After that the tracker-store etc. processes will no longer start up when you login, you'll need to logout and log back in for the change to take affect of course.

    Maybe one day one of these Linux desktop search things will work without killing the performance of the machine it runs on and thereby destroying the user experience it's supposed to enhance.

  2. #2
    Join Date
    Aug 2008
    Location
    Pitesti, Arges County, Romania
    Posts
    615

    Default Re: [Solved] How to disable tracker-store processes that eat 100% CPU

    Congrat`s for the tutorial, it really saved my openSUSE OS from Vbox
    openSUSE Community Member: -> en.opensuse.org/User:Creatura85
    Connect Profile:
    -> connect.opensuse.org/pg/profile/creatura85
    openSUSE Romania Member: -> suseromania.ro

  3. #3

    Default Re: [Solved] How to disable tracker-store processes that eat 100% CPU

    Thank You!

  4. #4
    Join Date
    Feb 2009
    Location
    Concordia, MO, USA
    Posts
    92

    Thumbs up Re: [Solved] How to disable tracker-store processes that eat 100% CPU

    Quote Originally Posted by tk83 View Post
    Maybe one day one of these Linux desktop search things will work without killing the performance of the machine it runs on and thereby destroying the user experience it's supposed to enhance.
    Maybe one day the people responsible will discover that it's not a good idea to turn these things on by default; I had the same issues with akonadi on KDE4, which prompted me to convert back to KDE3, since kMail doesn't appear to work on KDE4 without it.
    Thanks for the help.
    Hmmm... except that there is no /etc/xdg/autostart on my machine to be edited. Guess I'll have to dig some more.

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    11,210

    Default Re: [Solved] How to disable tracker-store processes that eat 100%CPU

    On 07/20/2013 12:46 AM, jlturriff wrote:
    >
    > Maybe one day the people responsible will discover that it's not a good
    > idea to turn these things on by default;


    disabling those kind of things (tracker, akonadi, kepomuk) are on my
    list of things to disable immediately...(the KDE People responsible
    are driven by different needs than me..)


    > I had the same issues with
    > akonadi on KDE4, which prompted me to convert back to KDE3, since kMail
    > doesn't appear to work on KDE4 without it.


    hmmm...i don't use KMail but i do remember it went through a big
    change in either 12.1 or .2 and there was a lot of trouble with it
    initially, but i *think* it has been fixed now....

    personally, i would have stayed in KDE4 and setup either tracker or
    akonadi (or both) to NOT try to index the universe--and kill my
    system response in the process..

    that is: *if* KMail in KDE4 actually won't work without it, the
    RESTRICT tracker/akonadi to only index the KMail files in your
    home....and NOT the entire /home/*


    > Thanks for the help.
    > Hmmm... except that there is no /etc/xdg/autostart on my machine to be
    > edited. Guess I'll have to dig some more.


    so, your post to a tracker thread is misplaced if you are using
    akonadi....they are not the same...and anyway the file you were
    looking for was not
    /etc/xdg/autostart
    but
    /etc/xdg/autostart/trackerd.desktop

    hth

    --
    dd
    http://tinyurl.com/DD-Caveat

  6. #6
    Will Honea NNTP User

    Default Re: [Solved] How to disable tracker-store processes that eat 100% CPU

    dd wrote:

    > hmmm...i don't use KMail but i do remember it went through a big
    > change in either 12.1 or .2 and there was a lot of trouble with it
    > initially, but i *think* it has been fixed now....
    >


    That was the thing that kept me on 11.4/evergreen for so long. After a few
    false starts, the migration seems to be working pretty well for all the KDE
    pim parts as of 12.3 (there are some things you have to do manually still)
    but I run into issues on some setups still - usually with the old KDE3
    setups that have survived updating for years while inheriting unusual
    setups.

    --
    Will Honea
    whonea@yahoo.com

  7. #7

    Default AW: Re: [Solved] How to disable tracker-store processes that eat 100%CPU

    Quote Originally Posted by DenverD View Post
    On 07/20/2013 12:46 AM, jlturriff wrote:
    >
    > Maybe one day the people responsible will discover that it's not a good
    > idea to turn these things on by default;


    disabling those kind of things (tracker, akonadi, kepomuk) are on my
    list of things to disable immediately...(the KDE People responsible
    are driven by different needs than me..)


    > I had the same issues with
    > akonadi on KDE4, which prompted me to convert back to KDE3, since kMail
    > doesn't appear to work on KDE4 without it.


    hmmm...i don't use KMail but i do remember it went through a big
    change in either 12.1 or .2 and there was a lot of trouble with it
    initially, but i *think* it has been fixed now....

    personally, i would have stayed in KDE4 and setup either tracker or
    akonadi (or both) to NOT try to index the universe--and kill my
    system response in the process..

    that is: *if* KMail in KDE4 actually won't work without it, the
    RESTRICT tracker/akonadi to only index the KMail files in your
    home....and NOT the entire /home/*


    > Thanks for the help.
    > Hmmm... except that there is no /etc/xdg/autostart on my machine to be
    > edited. Guess I'll have to dig some more.


    so, your post to a tracker thread is misplaced if you are using
    akonadi....they are not the same...and anyway the file you were
    looking for was not
    /etc/xdg/autostart
    but
    /etc/xdg/autostart/trackerd.desktop

    hth
    I just want to clarify some things regarding KDE, Akonadi and Nepomuk:
    Akonadi doesn't index anything. Nepomuk does.
    But on openSUSE file indexing is TURNED OFF by default. ("Configure Desktop"->"Desktop Search")

    And Akonadi only gets started if an application wants to use it, so no need for disabling that as well.
    Just don't use KMail, KOrganizer and so on. (they won't work without Akonadi anyway).

    The panel clock does use Akonadi for displaying events, so it can cause Akonadi to be started on login. But the option "Show events" is also TURNED OFF by default on openSUSE.
    Also there are some KRunner plugins using Akonadi, but, again, those are TURNED OFF by default on openSUSE.

    So on a fresh openSUSE install Akonadi DOES NOT get started, and Nepomuk file indexing IS TURNED OFF.

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    22,742

    Default Re: [Solved] How to disable tracker-store processes that eat 100%CPU

    On 2013-07-21 12:56, wolfi323 wrote:
    > So on a fresh openSUSE install Akonadi DOES NOT get started, and
    > Nepomuk file indexing IS TURNED OFF.


    And tracker is a gnome thing.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •