Results 1 to 9 of 9

Thread: Wireless Not Working Dell Studio XPS 1645

  1. #1

    Post Wireless Not Working Dell Studio XPS 1645

    How are you all doing today.. I have a strange problem with my laptop and need your help in resolving it...i am using a Dell Studio XPS 1645..i have got everything working except the wireless.. and the real problem here is that the wlan detects the network but does not connect to it and will keep on looping back and forward doing the same thing again and again..I am using Opensuse 11.4 with Gnome 3 Shell..here is details of the commands that i tried using to fix the issue

    # lspci
    00:00.0 Host bridge: Intel Corporation Core Processor DMI (rev 11)
    00:03.0 PCI bridge: Intel Corporation Core Processor PCI Express Root Port 1 (rev 11)
    00:08.0 System peripheral: Intel Corporation Core Processor System Management Registers (rev 11)
    00:08.1 System peripheral: Intel Corporation Core Processor Semaphore and Scratchpad Registers (rev 11)
    00:08.2 System peripheral: Intel Corporation Core Processor System Control and Status Registers (rev 11)
    00:08.3 System peripheral: Intel Corporation Core Processor Miscellaneous Registers (rev 11)
    00:10.0 System peripheral: Intel Corporation Core Processor QPI Link (rev 11)
    00:10.1 System peripheral: Intel Corporation Core Processor QPI Routing and Protocol Registers (rev 11)
    00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
    00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
    00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
    00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
    00:1c.3 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 4 (rev 05)
    00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 05)
    00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 (rev 05)
    00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
    00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
    00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
    00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 6 port SATA AHCI Controller (rev 05)
    00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
    02:00.0 VGA compatible controller: ATI Technologies Inc Device 9488
    02:00.1 Audio device: ATI Technologies Inc RV710/730
    05:00.0 Network controller: Intel Corporation Ultimate N WiFi Link 5300
    09:00.0 SD Host controller: Ricoh Co Ltd MMC/SD Host Controller (rev 01)
    09:00.1 System peripheral: Ricoh Co Ltd Memory Stick Host Controller (rev 01)
    09:00.2 System peripheral: Ricoh Co Ltd Device e852 (rev 01)
    09:00.3 FireWire (IEEE 1394): Ricoh Co Ltd FireWire Host Controller (rev 01)
    0b:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5784M Gigabit Ethernet PCIe (rev 10)
    ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-Core Registers (rev 04)
    ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 04)
    ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 04)
    ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 04)
    ff:03.0 Host bridge: Intel Corporation Core Processor Integrated Memory Controller (rev 04)
    ff:03.1 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Target Address Decoder (rev 04)
    ff:03.4 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Test Registers (rev 04)
    ff:04.0 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Control Registers (rev 04)
    ff:04.1 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Address Registers (rev 04)
    ff:04.2 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Rank Registers (rev 04)
    ff:04.3 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Thermal Control Registers (rev 04)
    ff:05.0 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Control Registers (rev 04)
    ff:05.1 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Address Registers (rev 04)
    ff:05.2 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Rank Registers (rev 04)
    ff:05.3 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Thermal Control Registers (rev 04)

  2. #2

    Default Re: Wireless Not Working Dell Studio XPS 1645

    # lsusb
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
    Bus 001 Device 003: ID 0c45:640f Microdia
    Bus 002 Device 003: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
    Bus 002 Device 004: ID 413c:8157 Dell Computer Corp. Integrated Keyboard
    Bus 002 Device 005: ID 413c:8158 Dell Computer Corp. Integrated Touchpad / Trackstick
    Bus 002 Device 006: ID 413c:8156 Dell Computer Corp. Wireless 370 Bluetooth Mini-card

    # ifconfig
    bnep0 Link encap:Ethernet HWaddr 90:4C:E50:31:81
    inet addr:192.168.22.2 Bcast:192.168.22.255 Mask:255.255.255.0
    inet6 addr: fe80::924c:e5ff:fed0:3181/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:4065 errors:0 dropped:0 overruns:0 frame:0
    TX packets:3962 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:2615592 (2.4 Mb) TX bytes:882891 (862.1 Kb)

    eth0 Link encap:Ethernet HWaddr 00:26:B9:22:71:2D
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:17

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:50 errors:0 dropped:0 overruns:0 frame:0
    TX packets:50 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:4012 (3.9 Kb) TX bytes:4012 (3.9 Kb)

    wlan0 Link encap:Ethernet HWaddr 00:21:6A:5B:93:84
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:108 (108.0 b)

  3. #3
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,381

    Default Re: Wireless Not Working Dell Studio XPS 1645

    On 08/21/2011 07:46 PM, 1second life wrote:
    >
    > How are you all doing today.. I have a strange problem with my laptop
    > and need your help in resolving it...i am using a Dell Studio XPS
    > 1645..i have got everything working except the wireless.. and the real
    > problem here is that the wlan detects the network but does not connect
    > to it and will keep on looping back and forward doing the same thing
    > again and again..I am using Opensuse 11.4 with Gnome 3 Shell..here is
    > details of the commands that i tried using to fix the issue
    >
    > # lspci


    > 05:00.0 Network controller: Intel Corporation Ultimate N WiFi Link
    > 5300


    Above is your network device.

    In the second posting, ifconfig only shows that the device has not gotten an IP,
    but we knew that.

    Please post the output of

    sudo /usr/sbin/iwlist scan

    That will show us if the device can transmit and receive, as well as what kind
    of encryption you are using. In case that happens to be WEP, you cannot use a
    passphrase but must use the hexadecimal key.

    I am assuming that you are using NetworkManager, not ifup.


  4. #4

    Default Re: Wireless Not Working Dell Studio XPS 1645

    Here is the result of iwlist
    # iwlist scan
    lo Interface doesn't support scanning.

    eth0 Interface doesn't support scanning.

    wlan0 Scan completed :
    Cell 01 - Address: DA:94:B9:41:94:16
    Channel:6
    Frequency:2.437 GHz (Channel 6)
    Quality=29/70 Signal level=-81 dBm
    Encryption keyff
    ESSID:"Airtel-dd"
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
    24 Mb/s; 36 Mb/s; 54 Mb/s
    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
    Mode:Ad-Hoc
    Extra:tsf=00000000012c17e7
    Extra: Last beacon: 3020ms ago
    IE: Unknown: 000941697274656C2D6464
    IE: Unknown: 010882848B962430486C
    IE: Unknown: 030106
    IE: Unknown: 06020000
    IE: Unknown: 2A0100
    IE: Unknown: 2F0100
    IE: Unknown: 32040C121860
    IE: Unknown: DD09001018020000000000


    I am using a open wireless network off my mobile phone and its a WEP.

    Yes i am using Network Manager..

    Thanks for the reply..

  5. #5
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,381

    Default Re: Wireless Not Working Dell Studio XPS 1645

    On 08/22/2011 12:26 AM, 1second life wrote:
    >
    > Here is the result of iwlist
    > # iwlist scan
    > wlan0 Scan completed :
    > Cell 01 - Address: DA:94:B9:41:94:16
    > Channel:6
    > Frequency:2.437 GHz (Channel 6)
    > Quality=29/70 Signal level=-81 dBm
    > Encryption keyff
    > ESSID:"Airtel-dd"


    --snip--

    > I am using a open wireless network off my mobile phone and its a WEP.
    >
    > Yes i am using Network Manager..


    No, it is unencrypted, not WEP. See the "Encryption key: off".

    Not all wireless devices will work in Ad-hoc mode. Yours should, but I have no
    way of testing. In the Connection Manager, did you set the mode correctly?

  6. #6

    Default Re: Wireless Not Working Dell Studio XPS 1645

    Hi lwfinger,

    I am quite sure that i have set the connection manager correctly... however i wanted to add one more thing that when i was using opensuse 11.4 with a previous version of gnome..everthing was working fine....i seriously suspect that it has got something to do with Gnome 3 Shell or Network Applet...

    is there any way that i can install a diff network manager for gnome 3 shell...
    -

  7. #7
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,381

    Default Re: Wireless Not Working Dell Studio XPS 1645

    On 08/22/2011 01:26 PM, 1second life wrote:
    >
    > Hi lwfinger,
    >
    > I am quite sure that i have set the connection manager correctly...
    > however i wanted to add one more thing that when i was using opensuse
    > 11.4 with a previous version of gnome..everthing was working fine....i
    > seriously suspect that it has got something to do with Gnome 3 Shell or
    > Network Applet...
    >
    > is there any way that i can install a diff network manager for gnome 3
    > shell...


    There is only one NetworkManager that is used for both Gnome and KDE. What
    changes in the applet. I know one can use the Gnome applet with KDE, but I just
    tested and if you want to deinstall NetworkManager-Gnome, YaST also wants to
    deinstall the Gnome shell.

    You need to switch to ifup using YaST and configure the wireless there.

  8. #8

    Default Re: Wireless Not Working Dell Studio XPS 1645

    I will stay with network manager as of now coz i am connecting it to my mobiles and internet via bluetooth works like a charm.. will look forward for the future releases of opensuse...

    Thanks for the help...

  9. #9

    Default Re: Wireless Not Working Dell Studio XPS 1645

    Hi

    Finally got it working.. after Yast update... dont know how it worked.. but it started working like charm just after the update...

    Thanks for the support

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •