Results 1 to 9 of 9

Thread: Opensuse 11.4 How to disable the touchpad

  1. #1

    Default Opensuse 11.4 How to disable the touchpad

    I'm running 11.4 gnome and need to be able to disable the touchpad on my laptop. I always use an external mouse.

    Any suggestions would be appreciated.

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    11,210

    Default Re: Opensuse 11.4 How to disable the touchpad

    On 07/19/2011 07:06 PM, Bearly230 wrote:
    >
    > I'm running 11.4 gnome and need to be able to disable the touchpad on my
    > laptop. I always use an external mouse.


    my netbook has a key combo (Fn+F7) to disable touchpad...and, once off
    it stays off even though boots...(and, if i decide to unplug and go, i
    can re-enable it easily)

    --
    DD
    Caveat-Hardware-Software
    openSUSE®, the "German Engineered Automobiles" of operating systems!

  3. #3
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,031

    Default Re: Opensuse 11.4 How to disable the touchpad

    There is a GNOME synaptics module - try a search for 'synap' - which should allow you to disable it.

  4. #4

    Default Re: Opensuse 11.4 How to disable the touchpad

    I have the key combo to disable it. And when I use it. I get a popup that it's been disabled, however it's still working. I've also try to locate the synaptics module with no luck.

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    11,210

    Default Re: Opensuse 11.4 How to disable the touchpad

    On 07/19/2011 09:36 PM, Bearly230 wrote:
    >
    > I have the key combo to disable it. And when I use it. I get a popup
    > that it's been disabled, however it's still working.


    check with the manufacturer...maybe they have a recall on the machine
    and/or you can get it repaired free..

    or, check the BIOS, maybe you can turn it off in there.....and, while
    you are at the makers site see if there is an updated BIOS...the key
    combo switch goes through the BIOS and not through the operating
    system...so, if the BIOS has been updated it might have fixed the keys
    not working problem..

    google: touchpad [maker] [model] problem

    --
    DD
    Caveat-Hardware-Software
    openSUSE®, the "German Engineered Automobiles" of operating systems!

  6. #6

    Default Re: Opensuse 11.4 How to disable the touchpad

    The machine is 2 weeks old, 2nd the key combo works in windows so not a hardware issue. 3rd I'm looking for real help not attitude.

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    11,210

    Default Re: Opensuse 11.4 How to disable the touchpad

    On 07/19/2011 11:16 PM, Bearly230 wrote:
    >
    > I'm looking for real help not attitude.


    ploink

    --
    DD
    Caveat-Hardware-Software
    openSUSE®, the "German Engineered Automobiles" of operating systems!

  8. #8
    Join Date
    Feb 2010
    Location
    Upstate New York, USA
    Posts
    505

    Default Re: Opensuse 11.4 How to disable the touchpad

    Quote Originally Posted by Bearly230 View Post
    I'm running 11.4 gnome and need to be able to disable the touchpad on my laptop. I always use an external mouse.

    Any suggestions would be appreciated.
    Install the gsynaptics package (in /oss, I think). This installs a program "Touchpad" in Control Center. Click on Touchpad, and locate, under the General tab, "Enable Touchpad". Clear the check mark, and the touchpad is unusable. Be advised that this sometimes becomes re-enabled on re-boot. If this re-enabling occurs, go to "Startup Applications" and locate Touchpad. Change the command string

    Code:
    gsynaptics-init --sm-disable
    to the desired touchpad setting. Refer to the synclient command syntax for values.

    BTW, some keyboards (like mine) have a touch-sensitive switch to disable the touchpad. (Obviously, the designers find humor is oxymoronic engineering).

    Also, as a caution, should your mouse fail, to restore the touchpad requires keyboard command sequences to execute the Touchpad function, and re-enable the "Enable Touchpad" value.
    Lap: Gateway NV79, i5-430, 4GB, 2 x 500GB HD, Intel GMA HD
    openSUSE 12.3 x64, KDE 4.12.4, Ubuntu 12.04LTS+10.04.3 LTS, Windows 7

    Lap: openSUSE 12.3, KDE 4.12.4, Windows/XP/SP3 guest and a Ubuntu 10.04.3 LTS boarder

  9. #9

    Default Re: Opensuse 11.4 How to disable the touchpad

    Thanks that's what I needed.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •