Results 1 to 6 of 6

Thread: :'( OpenSuse 11.4 Apache Nightmare.

  1. #1

    Default :'( OpenSuse 11.4 Apache Nightmare.

    So after spending a great dela of time working threw the Opensuse broken yast interface, I had finally gotten my apache server up and running with vhosts..

    My firewall is off.
    My app armor is off.

    All the great things I love about Suse.. I find Novell just can't get these things right..

    Now.... The Problem,

    it is so strange that I have barely the way to describe whats happening, except.. with apache, for oscommerce, the directory of admin isn't able to come up. You can run the site fine, you can run the install fine, but as soon as you try to go to any sort of admin panel it just gives a 403.. no matter what...

    on a virtual machine on that computer it gives that same issue.

    but on the computer sitting right next to it, everything works fine.

    So, I haven't the faintest of what is happenning..

    I have installed apache, osc, php of hundreds of differant installs...

    I spent a great deal of time wrestling with this, and have given up mostly, the serve now sits in a vm on a windows box...

    I really love opensuse, but this latest release has given me nothing but issues.. issues issues issues.. serious issues!!!

    I would really like to have opensuse running, with a xen layer, wich i have gotten running, with nvidia support, wich i did, and with a web server support running at just a command prompt.. wich is the final step.. then, eventually to migrate it to a dual xeon board.. once i have sold my evga dual xeon becuase it's "NOT COMPATABLE" with opensuse suse 11.4... but this is eally my final straw.. I haven't any patience left..

    a server shouldn't take months to get operational.. with windows this takes litteraly a day.. why can't linux? do I need to switch distribs? I have used ubuntu, and truthfully, sorry if any ubuntu fans are listenning, but I think there trying to make windows out of linux.. as in it's crippled.. whats the alternative? redhat? UGH! I have heard gento is good, but harder to get up and running then others, if it's any harder then opensuse, I may loose all my hair...

    Anyways, thanks everyone for all your help.
    Have a great day.

  2. #2
    Join Date
    Dec 2009
    Location
    Moldova
    Posts
    122

    Default Re: :'( OpenSuse 11.4 Apache Nightmare.

    error 403 has a set of substatuses : HTTP 403 - Wikipedia, the free encyclopedia.
    For example if this dir. or host is configured to work only through ssl.
    what is the exact message you get?
    put here the content of /var/log/apache2/error_log.

  3. #3
    Join Date
    Nov 2010
    Location
    Youngstown, OH
    Posts
    155

    Default Re: :'( OpenSuse 11.4 Apache Nightmare.

    Quote Originally Posted by ghostcyber View Post
    but I think there trying to make windows out of linux
    Been preaching that myself for about a year.
    The user-base is the same crowd/mentality anyway

    re: 403: Check the physical directory for OSCommerce/admin and look for an .htaccess file.
    Check it for for Deny / Allow rules.
    Allow from <yourIP>
    There may be several Allow/Deny s in there, so make certain you back up the original and check carefully for the correct entry for OSCommerce.

    Or you may have to check for same in httpd.conf or maybe it's apache[2].conf for similar Allow / Deny rule

    P.S. It's not a Novell issue, it has to be a Security Feature of OSCommerce.
    No need to switch distros.

    Good Luck.
    Lenovo: OpenSUSE 11.4/32 | Xfce 4.8.1 | Intel Core2 Duo T7200 | Intel 945GM/GMS | 4G RAM | Firefox 8.0 | Thunderbird 3.1.16

  4. #4
    Join Date
    Nov 2010
    Location
    Youngstown, OH
    Posts
    155

    Default Re: :'( OpenSuse 11.4 Apache Nightmare.

    My bad:

    There may be several Allow/Deny s in there, so make certain you back up the original and check carefully for the correct entry for OSCommerce.
    is meant for the httpd.conf or apache[2].conf file
    NOT the OSCommerce/admin/.htaccess file.
    Lenovo: OpenSUSE 11.4/32 | Xfce 4.8.1 | Intel Core2 Duo T7200 | Intel 945GM/GMS | 4G RAM | Firefox 8.0 | Thunderbird 3.1.16

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    3,210

    Default Re: :'( OpenSuse 11.4 Apache Nightmare.

    ghostcyber

    1. If you have a working machine side by side with your problem, you have an advantage right there. How is your working machine setup, different distro, different app version, what?

    2. Working only off your description that everything works except Admin pages, that sounds very much to me like an internal problem of the app. I'm not personally familiar with OScommerce, but have worked with many, many "Framework" web apps. Today, Admin pages require App Admin acccounts (not Sys Admin accounts) unless you've tied App security into Sys or Network Security. If OScommerce is typical, then file permissions is not a possible cause because all App accounts use impersonation and use the same security to the System.

    3. Am curious about why you felt you needed to disable your Firewall and AppArmor, those don't sound to me logical at all unless you're configured to use an unusual network configuration.

    4. Here is a fairly simple YMMV recommendation to setting up a <single site> (not multiple Hostheader sites) on a default openSUSE...

    - Using YAST, install the LAMP pattern
    - Using YAST, install MySQL tools (unless you're using another database)
    - A default Apache install places all PHP files in the /srv/www/htdocs directory. Rename the default www and its contents, then create a new www and www/htdocs and copy any new website into the www/htdocs folder
    - Read the App's INSTALL file (usually included in TAR), it will usually contain some special instructions like setting required file and folder permissions
    - Create an appropriate database (can use the MySQL tools)

    Typically many of today's web apps which have auto-install are now ready to go... Open a browser to http://localhost and you should be working

    IMO,
    Tony

  6. #6

    Arrow Re: :'( OpenSuse 11.4 Apache Nightmare.

    K, here we go,

    Side by side, one with windows, the other with opensuse, both are running VMWARE.

    take an image, working, with win08 r2 booting within VMWARE, and take it from the windows amchine to the opensuse machine... i get the 403's..

    there has to be something bloking some sort of port.. no, osc does not use ssl, you can, but it's not on by default.

    besides that.. I have the firewall turned OFF... isn't that supposted to turn the firewall off?

    Thanks for all the responces, you guys are what make opensuse .. possible.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •