Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: I just stink at linux

  1. #1

    Default I just stink at linux

    just did a second install of openSUSE 11.4, now all I get is the text screen:

    "Have a lot of fun..."
    "corbitt@linux-u1kc:~>"

    ????? what do I do now? I chose the GNU desktop and I'm guessing (hoping) this is NOT it. But how do I get there? During the installation a screen did tell me that it was going into text mode (i don't recall exactly why).

  2. #2

    Default Re: I just stink at linux

    here is more info, I read about using the command "startx" - so I did, here is what I got:

    xauth: file /home/corbitt/.serverauth.2645 does not exist

    Fatal server error:
    Cannot move old log file "/var/log/Xorg.0.log" to "/var/log/Xorg.0.log.old"

    Please consult the The X.Org Foundation support
    at X.Org Wiki - Home
    for help.

    xinit: giving up
    xinit: unable to connect to X server: Connection refused
    xinit: server error
    -----------------------------------------------------------------------------
    xinit falied. /usr/bin/Xorg is not setuid, maybe that's the reason?
    If so either use a display manager (strongly recommended) or adjust /etc/permissions. local

  3. #3
    Join Date
    Nov 2009
    Location
    West by God Virginia
    Posts
    6,231

    Default Re: I just stink at linux

    What is the GNU Desktop? Do you mean the Gnome Desktop? Note it is possible to install Linux without a Desktop, so are you sure you actually choose one? Do you see a graphic splash screen when the boot starts or do you just see a bunch of text scroll by? Did you try the failsafe boot option? One of the things that surprises Windows user is it is really important to read the screens. In Windows you generally have no or few choices so you just click through the screens without really paying attention, but in Linux there are many many ways to do things. So you need to pay attention to what is shown on the screens. If you have questions just ask here someone will explain things to you.

    So you also may be having problems witj a graphics card. SO what graphics do you have? In fact it would help if you gave a brief description of your hardware in general. ie how much memory processor etc.

  4. #4
    Join Date
    Nov 2009
    Location
    West by God Virginia
    Posts
    6,231

    Default Re: I just stink at linux

    Startx does not work anymore. Do this instead become root by

    su -
    then the root password note this does not echo to the screen!

    then

    init 5
    that will start the Xwindows system and should start the GUI desktop

  5. #5

    Default Re: I just stink at linux

    yes I meant gnome, I dont know where I got the GNU?? I only get a splash screen when I'm choosing between openSUSE and failsafe mode. I tried failsafe, but got the same results. The graphics card problem sounds likely - my graphics card is RADEON IGP 320M. Its an old laptop with a mobile AMD Athlon 1.66ghz processor and 704mb ram.

  6. #6

    Default Re: I just stink at linux

    ok, tried that. the "su" command seemed to work (text turned red), but init 5 did nothing.

  7. #7
    Join Date
    Nov 2009
    Location
    West by God Virginia
    Posts
    6,231

    Default Re: I just stink at linux

    I use NVIDIA so I guess we should wait for someone with more experience with the ATI cards.
    You could try my suggestion to use the the init 5 command. It may give some help in understanding the problem. Note you may need to do a init 3 before the init 5 in case the machine is stuck in the level 5 state. Level 5 is the GUI mode Level 3 is multi user text mode. Also note that since you can log into the terminal is likely that this can be fixed. You just need to do a few commands.

  8. #8

    Default Re: I just stink at linux

    ok, switched to init 3, then back to init 5; system seemed to try to load gui but went back to text. Got this 6 times:

    gdm [5385]: WARNING: GdmDisplay: display lasted 0.564776 seconds


    then this:

    gdm [5385]: WARNING: GdmLocalDisplayFactory: maximum number of X display failures reached: check X server log for errors

  9. #9
    Join Date
    Nov 2009
    Location
    West by God Virginia
    Posts
    6,231

    Default Re: I just stink at linux

    Ok lets go back a step. Did you check the checksums of the ISO file you downloaded? Instruction are on the download page.

    Also it would be good to run the media check option on the first menu of the install disk to make sure you have a good burn. Always use quality media and burn at the slowest speed.

  10. #10

    Default Re: I just stink at linux

    the issue seems to be with the media. its 'broken'. I'll burn it again and try a fresh install.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •