Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: No channels in KMix 4.6.0

  1. #1

    Default No channels in KMix 4.6.0

    KMix 4.6.0 in OpenSUSE 11.4 (x86) doesn't show up channels. It only shows "Internal sound Analog stereo". So I can't set the input/output channels and the headphone channel for my soundcard. The right soundcard drivers are installed (for Creative Sound Blaster Platinum Live Drive). Earlier versions of KMix worked just fine.

    This is what I found in /home/user/kde4/share/config/kmixctric:

    [MixerPulseAudio::Afspeelapparaten:1]
    name=

    [MixerPulseAudio::Afspeelstromen:1]
    name=

    [MixerPulseAudio:pnameapparaten:1]
    name=

    [MixerPulseAudio:pnamestromen:1]
    name=

    And I found this in home/user/kde4/share/config/kmixrc:

    [Global]
    MasterMixerDevice=alsa_output.pci-0000_00_0b.0.analog-stereo
    Position=0,0
    Size=250,313
    Visible=false

    The weird thing is on the other hand KAmix shows all channels properly. Also Audacity recognizes my soundcard properly for instance.

    I uninstalled KMix, deleted the KMix-files and Kmix config files and installed KMix again. No result at all.

    Has any one an idea?

    Thanks in advance,
    Willem Franssen

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,500
    Blog Entries
    48

    Smile Re: No channels in KMix 4.6.0

    openSUSE 11.4 uses Pulseaudio and it is suggested that you load the mixer control pavucontrol. You can open YaST / Software / Software Management and search on pavucontrol and install it if it is not already. You can run it using the menu Run Command:

    Code:
    /usr/bin/pavucontrol
    Give this a try and see if it is helpful to you.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,330

    Default Re: No channels in KMix 4.6.0

    Quote Originally Posted by wfranssen View Post
    KMix 4.6.0 in OpenSUSE 11.4 (x86) doesn't show up channels. It only shows "Internal sound Analog stereo". So I can't set the input/output channels and the headphone channel for my soundcard.
    PulseAudio takes a different approach and KMix follows that. You can of course disable P/A in YaST>Hardware>Sound>Other>PulseAudio... I don't as I prefer the way P/A works in KDE 4.6.0 and it delivers very good sound here (as it does on Gnome since 11.3).

    You have a master volume by left-click on KMix icon in system tray. The Mixer now has several tabs, separating output/input i.e. playback/capture. "Playback Devices" tab only has one channel per card/device, and if you right-click on that channel you can split it into two separately controlled channels. The other tabs get populated as applications make use of playback/capture through P/A. So you can control the volumes/levels of multiple application streams performing playback/capture.

    PulseAudio and KDE Phonon control your sound card through the alsa drivers to the hardware. The Mixer also has Settings>Audio Setup which takes you to the KDE Phonon settings. As previously mentioned you may prefer to install and use "pavucontrol" which I think provides similar facilities to the KMix and Phonon settings. I haven't needed to do so, but YMMV.

    Why do you personally feel the need to set hardware channel levels manually. For example, does/did any user really need to set an alsa channel called PCM (what) to any value other than high? Let the system take care of that stuff. I don't understand what you think you were missing?

  4. #4

    Default Re: No channels in KMix 4.6.0

    In kmix with pulsaudio, the trick is
    Let's say you click the kmix-playback devices, you hover the mouse on top of the slider control of e,g: internal audio analog surround control or high definition audio controller, just right click the mouse and you can change the settings.
    You can mute/unmute, split the channels and so on. Hope this helps.
    People who do not break things first will never learn to create anything

  5. #5

    Default Re: No channels in KMix 4.6.0

    To jdmcdaniel, consused, conram,

    I installed pavucontrol and other additional pulse audio packages.Does NOT solve the problem. You know, a proper mixer has to show up available channels like Mono, Stereo, Wave, Cd-digital, Synth, Headphone, SPDIF, Line, Mic, Aux, TAD, and so on. But KMix 4.6.0 does NOT. As a guitar player making home recordings sometimes, I have to be able to set channels of my choice. KAmix does show up all this stuff, KMix 4.60.0 doesn't. Earlier versions of KMix did. And out of the box.

    Another idea what to do?
    Willem Franssen

  6. #6

    Default Re: No channels in KMix 4.6.0

    well you can do as I did and delete pulseaudio, search for pulse in yast and uninstall everything but libpulse0 and libpulse-mainloop-glib0, (if you select those to uninstall you will get message that kde-base needs to be removed and you dont want that). reboot (desktop might not shutdown because it can't play the bye bye sound, in that case use init 6 in a terminal) after the reboot you will have full alsa control like before 11.4

  7. #7

    Default Re: No channels in KMix 4.6.0

    Hi Xilanaz.
    I did everything you suggested. KMix is working fine now and shows all channels.
    Thank you for your help.
    Willem Franssen

  8. #8
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,789
    Blog Entries
    30

    Default Re: No channels in KMix 4.6.0

    Quote Originally Posted by wfranssen View Post
    To jdmcdaniel, consused, conram,

    I installed pavucontrol and other additional pulse audio packages.Does NOT solve the problem. You know, a proper mixer has to show up available channels like Mono, Stereo, Wave, Cd-digital, Synth, Headphone, SPDIF, Line, Mic, Aux, TAD, and so on. But KMix 4.6.0 does NOT. As a guitar player making home recordings sometimes, I have to be able to set channels of my choice. KAmix does show up all this stuff, KMix 4.60.0 doesn't. Earlier versions of KMix did. And out of the box.
    Glad to read you managed to get this reading by removing pulse.

    Having stated that, pulse should give you MUCH MORE controls. I just don't know how to set it up properly, and with due respect to the great contributors we have on this forum, I don't think many others know how either.

    The problem here to a large extent is none of us know pulse all that well yet and hence we can not give much advice. And unfortunately many of the users who want the very advanced features for sound don't have the time/patience to learns the ins and outs of pulse so as to show the rest of us how pulse can actually do this better. ... Those who do know are not contributing. Hence the quick solution for those who don't know is to simply remove pulse, and hence nothing moves forward in terms of guides/helping with the knowledge, etc .....

  9. #9
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,330

    Default Re: No channels in KMix 4.6.0

    Quote Originally Posted by oldcpu View Post
    ... pulse should give you MUCH MORE controls.
    Some of us have spent time reading the stuff on the pulseaudio website. What I have read there, strongly suggests that the PulseAudio developers are of the opposite opinion to you i.e. there aim was to simplify the setup compared to straight alsa's complicated channel configuration. That's bad luck for musicians, such as the OP with his particular sound card deployment, because if they want to use openSUSE with KDE, disabling P/A is possibly the only way to go to support their old setup.

    Even on the studio distros specializing in audio production for musicians, you will find disagreement on the suitability of P/A for serious/professional musicians.

    Let's not forget that it's actually the Phonon/Solid combination that is supposed to take care of the hardware on KDE, not P/A. When I plug in my usb guitar effects processor (the guitar plugs into that processor), it is immediately picked up on KMix's Capture Devices tab where I can apply volume adjustment, split channel, and mute settings. All the clever stuff is on the effects processor. Then I just need it connected to P/A supported recording/playback applications.

    That is the kind of connectivity Pulse Audio appears to be aimed at, where many home users want to plug various accessories and gadgets into their laptops with ease, pick them up with favourite applications and multiple audio streams. The onboard chipsets are producing better and better sound. Windows and Apple have been setting the pace for many years in this marketplace. Since openSUSE is a general purpose distro, whether it's with KDE or Gnome, it must head down this road.

  10. #10
    Join Date
    Jun 2008
    Location
    where I am is where I am
    Posts
    1,169

    Default Re: No channels in KMix 4.6.0

    Quote Originally Posted by Xilanaz View Post
    well you can do as I did and delete pulseaudio, search for pulse in yast and uninstall everything but libpulse0 and libpulse-mainloop-glib0, (if you select those to uninstall you will get message that kde-base needs to be removed and you dont want that). reboot (desktop might not shutdown because it can't play the bye bye sound, in that case use init 6 in a terminal) after the reboot you will have full alsa control like before 11.4
    Thank You x5!!!!!
    Challenge your preconceptions, or they will challenge you.
    My 32 bit: E Machines T3103| VIA On board graphics|512MB RAM
    My 64 bit: Gateway 5670| Nvidia GeForce GT610 |CPU AMD Phenom 8400|4G RAM

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •