Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: openSuSe 11.4 SuSefirewall2 init and setup

  1. #1

    Unhappy openSuSe 11.4 SuSefirewall2 init and setup

    Hello,

    I've downloaded and fresh new installed 11.4 yesterday, but I got during the installation the following errors:

    Cannot enable service "SuSefirewall2_init"
    Cannot enable service "SuSefirewall2_setup"

    I tried after the installation was completed to go and manually enable the firewall startup at boot time with the same results.
    I googled the error but I didn't seem to find anything pertaining to my specific error.
    Can you please help? If there already is a thread about this please excuse me and point me to it.

    Thank you.
    Calin.

  2. #2

    Default Re: openSuSe 11.4 SuSefirewall2 init and setup

    Not sure what you mean by manually, but services generally need to be started by a root privileged user.

    Use YaST to setup and turn on your firewall. It should provide clear messages why it might be unable to start the firewall.
    Box 1: OpenSuse 11.1/Win7 | Linux 2.6.27 Gnome | AMD 64 X2 6000+ | nVidia 8600GT | 2GB RAM
    Box 2: OpenSuse 11.2 | Linux 2.6.31 Gnome | AMD 64 3000+ | ATI X800 Pro | 1GB RAM
    Box 3: Win7 Premium Home | Intel P4 3.0Gz | ATI AIW 2006 | 2GB RAM

  3. #3
    Join Date
    Nov 2009
    Location
    West by God Virginia
    Posts
    6,664

    Default Re: openSuSe 11.4 SuSefirewall2 init and setup

    Did you run the media check on the install media (first menu) and also prior to burn did you check the checksums? This sounds like a bad butn or download to me.

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    21,535

    Default Re: openSuSe 11.4 SuSefirewall2 init and setup

    On 2011-03-19 13:06, CalinJugarean wrote:
    > I tried after the installation was completed to go and manually enable
    > the firewall startup at boot time with the same results.


    Repeat in CLI, paste the exact command and response here. As Code (# in
    advanced edit).

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  5. #5

    Default Re: openSuSe 11.4 SuSefirewall2 init and setup

    OK, thank you, here's the command:

    # yast firewall startup atboot

    Start-Up:
    ---------

    Enabling firewall in the boot process...


    Errors:
    Cannot enable service 'SuSEfirewall2_init'.
    Cannot enable service 'SuSEfirewall2_setup'.

  6. #6

    Default Re: openSuSe 11.4 SuSefirewall2 init and setup

    Is your firewall configured before you try to start the firewall. I don't think its turned on by default and maybe trying to start it before its configured is your problem.
    Can you use SUSE Paste to paste the output from the last 2 days in
    Code:
     grep -i firewall  /var/log/messages
    Box 1: OpenSuse 11.1/Win7 | Linux 2.6.27 Gnome | AMD 64 X2 6000+ | nVidia 8600GT | 2GB RAM
    Box 2: OpenSuse 11.2 | Linux 2.6.31 Gnome | AMD 64 3000+ | ATI X800 Pro | 1GB RAM
    Box 3: Win7 Premium Home | Intel P4 3.0Gz | ATI AIW 2006 | 2GB RAM

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    21,535

    Default Re: openSuSe 11.4 SuSefirewall2 init and setup

    On 2011-03-19 18:06, CalinJugarean wrote:
    >
    > OK, thank you, here's the command:
    >
    > # yast firewall startup atboot
    >
    > Start-Up:
    > ---------
    >
    > Enabling firewall in the boot process...
    >
    >
    > Errors:
    > Cannot enable service 'SuSEfirewall2_init'.
    > Cannot enable service 'SuSEfirewall2_setup'.


    That's not you manually enabling the service, in the command line (CLI).
    That's automatic. I want you using chkconfig, and later running the service
    (rcSuSEfirewall2).

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  8. #8

    Default Re: openSuSe 11.4 SuSefirewall2 init and setup

    # chkconfig SuSEfirewall2_init on
    insserv: FATAL: service network is missed in the runlevels 2 4 to use service ha_logd
    insserv: FATAL: service syslog is missed in the runlevels 4 to use service ha_logd
    insserv: exiting now!
    /sbin/insserv failed, exit code 1

    # chkconfig SuSEfirewall2_setup on
    chkconfig SuSEfirewall2_setup on
    insserv: FATAL: service SuSEfirewall2_init has to be enabled to use service SuSEfirewall2_setup
    insserv: FATAL: service network is missed in the runlevels 2 4 to use service ha_logd
    insserv: FATAL: service syslog is missed in the runlevels 4 to use service ha_logd
    insserv: exiting now!
    /sbin/insserv failed, exit code 1

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    21,535

    Default Re: openSuSe 11.4 SuSefirewall2 init and setup

    On 2011-03-20 02:06, CalinJugarean wrote:
    >
    > # chkconfig SuSEfirewall2_init on


    I don't know... I run "chkconfig SuSEfirewall2_init" on mine and says off
    in my 11.4 test partition, but it is on in my 11.2. I'm baffled. Ah! I see,
    my firewall is down!

    [...]

    Ok, now is up. And the command I told you shows "on". Now, lets see about
    yours.

    > insserv: FATAL: service network is missed in the runlevels 2 4 to use
    > service ha_logd
    > insserv: FATAL: service syslog is missed in the runlevels 4 to use
    > service ha_logd
    > insserv: exiting now!
    > /sbin/insserv failed, exit code 1


    service ha_logd? What is that? High availability log daemon?

    You are running some non-typical software for someone installing openSUSE
    first time... You have some explaining to do.

    I'm afraid I can't help you with that setup.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  10. #10

    Default Re: openSuSe 11.4 SuSefirewall2 init and setup

    Hi!
    I've the same problem, but in my case the reason is different:

    Code:
    chkconfig SuSEfirewall2_init on
    insserv: FATAL: service syslog is missed in the runlevels 4 to use service vboxdrv
    insserv: exiting now!
    /sbin/insserv failed, exit code 1
    So, i'm going to try again removing at first VirtualBox.

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •