Results 1 to 5 of 5

Thread: Settings for laptop monitor with external VGA display - Opensuse 11.3-Gnome

  1. #1

    Default Settings for laptop monitor with external VGA display - Opensuse 11.3-Gnome

    Hi to everyone!
    I'd like to solve a little problem that I have connecting my notebook with an external VGA monitor.
    Everything seems to work fine, but when I close the laptop monitor, also the external monitor shuts down.
    I've tried to find different energy-saving setting for laptop display and external monitor. with no luck...
    My video card is an ATI Radeon Xpress 200M. On the ATI website there is no catalist control center for linux. (It would be very useful). So, for now, I can only use the display options on the panel.
    Please, note that I use Opensuse 11.3 with Gnome.
    I accept all of your suggest!
    Thanks

  2. #2
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    1,175

    Default Re: Settings for laptop monitor with external VGA display - Opensuse 11.3-Gnome

    I don't know about GNOME but in KDE in the Power Management settings we can can tell it so when the laptop lid is closed to do nothing (don't turn off screen/sleep/etc...) - I would assume there would be something similar in the GNOME power management settings. AFAIK this will leave both screens (laptop and external monitor on). If you wanted to still turn off the laptop screen when the lid is closed but leave the external monitor on I wouldn't know how to do that.
    Mageia 2 x86_64 - KDE 4.8.5
    Mageia Cauldron x86_64 - KDE 4.10 beta1

  3. #3

    Default Re: Settings for laptop monitor with external VGA display - Opensuse 11.3-Gnome

    I've solved my problem. Referring on this website, open terminal and past those two instructions, sudo is not necessary:

    gconftool-2 --type string --set /apps/gnome-power-manager/buttons/lid_ac "nothing"

    gconftool-2 --type string --set /apps/gnome-power-manager/buttons/lid_battery "nothing"
    Now, going on energy saving settings It's possible to set "Do nothing" when the lid is closed. Now, closing the lid, the laptop monitor shuts down an the external vga screen not, as I dreamt!
    Bye!!

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    16,016
    Blog Entries
    14

    Default Re: Settings for laptop monitor with external VGA display -Opensuse 11.3-Gnome

    Quote Originally Posted by sim0ne
    I've solved my problem. Referring on 'this website'
    (http://ubuntuforums.org/showthread.php?t=1430420), open terminal and
    past those two instructions, sudo is not necessary:

    >
    > gconftool-2 --type string --set
    > /apps/gnome-power-manager/buttons/lid_ac "nothing"
    >
    > gconftool-2 --type string --set
    > /apps/gnome-power-manager/buttons/lid_battery "nothing"
    >


    Now, going on energy saving settings It's possible to set "Do nothing"
    when the lid is closed. Now, closing the lid, the laptop monitor shuts
    down an the external vga screen not, as I dreamt!
    Bye!!
    Hi
    You can use the gconf-editor to do the same thing.... Did you try the
    Gnome power management settings to do the same thing?

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.29-0.3-default
    up 3:02, 2 users, load average: 2.42, 0.66, 0.35
    GPU GeForce 8600 GTS Silent - Driver Version: 260.19.26


  5. #5

    Default Re: Settings for laptop monitor with external VGA display -Opensuse 11.3-Gnome

    Quote Originally Posted by malcolmlewis View Post
    Did you try the
    Gnome power management settings to do the same thing?
    Yes, I do, but in power manager setting there were no "do nothing" option, after putting those two commands n the terminal the "do nothing" option appeared.

    Now it works fine, so I can say that the problem is solved!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •