Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Broadcom bcm4313 not working in 11.4 AMD64 Gnome Live RC2

  1. #1

    Default Broadcom bcm4313 not working in 11.4 AMD64 Gnome Live RC2

    Hi forums,

    I recently bought a new HP625 Laptop with SLED 11 preinstalled and got some problems with the wireless on 11.3. I got the recommendation here to try out the RC2 of 11.4, where a driver should be available by default. But the Wireless is not working from the Live CD. I planned to submit a bug-report, but there already is a bugreport for this device, that states that ad-hoc networks are not supported. So, I think the driver should work with the bcm4313.

    lspci:
    Code:
    06:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g LP-PHY [14e4:4727] (rev 01)
    hwinfo --wlan has no results in 11.4, in 11.3, using the "wl" driver:
    Code:
    26: PCI 600.0: 0282 WLAN controller                             
      [Created at pci.318]
      Unique ID: JNkJ.AGWX_IMf7TD
      Parent ID: WL76.ZA3gdk0Ate4
      SysFS ID: /devices/pci0000:00/0000:00:09.0/0000:06:00.0
      SysFS BusID: 0000:06:00.0
      Hardware Class: network
      Model: "Broadcom WLAN controller"
      Vendor: pci 0x14e4 "Broadcom"
      Device: pci 0x4727 
      SubVendor: pci 0x103c "Hewlett-Packard Company"
      SubDevice: pci 0x1483 
      Revision: 0x01
      Driver: "wl"
      Driver Modules: "wl"
      Device File: eth1
      Features: WLAN
      Memory Range: 0xd2100000-0xd2103fff (rw,non-prefetchable)
      IRQ: 17 (no events)
      HW Address: e0:2a:82:45:b8:cd
      Link detected: yes
      WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
      WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 2.484
      WLAN bitrates: 1 2 5.5 6 9 11 12 18 24 36 48 54 7 14.5 21.5 29 43.5 58 65 72
      WLAN encryption modes: WEP40 WEP104 WEP256 WEP128 TKIP CCMP
      WLAN authentication modes: open sharedkey wpa-psk wpa-eap
      Module Alias: "pci:v000014E4d00004727sv0000103Csd00001483bc02sc80i00"
      Driver Info #0:
        Driver Status: wl is active
        Driver Activation Cmd: "modprobe wl"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
      Attached to: #5 (PCI bridge)
    Is there something I need to do to get it to work?

    lsmod tells me, brcm80211 is already loaded.

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,271

    Default Re: Broadcom bcm4313 not working in 11.4 AMD64 Gnome Live RC2

    On 03/02/2011 12:06 PM, BuddelBob wrote:
    >
    > Hi forums,
    >
    > I recently bought a new HP625 Laptop with SLED 11 preinstalled and got
    > some problems with the wireless on 11.3. I got the recommendation here
    > to try out the RC2 of 11.4, where a driver should be available by
    > default. But the Wireless is not working from the Live CD. I planned to
    > submit a bug-report, but there already is a bugreport for this device,
    > that states that ad-hoc networks are not supported. So, I think the
    > driver should work with the bcm4313.
    >
    > lspci:
    >
    > Code:
    > --------------------
    > 06:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g LP-PHY [14e4:4727] (rev 01)
    > --------------------
    >
    > hwinfo --wlan has no results in 11.4, in 11.3, using the "wl" driver:
    >
    > Code:
    > --------------------
    > 26: PCI 600.0: 0282 WLAN controller
    > [Created at pci.318]
    > Unique ID: JNkJ.AGWX_IMf7TD
    > Parent ID: WL76.ZA3gdk0Ate4
    > SysFS ID: /devices/pci0000:00/0000:00:09.0/0000:06:00.0
    > SysFS BusID: 0000:06:00.0
    > Hardware Class: network
    > Model: "Broadcom WLAN controller"
    > Vendor: pci 0x14e4 "Broadcom"
    > Device: pci 0x4727
    > SubVendor: pci 0x103c "Hewlett-Packard Company"
    > SubDevice: pci 0x1483
    > Revision: 0x01
    > Driver: "wl"
    > Driver Modules: "wl"
    > Device File: eth1
    > Features: WLAN
    > Memory Range: 0xd2100000-0xd2103fff (rw,non-prefetchable)
    > IRQ: 17 (no events)
    > HW Address: e0:2a:82:45:b8:cd
    > Link detected: yes
    > WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
    > WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 2.484
    > WLAN bitrates: 1 2 5.5 6 9 11 12 18 24 36 48 54 7 14.5 21.5 29 43.5 58 65 72
    > WLAN encryption modes: WEP40 WEP104 WEP256 WEP128 TKIP CCMP
    > WLAN authentication modes: open sharedkey wpa-psk wpa-eap
    > Module Alias: "pci:v000014E4d00004727sv0000103Csd00001483bc02sc80i00"
    > Driver Info #0:
    > Driver Status: wl is active
    > Driver Activation Cmd: "modprobe wl"
    > Config Status: cfg=no, avail=yes, need=no, active=unknown
    > Attached to: #5 (PCI bridge)
    >
    > --------------------
    >
    >
    > Is there something I need to do to get it to work?
    >
    > lsmod tells me, brcm80211 is already loaded.


    Is the firmware available? Check the output of dmesg.

  3. #3

    Default Re: Broadcom bcm4313 not working in 11.4 AMD64 Gnome Live RC2

    No, it is not available:
    Code:
    [   44.664752] brcm80211: module is from the staging directory, the quality is unknown, you have been warned.
    [   44.675176] brcm80211 0000:06:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    [   44.675185] brcm80211 0000:06:00.0: setting latency timer to 64
    [   45.790965] brcm80211: fail to load firmware brcm/bcm43xx-0.fw
    [   45.795666] brcm80211: Failed to find firmware usually in /lib/firmware/brcm
    [   45.800337] brcm80211 0000:06:00.0: PCI INT A disabled
    [   45.804920] brcm80211: wl_pci_probe: wl_attach failed!
    I have run the script "/usr/sbin/install_bcm43xx_firmware" but it seems to be the wrong firmware. I even tried to manually reload the module. It still can't find the correct firmware.

    Where do I get it? The one provided by the script seems to be for the reverse engineered b43 driver.

  4. #4

    Default Re: Broadcom bcm4313 not working in 11.4 AMD64 Gnome Live RC2

    Ok, I found out, that the firmware is already shipped with package kernel-firmware, but it is broken. Fix is to symlink
    bcm43xx-0.fw -> bcm43xx-0-610-809-0.fw
    bcm43xx_hdr-0.fw -> bcm43xx_hdr-0-610-809-0.fw

    [Bug 673054] The firmware pack needed for the driver 'brcm80211' is miss

    I will risk and install 11.4 RC2 on my laptop. Maybe I'm back whining soon...

  5. #5

    Default Re: Broadcom bcm4313 not working in 11.4 AMD64 Gnome Live RC2

    New system installed and working fine, inclusive wireless and suspend.

    To get the Broadcom wireless working in 11.4 RC2 do as root:
    Code:
    ln -s /lib/firmware/brcm/bcm43xx-0-610-809-0.fw /lib/firmware/brcm/bcm43xx-0.fw
    ln -s /lib/firmware/brcm/bcm43xx_hdr-0-610-809-0.fw /lib/firmware/brcm/bcm43xx_hdr-0.fw
    modprobe -r brcm80211
    modprobe brcm80211
    Thanks for helping!

  6. #6
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,271

    Default Re: Broadcom bcm4313 not working in 11.4 AMD64 Gnome Live RC2

    On 03/02/2011 04:06 PM, BuddelBob wrote:
    >
    > New system installed and working fine, inclusive wireless and suspend.
    >
    > To get the Broadcom wireless working in 11.4 RC2 do as root:
    >
    > Code:
    > --------------------
    >
    > ln -s /lib/firmware/brcm/bcm43xx-0-610-809-0.fw /lib/firmware/brcm/bcm43xx-0.fw
    > ln -s /lib/firmware/brcm/bcm43xx_hdr-0-610-809-0.fw /lib/firmware/brcm/bcm43xx_hdr-0.fw
    > modprobe -r brcm80211
    > modprobe brcm80211
    >
    > --------------------
    >
    >
    > Thanks for helping!


    You are welcome. As you learned, install_bcm43xx_firmware is for b43/b43legacy.
    Brcm80211 uses firmware that is in linux-firmware. Just to complete the
    discussion, wl has the firmware built in and does not use external firmware.

    The link step above is a temporary one. The Broadcom people that do brcm80211
    failed to think ahead, then decided to change the name of the firmware files.
    Unfortunately, the driver and the firmware source are not always in step. They
    should have looked for both sets of names for a period of time. As you can tell,
    I don't have a high opinion of the coders at Broadcom.


  7. #7

    Default Re: Broadcom bcm4313 not working in 11.4 AMD64 Gnome Live RC2

    Argh!

    Came from work, waking up the laptop and encountered a complete system freeze. Got an unbootable system again. Every time the system tries to activate the broadcom chip it will freeze the system immediately. I had to disable the module and am without wireless... again.

    I can't find any information on this issue, so I think it is fine to report it as bug? I am careful now. too many surprises with this HP 625.

  8. #8
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,271

    Default Re: Broadcom bcm4313 not working in 11.4 AMD64 Gnome Live RC2

    On 03/03/2011 11:36 AM, BuddelBob wrote:
    >
    > Argh!
    >
    > Came from work, waking up the laptop and encountered a complete system
    > freeze. Got an unbootable system again. Every time the system tries to
    > activate the broadcom chip it will freeze the system immediately. I had
    > to disable the module and am without wireless... again.
    >
    > I can't find any information on this issue, so I think it is fine to
    > report it as bug? I am careful now. too many surprises with this HP 625.


    Which driver? On the Live CD, it must be brcm80211. If so, and it used to work
    with an earlier version, report it to both Novell and kernel bugzilla as a
    regression. Cross reference the bug reports.

    I seem to recall some hivernate/suspend problems in the wireless mailing list,
    but I don't recall the details as I don't have the hardware.

  9. #9

    Default Re: Broadcom bcm4313 not working in 11.4 AMD64 Gnome Live RC2

    I don't think it is a regression. The driver worked fine until it failed to wake up from suspend (known issue). After that even the Live CD crashes the system when activating wireless. I think the suspend-issue somehow corrupted the wireless chip (firmware?). I have had this error on 11.3 with compat-wireless too.

    I have the bug reported:
    https://bugzilla.novell.com/show_bug.cgi?id=676785

  10. #10
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,271

    Default Re: Broadcom bcm4313 not working in 11.4 AMD64 Gnome Live RC2

    On 03/03/2011 01:06 PM, BuddelBob wrote:
    >
    > I don't think it is a regression. The driver worked fine until it failed
    > to wake up from suspend (known issue). After that even the Live CD
    > crashes the system when activating wireless. I think the suspend-issue
    > somehow corrupted the wireless chip (firmware?). I have had this error
    > on 11.3 with compat-wireless too.
    >
    > I have the bug reported:
    > https://bugzilla.novell.com/show_bug.cgi?id=676785


    Suspend cannot corrupt the firmware. It exists on the disk in a file that is
    only read and loaded into the device. The device stores it in RAM and does not
    save it across boots or even resets. Rebooting gets a fresh copy. Furthermore,
    there are no non-volatile registers on the device that can get corrupted -
    changing any of them is very difficult.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •