Results 1 to 8 of 8

Thread: Logitech wireless keyboard and shift and ctrl keys

  1. #1

    Default Logitech wireless keyboard and shift and ctrl keys

    So Ive had this issue off and on for a while now, but have never really looked to see if others have had it or how I can fix it. Essentially the problem is that kde seems to randomly decide that I am holding down the shift or ctrl key.

    Im using a logitech cordless desktop s510, running openSUSE 11.3 x86_64. Ive had this problem on and off using a couple of different logitech keyboards. The most often time when it happens with the shift key is when im coding, and the control key when Im running a keyboard shortcut.

    I can usually fix the issue by holding down the key that kde thinks is pressed for like 5-10 seconds and releasing, however sometimes I have to unplug and then replug in the usb adapter for kde to get things right. This doesnt happen if im running a non-graphical terminal (thouhg I cant say whether it happens in gnome as I dont have gnome installed) so I am thinking its related to kde. The keyboard can be plugged into other computers and they dont act the same way.

    This gets esspecially annoying when Im coding (because of all the symbols) and generally when the issue occurs. I think it may have something to do with the key being pressed for over a certain length.

    Just wondering if anyone else has seen this issue and if there is a known way to stop it from occurring.

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    11,210

    Default Re: Logitech wireless keyboard and shift and ctrl keys

    sounds like maybe one of the accessibility features of KDE has been
    inadvertently activated...so, try this:

    open Personal Settings - Configure Desktop and go to Workspace
    Appearance and Behavior > Accessibility and make sure every check box
    in all tabs is UNchecked..

    if that doesn't fix it, post again...(when i'll suggest you plug in a
    non-USB keyboard and see if the problem goes away!)

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  3. #3

    Default Re: Logitech wireless keyboard and shift and ctrl keys

    Not exactly sure if I went to the right place, as the menu structure you mention is not what I have in the personal settings window. But I did find an icon for accessibility and there was a tab called keyboard filters, the slow keys was checked so I disabled that, and it appears to have solved the problem. I havent had a lot of time to test it out but so far with slow keys disabled I havent been able to replicate the issue. Thanks for pointing me in the right direction.

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    11,210

    Default Re: Logitech wireless keyboard and shift and ctrl keys

    On 03/03/2011 01:36 AM, baaldemon wrote:
    >
    > Not exactly sure if I went to the right place, as the menu structure you
    > mention is not what I have


    you didn't mention what openSUSE version or desktop environment and
    version you were using, so i assumed you were using what i use (in my
    sig)...apparently you are not, but nonetheless it sounds like you
    found the right spot and turned off the correct irritant..

    come to think of it, i guess you must be using 11.1, as i think it was
    born with "slow keys" activated...

    > Thanks for pointing me in the right direction.


    welcome..

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  5. #5

    Default Re: Logitech wireless keyboard and shift and ctrl keys

    Actually I did mention which version 11.3 x86_64 in my first post, though I did leave out which version of kde I am running, which is 4.4.4

  6. #6
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    11,210

    Default Re: Logitech wireless keyboard and shift and ctrl keys

    sorry, you are correct!!
    but, now that i see you and i are running the same software (except 32
    v 64, which should have no bearing) i'm mystified that my path

    "Personal Settings - Configure Desktop and go to Workspace
    Appearance and Behavior > Accessibility"

    couldn't be followed....perhaps a language problem?

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  7. #7

    Default Re: Logitech wireless keyboard and shift and ctrl keys

    Not a language problem, the selections just arent there. You are running 4.5.5 versus my 4.4.4, so Im guessing they must have moved things around in the personal settings in 4.5.

    Heres what my personal settings page looks like

  8. #8
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    11,210

    Default Re: Logitech wireless keyboard and shift and ctrl keys

    On 03/04/2011 03:06 PM, baaldemon wrote:
    >
    > Heres what my personal settings page looks like [image:
    > http://img231.imageshack.us/img231/4...lsettings.png]


    yep, where yours says "Personal" (right above "About me" and
    "Accessibility") mine says "Workspace Appearance and Behavior"...but,
    what is "About Me" on yours is "Personal Information" on mine, which
    is in the top block "Common Appearance and Behavior"

    i wish the folks programming KDE spent less time on moving stuff
    around and giving it new names and more time on making it less likely
    to puke!

    [i changed from four desktops to two (in "Windows Behavior" > Virtual
    Desktops") a couple of days ago, clicked Apply and instantly had a
    blank desktop, except for the one app i had open (Thunderbird), there
    was no panel, no desktop folder, no clock, no nothing! could not right
    click on the desktop to order a shutdown...could only click to close
    Thunderbird and then see the mouse pointer move....NOTHING
    eles....cool! so, i did Ctrl+Alt+F1, logged in as root and gave a
    shutdown -r now, and hit enter...luckily when it rebooted i had a
    desktop again..]

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •