Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: 'View First Unread' does not work

  1. #1
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,108

    Default 'View First Unread' does not work

    As the title suggests, the 'View First Unread'-button does not work properly since a few days. It will lead me to the first comment on the page that contains the first unread comment instead of the actual first unread comment.

    Tested with the current Firefox on openSUSE and WinXP.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    5,270
    Blog Entries
    3

    Default Re: 'View First Unread' does not work

    Yes, I am seeing the same thing.

    On the first page of a post, it works.

    When the first unread post is on the second or later page, it takes me to the top of that page, rather than to the first unread message.
    opensuse factory; KDE 4.14.1 (main desktop);
    opensuse 13.1, KDE 4.11.5 (laptop);

  3. #3
    Join Date
    Jul 2008
    Location
    Bellevue, WA
    Posts
    14,379

    Default Re: 'View First Unread' does not work

    On Wed, 23 Feb 2011 09:36:02 +0000, gropiuskalle wrote:

    > As the title suggests, the 'View First Unread'-button does not work
    > properly since a few days. It will lead me to the first comment on the
    > page that contains the first unread comment instead of the actual first
    > unread comment.
    >
    > Tested with the current Firefox on openSUSE and WinXP.


    Can you provide me with steps to reproduce the issue? Also, if it makes
    a difference, which threading mode are you using (flat, hybrid, or
    threaded)?

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  4. #4
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,108

    Default Re: 'View First Unread' does not work

    I am using the default threading-mode [simple chronological order] (that is "flat", isn't it?).

    What I do is:

    1. Browse through threads via "What's new?" → "New posts"

    2. Choose a thread I have already read but contains new posts

    3. Click "View first unread"

    What it does:

    It takes me do the first post of the page containing the first unread post

    What it should do:

    Taking me to the first unread post

    As nrickert mentions, it does work when the first unread post is on the first page, but not when it is on page 2, 3 etc.

  5. #5
    Join Date
    Jul 2008
    Location
    Bellevue, WA
    Posts
    14,379

    Default Re: 'View First Unread' does not work

    On Thu, 24 Feb 2011 23:36:02 +0000, gropiuskalle wrote:

    > I am using the default threading-mode [simple chronological order] (that
    > is "flat", isn't it?).
    >
    > What I do is:
    >
    > 1. Browse through threads via "What's new?" → "New posts"
    >
    > 2. Choose a thread I have already read but contains new posts
    >
    > 3. Click "View first unread"
    >
    > What it does:
    >
    > It takes me do the first post of the page containing the first unread
    > post
    >
    > What it should do:
    >
    > Taking me to the first unread post
    >
    > As nrickert mentions, it does work when the first unread post is on the
    > first page, but not when it is on page 2, 3 etc.


    Thanks, that's good to know - will pass this along.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  6. #6
    Join Date
    Jun 2008
    Location
    Connecticut, USA
    Posts
    2,161
    Blog Entries
    1

    Default Re: 'View First Unread' does not work

    This happens to me in Firefox and Chrome, on Windows and ChromeOS.

    I believe this happens in Linux too.
    "Linux provides freedom, problem is most users don't know what it is or how to use it." ~me
    Friends don't let Friends wear red shirts on away parties!
    Linux User #477531 | Danbury Area Computer Society (www.dacs.org)

  7. #7
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,108

    Default Re: 'View First Unread' does not work

    Any news on that issue?

  8. #8
    Join Date
    Jun 2008
    Location
    Connecticut, USA
    Posts
    2,161
    Blog Entries
    1

    Default Re: 'View First Unread' does not work

    Funny, when I tried it with this post, it worked but all of the other threads I tried it on it didn't.
    "Linux provides freedom, problem is most users don't know what it is or how to use it." ~me
    Friends don't let Friends wear red shirts on away parties!
    Linux User #477531 | Danbury Area Computer Society (www.dacs.org)

  9. #9
    Join Date
    Jul 2008
    Location
    Bellevue, WA
    Posts
    14,379

    Default Re: 'View First Unread' does not work

    On Mon, 14 Mar 2011 07:06:01 +0000, gropiuskalle wrote:

    > Any news on that issue?


    Not as of yet.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  10. #10
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,108

    Default Re: 'View First Unread' does not work

    Quote Originally Posted by dragonbite
    Funny, when I tried it with this post, it worked but all of the other threads I tried it on it didn't.
    As mentioned, when a thread has only one page yet or the first unread post is on the first page, it does work. The unwanted behaviour occurs with multiple-page threads only.

    Quote Originally Posted by hendersj
    Not as of yet.
    Awww. Okay. Um. Well, I'm sure you will keep it in your mind.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •