Page 1 of 4 123 ... LastLast
Results 1 to 10 of 40

Thread: Sound not only in the headphones

  1. #1

    Default Sound not only in the headphones

    Hi!

    I have a problem with sound on a laptop (ASUS X52Je). I have sound from the speakers and in headphones when headphones are connected (jack). Earlier on ubuntu (gnome) after connecting headphones, speakers in the laptop is automatically muted.

    I would like that when you plug headphones music was only in them, and after disconnecting automatically returned to the speakers in a laptop.

    I'm using OpenSuse 11.3 (64bit) KDE - all as after a standard installation.

    Please help.

  2. #2
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,336

    Default Re: Sound not only in the headphones

    I had this on a ThinkPad notebook with standard 11.3 64bit KDE or Gnome. In Kmix I also had separate channels for speakers and headphones, do you see that?

    After I upgraded the kernel to 2.6.37 (for other reasons), it changed to muting speakers on plugging in headphones, as you prefer. There are risks to upgrading the kernel and it may not solve your issue. However, that newer kernel comes as standard in 11.4 which is due to be released in March - just a few weeks away.

    In the meantime, you could follow the links and checks in the multimedia forum sticky. Here is the link:

    Thread: Welcome to multimedia sub-area

    One of the links in that post will take you to a troubleshooting guide.

  3. #3
    Christoph Schmees NNTP User

    Default Re: Sound not only in the headphones

    Bocian92 schrieb:
    > Hi!
    >
    > I have a problem with sound on a laptop (ASUS X52Je). I have sound from
    > the speakers and in headphones when headphones are connected (jack).
    > Earlier on ubuntu (gnome) after connecting headphones, speakers in the
    > laptop is automatically muted.
    >
    > I would like that when you plug headphones music was only in them, and
    > after disconnecting automatically returned to the speakers in a laptop.
    >


    in ancient times the jack for audio out used to be equipped with
    a switch ensuring that either the built in speakers or the
    external headphone or amplifier was in operation. Isn't that true
    with your laptop?

    Christoph

    --
    email:
    nurfuerspam -> gmx
    de -> net

  4. #4

    Default Re: Sound not only in the headphones

    I have in kmix : HDA Intel / Master or PCM - there are responsible only for the volume.

    And I could ask for a solution to the problem in each step? (enter commands in a terminal, which file do I edit)

  5. #5
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,336

    Default Re: Sound not only in the headphones

    If you have an internet browser, please first go to the link I gave you above, and go through it! We will require more information from you, and that link will help you provide it.

  6. #6
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,870
    Blog Entries
    30

    Default Re: Sound not only in the headphones

    Quote Originally Posted by Bocian92 View Post
    And I could ask for a solution to the problem in each step? (enter commands in a terminal, which file do I edit)
    Bocian92, in order to give a solution, we need more detail as noted by user consused. To make it easier for you I have quoted below the salient portion out of the multimedia stickie that consused referenced:
    please post in this ... sub-forum, providing in your post the following information:
    • provide the URLs (of a summary webpage) that are created by running the diagnostic script noted here:
      SDB:AudioTroubleshooting - openSUSE - Script to run to obtain detailed information. On openSUSE-11.1 and newer that will ask you to run the script
      Code:
      /usr/sbin/alsa-info.sh
      and select the SHARE/UPLOAD option and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL/website-address that gives. Just the URL/website-address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
      .
      Note if for some reason that gives you no website/url/address then run it with the no-upload option:
      Code:
      /usr/sbin/alsa-info.sh --no-upload
      and post the file /etc/alsa-info.txt it creates to Pastebin.com and press SUBMIT on that site and again post here the URL/website-address it provides.

    .
    ... some clarification on running the script "alsa-info.sh" ... when you run:
    Code:
    /usr/sbin/alsa-info.sh
    you should get something like this (if it asks for an update, select NO):


    followed by this (select the SHARE/UPLOAD option):


    followed by this (its quickest if you simply select 'NO' to seeing the output - you will see it on the web page) :


    followed by this (where in RED is the URL).


    Just post the URL you get (similar to the RED URL in my example, but yours will be different).

    Again, if you can not get that, then run this with the no upload option:
    Code:
    /usr/sbin/alsa-info.sh --no-upload
    which will create the file /tmp/alsa-info.txt. Copy that file and paste it on Pastebin.com and press submit. That will give you a URL address. Please post that URL here.

    Also provide the following:
    • in a terminal, or xterm, or konsole, type: rpm -qa '*alsa*' #and post output here
    • in a terminal, or xterm, or konsole, type: rpm -qa '*pulse*' #and post output here
    • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
    • in a terminal, or xterm, or konsole, type: uname -a #and post output here
    • ...
    • for openSUSE-11.2 or newer, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here


  7. #7

    Default Re: Sound not only in the headphones

    /usr/sbin/alsa-info.sh
    --> upload=true&script=true&cardinfo= !!#############

    rpm -qa '*alsa*'
    Code:
    alsa-oss-1.0.17-29.2.x86_64
    alsa-plugins-1.0.23-1.9.x86_64
    alsa-1.0.23-2.12.x86_64
    alsa-oss-32bit-1.0.17-29.2.x86_64
    alsa-utils-1.0.23-1.8.x86_64
    alsa-plugins-32bit-1.0.23-1.9.x86_64
    rpm -qa '*pulse*'
    Code:
    libpulse0-0.9.21-10.1.1.x86_64
    libxine1-pulse-1.1.18.1-1.37.x86_64
    libpulse-mainloop-glib0-0.9.21-10.1.1.x86_64
    rpm -q libasound2
    Code:
    libasound2-1.0.23-2.12.x86_64
    uname -a
    Code:
    Linux linux-u55o.site 2.6.34.7-0.7-desktop #1 SMP PREEMPT 2010-12-13 11:13:53 +0100 x86_64 x86_64 x86_64 GNU/Linux
    cat /etc/modprobe.d/50-sound.conf
    Code:
    options snd slots=snd-hda-intel,snd-hda-intel
    # u1Nb.yUttYMZUFR7:5 Series/3400 Series Chipset High Definition Audio
    alias snd-card-0 snd-hda-intel
    # NXNs.K3+3qP5NfZ8:ATI Technologies Inc
    alias snd-card-1 snd-hda-intel
    It is all what you need?

  8. #8
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,870
    Blog Entries
    30

    Default Re: Sound not only in the headphones

    Quote Originally Posted by Bocian92 View Post
    Ok, I note your PC is an ASUSTeK K52Je running a 64-bit openSUSE-11.3 with the 2.6.34.7-0.7-desktop kernel and the 'stock' 1.0.22/1.0.23 alsa version with a Conexant 5069 audio hardware codec. I note others on Ubuntu and Red Hat/Fedora have reported this speaker not muting problem with the "Conexant 5069", such as this thread: https://bugzilla.redhat.com/show_bug.cgi?id=612769. I took a look at the HD-Audio-Models.txt file for version 1.0.23 of alsa and noted the option model=ideapad that one Fedora user noted worked, is in fact a model option associated with the "Conexant 5066"
    Code:
    Conexant 5066
    =============
      laptop	Basic Laptop config (default)
      dell-laptop	Dell laptops
      olpc-xo-1_5	OLPC XO 1.5
      ideapad       Lenovo IdeaPad U150
    ... in fact version 1.0.24 of alsa has 'ideapad' as an option for Conexant 5051 also, AND I note 1.0.24 of alsa has "asus" as an option for the Asus K52JU which is 'close' (albeit not the same) as your Hardware.

    Hence IMHO you should update to version 1.0.24 of alsa, with guidance here (which is a bit out of date, but the same philosophy applies) : SDB:Alsa-update - openSUSE ... ie install alsa-driver-kmp-desktop for the 2.6.34.7 kernel and also update alsa-oss, alsa-plugins, alsa, alsa-oss-32bit, alsa-utils, alsa-plugins-32bit and libasound2 per the guidance in that openSUSE alsa update website

    Restart and test. If that does not work, then with that update in place, modify your /etc/modprobe.d/50-sound.conf file so that it looks like:
    Code:
    options snd-hda-intel model=asus
    options snd slots=snd-hda-intel,snd-hda-intel
    # u1Nb.yUttYMZUFR7:5 Series/3400 Series Chipset High Definition Audio
    alias snd-card-0 snd-hda-intel
    # NXNs.K3+3qP5NfZ8:ATI Technologies Inc
    alias snd-card-1 snd-hda-intel
    where you can see I added a line to the front of that file. The location IS important. Restart after saving the edit.

  9. #9

    Default Re: Sound not only in the headphones

    Thank you. All work perfectly.

  10. #10
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,870
    Blog Entries
    30

    Default Re: Sound not only in the headphones

    Quote Originally Posted by Bocian92 View Post
    Thank you. All work perfectly.
    Glad to read it is working now. What did you do to get it working ? Update to 1.0.24 of alsa ? Or did you just modify the /etc/modprobe.d/50-sound.conf file ? or both ?

Page 1 of 4 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •