Results 1 to 6 of 6

Thread: Update openSUSE 11.4. KDE

  1. #1
    Join Date
    Jul 2010
    Location
    Prague
    Posts
    148

    Red face Update openSUSE 11.4. KDE

    Today update offers me 352 packages but nothing provides libxml2.so.2(LIBXML2_2.4.30) needed by gstreamer-0_10-0.10.32-1000.pm.1000.1.i586
    nothing provides libxml2.so.2(LIBXML2_2.4.30) needed by libgstreamer-0_10-0-0.10.32-1000.pm.1000.1.i586
    nothing provides libxml2.so.2(LIBXML2_2.4.30) needed by gstreamer-0_10-plugins-base-0.10.32-999.pm.1005.1.i586
    libeXosip2-4-3.1.0-52.5.i586 requires libosipparser2.so.3, but this requirement cannot be provided
    libxine1-codecs-1.1.19-2.pm.48.15.i586 requires libcdio.so.10, but this requirement cannot be provided. I cannot find above mentioned packages. Can anybody help me?

  2. #2
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    602

    Default Re: Update openSUSE 11.4. KDE

    What do you mean by "11.4"? Are you using a Milestone or one of the Factories? And what "update" do you mean? YaST update for 11.4 (factory) only has test updates.

    Do not try to use the Packman 11.3 gstreamer. The gstreamer packages from OBS Factory work. If you absolutely need to use the Packman repositories before there is a Packman 11.4, you might try Packman factory.

  3. #3
    Join Date
    Jul 2010
    Location
    Prague
    Posts
    148

    Default Re: Update openSUSE 11.4. KDE

    Thank you, I hope to be solved.

  4. #4
    Join Date
    Jun 2008
    Location
    Stoney Stanton - England
    Posts
    762

    Default Re: Update openSUSE 11.4. KDE

    There are two packman factory repos that you can use for 11.4. These are:-

    Index of /suse/Factory/Essentials

    and

    Index of /suse/factory

    Would suggest that you add both - as they have different updated rpm packages. The repos are not full but include all that is need to install vlc, mplayer & xine.

    The main thing missing is k3b-codecs but you can get this from the packman 11.3 repo at:-

    PackMan :: Package details for k3b

    My posting assumes that you are using one of the recent milestone releases for 11.4 and kde 4.6

  5. #5
    Join Date
    Jun 2008
    Location
    Cambridge, UK
    Posts
    53

    Default Re: Update openSUSE 11.4. KDE

    I was unable to install mplayer and vlc on 11.4-milestone5 due to missing dependencies, couldn't find a packman repo for 11.4, found this thread, so am sorted out now, thanks!
    --
    Cambridge geek, will code for gadgets

  6. #6

    Default Re: Update openSUSE 11.4. KDE

    Hi, I have recently upgraded to openSUSE_11.4 I am using factory repo(s) however, not milestone.

    I managed to get bombono-dvd working to rip dvds and then burn them, however I am getting different errors still related mysteriously to the libxml2.so libraries when running any kind of player including firefox embedded, the errors relate to gstreamer from the packman factory repos aforementioned, however the gstreamer package is not the culprit, the error is also related to the libxml2 package from openSUSE_Factory repo.

    I am currently using libxml2-2.7.8-46.4.x86_64 from devel:libraries:c_c++/openSUSE_Factory

    before this I was using libxml2-2.7.8-15.5.x86_64.rpm from XML/xml-factory


    both the versions of this package giver errors on the start of programs like totem or

    rhythmbox: /usr/lib64/libxml2.so.2: no version information available (required by /usr/local/lib/libgstreamer-0.10.so.0)

    always the same error.

    anyclues?

    jasonsmr@hotmail.com

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •