Results 1 to 8 of 8

Thread: Audio HDMI with Youtube issue

  1. #1
    Join Date
    Mar 2009
    Location
    Canberra, Australia
    Posts
    38

    Unhappy Audio HDMI with Youtube issue

    The issues I am having are with a new mini-itx Gigabyte GA-HN55N-USB3 motherboard put in the loungeroom as the main mythtv box. This is connected via hdmi to a Panasonic Viera plasma TV. This mb is an intel based board with an Intel Core i3 series processor, and Realtek ALC892R codec, HD audio etc.

    I am running mythtv-0.24-0.pm.6.2-X86_64 (binary packages from packman), one package Mythnetvision does have video but no audio when accessing youtube etc.
    Similarly if I run Firefox and go to youtube, I have video and also no sound. (An element to using mythnetvision which is still in beta, is a working flash install which I do have). I do have full sound available for music, TV recordings, and videos, which is great.

    I have been running opensuse 11.3 and do fairly regular updates, I have 3 other PC's based on Gigabyte motherboards with AMD Athlon(tm) 64 X2 Dual Core Processor 5200+ and Nvidia cards. On each of these I can run any of the multimedia applications, including mythtv, and Youtube on Firefox and sound is OK via the onboard soundcards using basic computer stereo speakers.

    To test the mini-itx further I connected a standard pc screen, together with a pair of pc stereo speakers to the line out jack (green) I then got all sound I wanted, mythnetvision accessing youtube etc. as well as Youtube on Firefox.

    I have read and tried a number of suggestions from the forums in adjusting the order of the playback settings in KDE Personal settins/computer administration/multimedia but have had no luck.

    Here are the details:
    OS opensuse 11.3 x86_64
    KDE 4.4.4 (KDE 4.4.4) "release 3"
    motherboard audio 1. Realtek ALC892 codec
    2. High Definition Audio
    3. 2/4/5.1/7.1-channel
    4. Support for S/PDIF Out
    /usr/sbin/alsa-info.sh has been posted at:
    http://www.alsa-project.org/db/?f=dc...2e13f3544cdbc5

    rpm -qa '*alsa*'
    alsamixergui-0.9.0rc1-746.1.x86_64
    alsa-plugins-pulse-1.0.23-1.9.x86_64
    alsa-firmware-1.0.24.1-11.2.noarch
    pyalsaaudio-0.6-2.pm.2.1.x86_64
    alsa-plugins-samplerate-1.0.24-36.2.x86_64
    alsa-utils-1.0.23-1.8.x86_64
    alsa-plugins-speex-1.0.24-36.2.x86_64
    Performous-plugin-alsa-0.5.1-0.pm.3.25.x86_64
    pyalsa-1.0.22-1.8.x86_64
    projectM-libvisual-alsa-2.0.1-1.pm.2.1.x86_64
    alsa-tools-gui-1.0.23-1.8.x86_64
    alsa-1.0.24.1-79.1.x86_64
    alsa-plugins-1.0.24-36.2.x86_64
    alsa-devel-1.0.24.1-79.1.x86_64
    java-1_6_0-sun-alsa-1.6.0.u23-0.2.1.x86_64
    alsa-oss-1.0.17-56.14.x86_64
    alsa-plugins-samplerate-32bit-1.0.24-36.2.x86_64
    alsa-tools-1.0.23-1.8.x86_64


    mythtv@lounge:~> rpm -qa '*pulse*'
    alsa-plugins-pulse-1.0.23-1.9.x86_64
    libpulse-mainloop-glib0-0.9.21-10.1.1.x86_64
    libpulse0-0.9.21-10.1.1.x86_64
    libpulse-browse0-0.9.21-10.1.1.x86_64
    libpulse-mainloop-glib0-32bit-0.9.21-10.1.1.x86_64
    libpulse0-32bit-0.9.21-10.1.1.x86_64
    pulseaudio-0.9.21-10.1.1.x86_64
    pulseaudio-utils-0.9.21-10.1.1.x86_64

    rpm -q libasound2
    libasound2-1.0.24.1-79.1.x86_64

    uname -a
    Linux lounge 2.6.34.7-0.7-default #1 SMP 2010-12-13 11:13:53 +0100 x86_64 x86_64 x86_64 GNU/Linux

    I have checked sound card settings in Yast2 and can get no sound , with hdmi connected, can get sound when I used the line out and stereo speakers.

    If I try to use kmix it generally crashes.

    I hope this may give some of the kind people here enough info to advice me, if there is anything I have missed please ask.

    john

  2. #2
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    3,036

    Default Απ: Audio HDMI with Youtube issue

    I had the same problem with youtube videos. I had no sound. I fixed it with alsamixer. Download alsamixer through yast, then write alsamixer in terminal and increase the sound bars.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE 12,3||x86_64||KDE 4.10.5||AMD PHENOM II X3||AMD RADEON 6990.
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  3. #3
    Join Date
    Jun 2008
    Location
    United Kingdom
    Posts
    5,328

    Default Re: Απ: Audio HDMI with Youtube issue

    Quote Originally Posted by stamostolias View Post
    Download alsamixer through yast...
    AFAIK alsamixer is already installed on 11.3 by default. You just need to run it from a terminal as a normal user.

  4. #4
    Join Date
    Mar 2009
    Location
    Canberra, Australia
    Posts
    38

    Default Re: Απ: Audio HDMI with Youtube issue

    Thanks for the response guys.

    I have Alsamixer installed and have maximum volume on Master, PCM, Front, Surround, Centre, LFE, Line, CD the 4 Spdif tabs are green but with no volume and cannot be adjusted.

    I would appreciate any other ideas or advice.

    John

  5. #5

    Default Re: Απ: Audio HDMI with Youtube issue

    You need to create /etc/asound.conf and paste this in there:

    Code:
     pcm.!default {
          type plug
          slave.pcm {
                  type hw
                  card 0
                  device 3
          }
     }
    If that doesn't work then change device 3 to device 7,

  6. #6

    Default Re: Audio HDMI with Youtube issue

    Have a look on your tv connection to hdmi. On my samsung there are some adjustment you have to make. This tv I am using has a pc port, two hdmi and a hdmi/dvi port. I am not sure with your panasonic plasma connection but here using hdmi, there are options like hdmi---pc, hdmi --- and hdmi/dvi --- dvi pc. If you have the manual of your tv and this options are present you will be able to determine which one to use. It might be the missing link regarding your sound.
    People who do not break things first will never learn to create anything

  7. #7
    Join Date
    Mar 2009
    Location
    Canberra, Australia
    Posts
    38

    Red face Re: Απ: Audio HDMI with Youtube issue

    Quote Originally Posted by londy View Post
    You need to create /etc/asound.conf and paste this in there:

    Code:
     pcm.!default {
          type plug
          slave.pcm {
                  type hw
                  card 0
                  device 3
          }
     }
    If that doesn't work then change device 3 to device 7,
    Hi Londy,

    Thanks for that detail.

    It appears to have solved my problem.

    I had previously read about using an .asoundrc file but I hadn't managed to succeed with getting it to work.

    Needless to say I am grateful for your assistance.

    Best wishes,

    John

  8. #8
    Join Date
    Mar 2009
    Location
    Canberra, Australia
    Posts
    38

    Default Re: Audio HDMI with Youtube issue

    Quote Originally Posted by conram View Post
    Have a look on your tv connection to hdmi. On my samsung there are some adjustment you have to make. This tv I am using has a pc port, two hdmi and a hdmi/dvi port. I am not sure with your panasonic plasma connection but here using hdmi, there are options like hdmi---pc, hdmi --- and hdmi/dvi --- dvi pc. If you have the manual of your tv and this options are present you will be able to determine which one to use. It might be the missing link regarding your sound.
    Hi Conran,

    Thank you for advice here, I had a closer look at the (rather brief) Panasonic manual and it appears that if I used a DVI to HDMI connection I could supplement it with an audio cable, although I have been using a HDMI<> HDMI cable. That would probably work, however as mentioned above by Londy, the creation of the /etc/asound.conf file is working well.

    I do however appreciate your suggestion and you taking the time to respond.

    Kind regards,

    John

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •