Results 1 to 6 of 6

Thread: Desktop mirrored on KDE4 Desktop

  1. #1

    Default Desktop mirrored on KDE4 Desktop

    Turned on my computer this morning only to have my desktop come up as if I was looking in a mirror. The icons and taskbar etc are in the correct places, only everything is a mirror image. This is a per user problem as my wife's account is fine. I have tried deleting all of the plasma files in the ./config directory with no luck.

    KDE 4.5 on openSUSE 11.3
    NVidia graphics if that matters

  2. #2

    Default Re: Desktop mirrored on KDE4 Desktop

    Hello msharnden,

    Quote Originally Posted by msharnden
    Turned on my computer this morning only to have my desktop come up as if I was looking in a mirror. The icons and taskbar etc are in the correct places, only everything is a mirror image. This is a per user problem as my wife's account is fine. I have tried deleting all of the plasma files in the ./config directory with no luck.

    KDE 4.5 on openSUSE 11.3
    NVidia graphics if that matters
    Strange problem, have a look under System Settings->General->Display.
    Select Size & orientation and make sure that Orientation is set to No rotation.

    If it's set to no rotation you can set it to Mirror horizontal/vertical to undo the effect.

    I recommend if the mirror is even without the KDE setting to check nvidia's control centre (<- not sure about the name) for any mirror setting.

    Good luck!
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

  3. #3

    Default Re: Desktop mirrored on KDE4 Desktop

    Well it turned out to be Desktop Effects. Now to figure out which one is causing the problem.

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    11,210

    Default Re: Desktop mirrored on KDE4 Desktop

    strange--you didn't happen to fiddle with any locale or language
    settings which might have resulted in right to left direction reading
    environment....like hebrew, arabic etc...??

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 11.3, KDE4.5.5
    "release 1", Thunderbird3.0.11,]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  5. #5

    Default Re: Desktop mirrored on KDE4 Desktop

    Quote Originally Posted by DenverD View Post
    strange--you didn't happen to fiddle with any locale or language
    settings which might have resulted in right to left direction reading
    environment....like hebrew, arabic etc...??
    Nope, for once I hadn't been fiddling for a while. Turns out is was OpenGL. If I changed the composting type to XRender the problem went away. I updated to the newest NVidia driver and have switched back to OpenGL without any problems so far.

  6. #6
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    11,210

    Default Re: Desktop mirrored on KDE4 Desktop

    On 01/30/2011 08:06 PM, msharnden wrote:
    > without any problems so far.


    very happy you found the solution, because it was a problem i had
    never heard before..

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 11.3, KDE4.5.5
    "release 1", Thunderbird3.0.11,]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •