Results 1 to 6 of 6

Thread: Cannot enter home directory

  1. #1

    Default Cannot enter home directory

    hi there,

    i'm having problem booting my opensuse installation.

    The hole story:

    I installed windows7 after installing opensuse 11.3. I knew this would mess up my bootloader but i thought fixing it would be easy with this guide - (part2, Using Ubuntu 9.10 livecd or higher: How to restore Grub 2 after reinstalling Windows XP/Vista/Win7) - which has worked for several times using ubuntu.
    Unfortunately this doesn't work on opensuse, so i fell back to this guide (openSuse dual boot loader gone after Windows reinstallation)
    which comes down to this (this is what i did)
    grub (ENTER)
    grub> find /boot/grub/stage1 (ENTER)
    > (hd0,5)
    grub> root (hd0,5) (ENTER)
    >Filesystem type is ext3fs, partition type 0x83 //partition type may be different, don't remember the exact output
    grub> setup (hd0) (ENTER)
    after rebooting opensuse doesn't log me in with an error like in this post (Cannot Login (Can't Mount Something))
    again for me:

    Login in yokist. Cannot enter home directory. Using /
    //pressing ok
    kstartupconfig4 does not exist or fails. The error code is 3, Check your installation.

    I tried (as mentioned in the 3rd thread (http://forums.opensuse.org/forums/en...mething.html):

    Mount your root partition of openSUSE
    And navigate to /etc/fstab

    In that folder /etc
    there may also be a old file fstab.old

    You need to rename the file fstab to fstab.bak
    and the file fstab.old to fstab
    but there is no fstab.old, just my normal fstab

    actually i'm not that noobish on opensuse/linx anymore, but i have no clue how to fix this. i want to avoid reinstalling opensuse though.

    cheers

  2. #2

    Default Re: Cannot enter home directory

    My first thought was "reinstall openSuse"
    In the installation, you installed the Root directory on a separate partition from the home directory?
    If you did, did you write down/remember what /dev/sda? the home directory was? If you do, just mount it using
    Code:
    mkdir /media/home
    mount /dev/sda? /media/home
    If that works, then worry about fstabbing it. If it doesn't, you have bigger problems on your hands.
    Vaio F11: i7-720QM 8GB RAM Nvidia GT 330m
    Win 7 Pro 64 bit | openSuse 11.4 64 bit | Arch Linux 64 bit

  3. #3

    Default Re: Cannot enter home directory

    Quote Originally Posted by yokist View Post
    I installed windows7 after installing opensuse 11.3. I knew this would mess up my bootloader but i thought fixing it would be easy with this guide - (part2, Using Ubuntu 9.10 livecd or higher: How to restore Grub 2 after reinstalling Windows XP/Vista/Win7) - which has worked for several times using ubuntu.
    Unfortunately this doesn't work on opensuse.
    This is normal. Ubuntu uses Grub2 and openSUSE Legacy Grub. They are different programs.


    Quote Originally Posted by yokist View Post
    but there is no fstab.old, just my normal fstab
    Then you have to edit /etc/fstab and write the correct devices there.


    Quote Originally Posted by yokist View Post
    actually i'm not that noobish on opensuse/linx anymore, but i have no clue how to fix this. i want to avoid reinstalling opensuse though.
    First boot from a live CD, open a terminal, and post the output of :
    Code:
    su -l
    fdisk -l
    Further mount (hd0,5) and show us your /etc/fstab:
    Code:
    su -l
    mount /dev/sda6 /mnt
    cat /mnt/etc/fstab

  4. #4

    Default Re: Cannot enter home directory

    hi,

    thank you for your responses.

    In the installation, you installed the Root directory on a separate partition from the home directory?
    If you did, did you write down/remember what /dev/sda? the home directory was? If you do, just mount it using
    yes i have installed root on a separate partition. actually i have two /home partitions. Old one on sda7-(hd0,6), and home in use on sda8-(hd0,7)

    fdisk partitions

    linux:~ # fdisk -l

    Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
    255 heads, 63 sectors/track, 121601 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x06850684

    Device Boot Start End Blocks Id System
    #windows boot
    /dev/sda1 * 1 13 102400 7 HPFS/NTFS
    Partition 1 does not end on cylinder boundary.
    #windows system
    /dev/sda2 13 5211 41746432 7 HPFS/NTFS
    #logical partition
    /dev/sda3 5211 121602 934912000 f W95 Ext'd (LBA)
    #swap
    /dev/sda5 5211 5746 4297387 82 Linux swap / Solaris
    #opensuse root /
    /dev/sda6 5746 10315 36706304 83 Linux
    #opensuse home (old)
    /dev/sda7 10315 115354 843726061+ 83 Linux
    #opensuse home to use containing folder yokist
    /dev/sda8 115355 119924 36702208 83 Linux
    fstab

    linux:~ # mount /dev/sda6 /mnt/sda6/
    linux:~ # cat /mnt/sda6/etc/fstab
    disk/dev/disk/by-id/ata-SAMSUNG_HD103UJ_S13PJ1LS711954-part5 swap swap defaults 0 0
    /dev/disk/by-id/ata-SAMSUNG_HD103UJ_S13PJ1LS711954-part6 / ext4 acl,user_xattr 1 1
    /dev/disk/by-id/ata-SAMSUNG_HD103UJ_S13PJ1LS711954-part8 /home ext4 acl,user_xattr 1 2
    /dev/disk/by-id/ata-SAMSUNG_HD103UJ_S13PJ1LS711954-part1 /windows/boot ntfs-3g ro,user,noauto,users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
    /dev/disk/by-id/ata-SAMSUNG_HD103UJ_S13PJ1LS711954-part2 /windows/system ntfs-3g rw,user,noauto,users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
    /dev/disk/by-id/ata-WDC_WD7500AACS-00D6B0_WD-WCAU42783564-part1 /media/backup_hd ntfs-3g rw,user,noauto,users,umask=000 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    debugfs /sys/kernel/debug debugfs noauto 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0

  5. #5

    Default Re: Cannot enter home directory

    I don't see anything wrong here.
    Try to boot in runlevel 3 (console mode). To do that, append "3" preceeded by space to the options (at bottom of Grub screen) and press enter on the normal openSUSE entry (not failsafe). You will get a console login prompt. Login as root (it should work) and type:
    Code:
    mount
    Write down the output of this command and post it later when you return here.
    Then type exit to log out and login as user. Do you get error messages at this point? If so, which ones?

  6. #6

    Default Re: Cannot enter home directory

    hi,
    thanks great, that was it.

    my fstab apparently had the wrong entry for my home dir (my old one with other username) listed. I have no idea how that could happen.

    so it should have been

    ...
    /dev/disk/by-id/ata-SAMSUNG_HD103UJ_S13PJ1LS711954-part7 /home ext4 acl,user_xattr 1 2
    ...
    instead of

    ...
    /dev/disk/by-id/ata-SAMSUNG_HD103UJ_S13PJ1LS711954-part8 /home ext4 acl,user_xattr 1 2
    ...
    i fixed it and it works now.

    thanks again

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •