Results 1 to 4 of 4

Thread: How to enable autologin with Xfce

  1. #1

    Default How to enable autologin with Xfce

    Hi,

    I'm using openSUSE 11.3 with Xfce 4.7.0 and I want to enable automatic login. What I have tried so far:

    1) YaST -> User and Group Management -> Expert Options -> Login Settings. This didn't work because I have no "Login Settings" option in this menu.

    2) Editing variables "DISPLAYMANAGER_AUTOLOGIN" and "DISPLAYMANAGER_PASSWORD_LESS_LOGIN" via YaST -> /etc/sysconfig Editor. This didn't work too and xdm was still asking about name and password no matter what I set here.

    3) I don't know how to configure xdm, so I tried to replace xdm with gdm. Gdm worked, but application "gdmsetup" was missing from my installation (YaST simply don't offer this package) and I don't know how to set up gdm manually, so I ended without autologin again.

    Any ideas? I'm very lazy and I really don't want to type my name and password every time, not to mention that Xfce login screen in SUSE 11.3 looks really bad :-(

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    14,023
    Blog Entries
    12

    Default Re: How to enable autologin with Xfce

    /etc/sysconfig/displaymanager : DISPLAYMANAGER_AUTOLOGIN="YOUR_USER_NAME_HERE". Should work on at least kdm en gdm. Mind, you do need a reboot.......

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    15,958
    Blog Entries
    14

    Default Re: How to enable autologin with Xfce

    Quote Originally Posted by bumbicek

    2) Editing variables "DISPLAYMANAGER_AUTOLOGIN" and
    "DISPLAYMANAGER_PASSWORD_LESS_LOGIN" via YaST -> /etc/sysconfig Editor.
    This didn't work too and xdm was still asking about name and password no
    matter what I set here.

    3) I don't know how to configure xdm, so I tried to replace xdm with
    gdm. Gdm worked, but application "gdmsetup" was missing from my
    installation (YaST simply don't offer this package) and I don't know how
    to set up gdm manually, so I ended without autologin again.

    Any ideas? I'm very lazy and I really don't want to type my name and
    password every time, not to mention that Xfce login screen in SUSE 11.3
    looks really bad :-(
    Hi
    In the DISPALYMANAGER you user your username, you don't need to touch
    the password one. Then in the windowmanager you need to use startxfce4
    as the parameter.

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (i586) Kernel 2.6.32.24-0.2-pae
    up 2 days 21:02, 2 users, load average: 0.21, 0.08, 0.01
    ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME


  4. #4

    Default Re: How to enable autologin with Xfce

    Thank you guys, problem solved. "DISPLAYMANAGER_AUTOLOGIN" AND gdm was the right combination (with xdm this didn't work).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •