Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: VLC media player - screensaver still comes on

  1. #1
    Join Date
    Oct 2008
    Location
    South Africa
    Posts
    148

    Default VLC media player - screensaver still comes on

    Hi Everyone,

    This week I've installed openSUSE 11.3 and it works like a dream. My only problem is that when I watch DVD's or video files, my screensaver still comes on. Yes I know that some of you don't like screensavers on your systems, but I like my good old screensaver.

    I know with SMPlayer there is an option under the preferences to disable the screensaver with video playback. I can't find such an option in the preferences for VLC.

    Any suggestions?

    Many thanks

    henkasdf
    Those who never try never fly!
    Box: openSUSE 11.4 x64 | KDE 4.6 | Intel DG41RQ | Intel Core 2 Quad 2.4 | nVIDIA 8400GS | 4GB RAM
    Note: Windows 7 | SP-1 | Intel Centrino Duo 1.7 | Intel 945GM | LG-F1 | 2GB RAM

  2. #2
    Join Date
    Oct 2008
    Location
    South Africa
    Posts
    148

    Default Re: VLC media player - screensaver still comes on

    Hi Evereryone,

    I have found the solution:

    #
    1

    Open VLC media player. For example, in Ubuntu 10.04 click "Main Menu," hover over "Sound and Video," and then click "VLC Media Player."
    #
    2

    Click "Tools" and then "Preferences" in the VLC toolbar. VLC displays the "Simple" or beginners' preferences and settings interface by default.
    #
    3

    Click the "All" radio (round) button at the bottom left corner of the window. This expands the settings options to include advanced VLC features.
    #
    4

    Click "Video" in the expanded menu on the left side of the window. Check the box next to "Disable Screensaver" under "General Video Settings" on the right.
    #
    5

    Click the "Save" button to activate the new settings and close the VLC preferences window. Now the screen saver will be disabled during any type of video playback.


    Read more: How to Disable the Screensaver in VLC | eHow.com How to Disable the Screensaver in VLC | eHow.com
    Those who never try never fly!
    Box: openSUSE 11.4 x64 | KDE 4.6 | Intel DG41RQ | Intel Core 2 Quad 2.4 | nVIDIA 8400GS | 4GB RAM
    Note: Windows 7 | SP-1 | Intel Centrino Duo 1.7 | Intel 945GM | LG-F1 | 2GB RAM

  3. #3
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    1,704

    Default Re : Re: VLC media player - screensaver still comes on

    Oh! Thanks, i didn't know this one.

  4. #4
    Join Date
    Oct 2008
    Location
    South Africa
    Posts
    148

    Default Re: Re : Re: VLC media player - screensaver still comes on

    Quote Originally Posted by DaaX View Post
    Oh! Thanks, i didn't know this one.
    Hi,

    Unfortunately when I went to that setting it was already set to "Disable screen saver". Now I don't know what to do. I've unchecked it and applied the settings and I've rechecked and apllied it but the screen saver still comes on. When I use SMplayer though, I can watch a DVD straight through without the screen saver coming on.

    Any suggestions as to why this is happening?

    Many thanks

    henkasdf
    Those who never try never fly!
    Box: openSUSE 11.4 x64 | KDE 4.6 | Intel DG41RQ | Intel Core 2 Quad 2.4 | nVIDIA 8400GS | 4GB RAM
    Note: Windows 7 | SP-1 | Intel Centrino Duo 1.7 | Intel 945GM | LG-F1 | 2GB RAM

  5. #5
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,735

    Default Re: Re : Re: VLC media player - screensaver still comes on

    Quote Originally Posted by henkasdf View Post
    Hi,

    Unfortunately when I went to that setting it was already set to "Disable screen saver". Now I don't know what to do. I've unchecked it and applied the settings and I've rechecked and apllied it but the screen saver still comes on. When I use SMplayer though, I can watch a DVD straight through without the screen saver coming on.

    Any suggestions as to why this is happening?

    Many thanks

    henkasdf
    Had the same problem. As far as I know it was some sort of bug in KDE power management. For me it depended on the KDE version. As far as I remember it was working well in KDE 4.4 and it wasn't in KDE 4.3. It is working fine for me in KDE 4.5.

    Best regards,
    Greg

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    37,035
    Blog Entries
    16

    Default Re: Re : Re: VLC media player - screensaver still comes on

    Which is why I use smplayer. Do you not like it or something.
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,735

    Default Re: Re : Re: VLC media player - screensaver still comes on

    Quote Originally Posted by caf4926 View Post
    Which is why I use smplayer. Do you not like it or something.
    The option to disable screensaver wasn't working in smplayer for me as well in the buggy KDE versions so that actually didn't depend on the player.

  8. #8
    Join Date
    Oct 2008
    Location
    South Africa
    Posts
    148

    Default Re: Re : Re: VLC media player - screensaver still comes on

    Quote Originally Posted by caf4926 View Post
    Which is why I use smplayer. Do you not like it or something.
    I just prefer VLC above SMplayer that's all, I've been using it for about 2 years and I'm very happy with it. I have SMplayer installed though.

    I must admit that my previous installation of openSUSE 11.2 was a lot more stable than my current 11.3 . Do you suggest I upgarde to KDE 4.5?

    Thanks a lot for your friendly and helpful advice always!

    henkasdf
    Those who never try never fly!
    Box: openSUSE 11.4 x64 | KDE 4.6 | Intel DG41RQ | Intel Core 2 Quad 2.4 | nVIDIA 8400GS | 4GB RAM
    Note: Windows 7 | SP-1 | Intel Centrino Duo 1.7 | Intel 945GM | LG-F1 | 2GB RAM

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    37,035
    Blog Entries
    16

    Default Re: Re : Re: VLC media player - screensaver still comes on

    @henkasdf
    Upgrade is personal choice really. If what you have is working well, stick with it. And just ATM I am not doing updates on my kde4.5 because I'm unsure what is happening to some of the packages there (namely: amarok). I didn't get a definite answer to my question in the IRC either. But currently amarok has been withdrawn from R45 repo.
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

  10. #10
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,735

    Default Re: Re : Re: VLC media player - screensaver still comes on

    Quote Originally Posted by henkasdf View Post
    I just prefer VLC above SMplayer that's all, I've been using it for about 2 years and I'm very happy with it. I have SMplayer installed though.

    I must admit that my previous installation of openSUSE 11.2 was a lot more stable than my current 11.3 . Do you suggest I upgarde to KDE 4.5?

    Thanks a lot for your friendly and helpful advice always!

    henkasdf
    I think You could try to upgrade and see if this resolves the screensaver issue. If not than downgrade is fairly easy to do. I prefer 4.5 but that's a matter of personal preference I guess.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •