Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Alle geluiden gaan veel te snel

  1. #1

    Default Alle geluiden gaan veel te snel

    Beste forumbezoekers,

    Sinds een week of 3 heb ik OpenSUSE 11.3 KDE geinstalleerd op mijn laptop. Hiervoor heb ik Windows Vista en Ubuntu 9.10 & 10.04 gehad. Het probleem dat ik heb bij OpenSUSE is dat alle geluiden die worden afgespeeld, ook het OpenSUSE opstartgeluid, Youtube en alle muziek, veel te snel gaan. Hij speelt zo'n 5 tot 8 seconden geluid in 1 seconde af. En ik merk dat als ik met de scroll van mijn muis speel dat het dan nog harder gaat. Maar als ik niets doe, speelt hij het ook te snel af. Deze problemen had ik niet bij de andere OSen.

    Ik ben eigenlijk best wel een leek als het op systeem informatie zoeken aan komt, en heb echt geen idee wat ik kan doen om jullie te helpen met mijn probleem. Dus als jullie me willen helpen, zouden jullie dat dan aardig gedetailleerd willen beschrijven?

    Met vriendelijke groet,
    Ben

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    14,084
    Blog Entries
    12

    Default Re: Alle geluiden gaan veel te snel

    Dag Ben, van harte welkom hier,

    Het vermoeden rijst dat je de multimedia pakketten nog niet genstalleerd hebt. Hier Mutlimedia - Packman in het Kort staat hoe je alle codecs kunt installeren.
    Een andere mogelijkheid is dat er een probleem is met de driver van je geluidskaart, om daarachter te komen hebben we wat meer info van je nodig, voer onderstaande commando's uit in een terminal venster, en kopier de output hier:
    Code:
    /sbin/lspci -nnk
    en
    Code:
    uname -a
    - Athlon X6 3.6 GHz, 16 GB DDR3, 64 GB SSD, 3 TB of disks, GT540, openSUSE Factory + KDE
    - ASUS A73SD, Intel + GT610M Optimus, 6 GB, 2 x 120 GB SSD, openSUSE Factory + KDE

    Anything that can go wrong.... will teach us

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Alle geluiden gaan veel te snel

    Bedankt voor die handleiding, Knurpht. Volgens mij heb ik daar eerder al wat mee gedaan, aangezien de helft van de pakketten al wel waren geinstalleerd. Helaas heeft dit niet het probleem opgelost, geluiden worden nog steeds te snel afgespeeld.

    Code:
    ben@linux-a6dq:~> /sbin/lspci -nnk
    00:00.0 Host bridge [0600]: ATI Technologies Inc Device [1002:5a31] (rev 01)
            Subsystem: ASUSTeK Computer Inc. Device [1043:1627]
    00:01.0 PCI bridge [0604]: ATI Technologies Inc RS480 PCI Bridge [1002:5a3f]
    00:04.0 PCI bridge [0604]: ATI Technologies Inc RS480 PCI Bridge [1002:5a36]
            Kernel driver in use: pcieport
    00:05.0 PCI bridge [0604]: ATI Technologies Inc RS480 PCI Bridge [1002:5a37]
            Kernel driver in use: pcieport
    00:06.0 PCI bridge [0604]: ATI Technologies Inc RS480 PCI Bridge [1002:5a38]
            Kernel driver in use: pcieport
    00:07.0 PCI bridge [0604]: ATI Technologies Inc RS480 PCI Bridge [1002:5a39]
            Kernel driver in use: pcieport
    00:12.0 SATA controller [0106]: ATI Technologies Inc SB600 Non-Raid-5 SATA [1002:4380]
            Subsystem: ASUSTeK Computer Inc. Device [1043:1627]
            Kernel driver in use: ahci
    00:13.0 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI0) [1002:4387]
            Subsystem: ASUSTeK Computer Inc. Device [1043:1627]
            Kernel driver in use: ohci_hcd
    00:13.1 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI1) [1002:4388]
            Subsystem: ASUSTeK Computer Inc. Device [1043:1627]
            Kernel driver in use: ohci_hcd
    00:13.2 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI2) [1002:4389]
            Subsystem: ASUSTeK Computer Inc. Device [1043:1627]
            Kernel driver in use: ohci_hcd
    00:13.3 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI3) [1002:438a]
            Subsystem: ASUSTeK Computer Inc. Device [1043:1627]
            Kernel driver in use: ohci_hcd
    00:13.4 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI4) [1002:438b]
            Subsystem: ASUSTeK Computer Inc. Device [1043:1627]
            Kernel driver in use: ohci_hcd
    00:13.5 USB Controller [0c03]: ATI Technologies Inc SB600 USB Controller (EHCI) [1002:4386]
            Subsystem: ASUSTeK Computer Inc. Device [1043:1627]
            Kernel driver in use: ehci_hcd
    00:14.0 SMBus [0c05]: ATI Technologies Inc SBx00 SMBus Controller [1002:4385] (rev 13)
            Subsystem: ASUSTeK Computer Inc. Device [1043:1627]
    00:14.1 IDE interface [0101]: ATI Technologies Inc SB600 IDE [1002:438c]
            Subsystem: ASUSTeK Computer Inc. Device [1043:1627]
            Kernel driver in use: pata_atiixp
    00:14.2 Audio device [0403]: ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383]
            Subsystem: ASUSTeK Computer Inc. Device [1043:1339]
            Kernel driver in use: HDA Intel
    00:14.3 ISA bridge [0601]: ATI Technologies Inc SB600 PCI to LPC Bridge [1002:438d]
            Subsystem: ASUSTeK Computer Inc. Device [1043:1627]
    00:14.4 PCI bridge [0604]: ATI Technologies Inc SBx00 PCI to PCI Bridge [1002:4384]
    01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RC410 [Radeon Xpress 200M] [1002:5a62]
            Subsystem: ASUSTeK Computer Inc. Device [1043:1402]
            Kernel driver in use: radeon
    02:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR5001 Wireless Network Adapter [168c:001c] (rev 01)
            Subsystem: Atheros Communications Inc. AR5006EG 802.11bg NIC (2.4GHz, PCI Express) [168c:3065]
            Kernel driver in use: ath5k
    08:01.0 CardBus bridge [0607]: Ricoh Co Ltd RL5c476 II [1180:0476] (rev b3)
            Subsystem: ASUSTeK Computer Inc. Device [1043:1627]
            Kernel driver in use: yenta_cardbus
    08:01.1 SD Host controller [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter [1180:0822] (rev 17)
            Subsystem: ASUSTeK Computer Inc. Device [1043:1627]
            Kernel driver in use: sdhci-pci
    08:01.2 System peripheral [0880]: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter [1180:0592] (rev 08)
            Subsystem: ASUSTeK Computer Inc. Device [1043:1627]
    08:07.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ [10ec:8139] (rev 10)
            Subsystem: ASUSTeK Computer Inc. L8400B or L3C/S notebook [1043:1045]
            Kernel driver in use: 8139too
    Code:
    ben@linux-a6dq:~> uname -a
    Linux linux-a6dq.site 2.6.34-12-default #1 SMP 2010-06-29 02:39:08 +0200 i686 i686 i386 GNU/Linux
    Hopelijk helpt dit om het probleem op te sporen.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    14,084
    Blog Entries
    12

    Default Re: Alle geluiden gaan veel te snel

    Vraag: je bent er zeker van dat je wel het goede geluid hoort, alleen op de verkeerde snelheid?

    Heb je ook al eens de volgende dingen geprobeerd?

    -Nieuwe gebruiker aanmaken, inloggen als die gebruiker en kijken of het fenomeen dan ook bestaat. Als dat niet zo is, zit er iets fout in je account.
    -In Yast - Hardware - Geluid de kaart verwijderen, rebooten en vervolgens in Yast de kaart opnieuw configureren, controleren of het testgeluid goed is.

    Ik zal vanavond later even kijken of ik nog wat specifieke dingen kan vinden over de kaart
    - Athlon X6 3.6 GHz, 16 GB DDR3, 64 GB SSD, 3 TB of disks, GT540, openSUSE Factory + KDE
    - ASUS A73SD, Intel + GT610M Optimus, 6 GB, 2 x 120 GB SSD, openSUSE Factory + KDE

    Anything that can go wrong.... will teach us

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: Alle geluiden gaan veel te snel

    Ja, ik ben er zeker van dat het wel de juiste tonen zijn die ik hoor, alleen versneld.

    Op het nieuwe account klonk het geluid al wat beter, dat wil zeggen dat als ik niets deed het geluid goed liep. Zodra ik een venster verschoof of met de muis over een paar knoppen ging, begon hij weer snel af te spelen.

    Ik heb geprobeerd om de kaart te verwijderen, maar telkens als ik dat deed werd het hele scherm zwart en moest ik weer opnieuw opstarten. De geluidskaart heeft wel een keer de status 'niet geconfigureerd' gehad, maar dat heeft na het opnieuw configureren niets uitgehaald.

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    14,084
    Blog Entries
    12

    Default Re: Alle geluiden gaan veel te snel

    Oeps, dat zijn verschijnselen die ik nog niet ken. Je zou bijna het idee krijgen dat grafische dingen het geluid benvloeden. Voor een nieuwe gebruiker gaat het dus goed tot je dingen begint te doen.

    We moeten eerst eens uitvinden of de kaart op zichzelf het goed doet. Daartoe moet je opstarten zonder grafische desktop.
    In het GRUB opstartscherm type je op de Opties regel:
    Code:
    init 3
    Start de computer op, je krijgt een login prompt te zien. Login met je gebruikersnaam en wachtwoord. Doe dan:
    Code:
    su -c yast
    (rootpassword ingeven)
    Je kunt "rondfietsen" met de TAB en pijltjes toetsen
    Ga naar Hardware - Geluid en kijk of je meermalen het testgeluid normaal te horen krijgt.

    Kun je ook eens proberen of je er in de Failsafe modus ook last van hebt?
    - Athlon X6 3.6 GHz, 16 GB DDR3, 64 GB SSD, 3 TB of disks, GT540, openSUSE Factory + KDE
    - ASUS A73SD, Intel + GT610M Optimus, 6 GB, 2 x 120 GB SSD, openSUSE Factory + KDE

    Anything that can go wrong.... will teach us

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, The Netherlands
    Posts
    64

    Default Re: Alle geluiden gaan veel te snel

    Probeer dit eens:

    Stap 1: Open een terminal, CTRL+F2: konsole

    Stap 2: Voer het volgende commando uit:
    Code:
    sudo kwrite /etc/modprobe.d/alsa-base.conf
    # Voeg de volgende regel toe aan het eind van alsa-base.conf:

    Code:
    options snd-hda-intel model=mobile
    Sla het gewijzigde bestand op, herstart de pc en test het geluid opnieuw.

    Als dit niet werk kan je ook nog het volgende proberen:
    Vervang
    Code:
    model=mobile
    door
    Code:
    model=laptop
    flarkbox|AMDx64 X2 6000+|Nvidia 8600GT|4 GiB RAM
    flarkstation|C2D T7600|ATI FireGL V5200|4 GiB RAM
    flarkbook|Atom N270|Intel 945 GME|2 GiB RAM
    All on Ubuntu 10.10/openSUSE 11.4
    never unexpect nothing...

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    14,084
    Blog Entries
    12

    Default Re: Alle geluiden gaan veel te snel

    Kijk ook eens naar de settings in Systemsettings - Multimedia - Phonon, en probeer eens de volgorde van de "apparaten" te wijzigen

    En dan: je kunt ook LXDE ernaast installeren, daar op inloggen en dan media of geluiden afspelen, zien wat het dan doet.

    Voor wat betreft de instabiliteit: dat zou wel eens met de driver van je videokaart te maken kunnen hebben. Als ik het goed heb, moet je de ATI repo toevoegen om de juiste driver te installeren.

    NB. Er loopt op dit moment ook een onderwerp in de engelstalige forums: http://forums.opensuse.org/english/g...highlight=fast , die hou ik ook wel even in de gaten.
    Last edited by Knurpht; 17-Nov-2010 at 14:37.
    - Athlon X6 3.6 GHz, 16 GB DDR3, 64 GB SSD, 3 TB of disks, GT540, openSUSE Factory + KDE
    - ASUS A73SD, Intel + GT610M Optimus, 6 GB, 2 x 120 GB SSD, openSUSE Factory + KDE

    Anything that can go wrong.... will teach us

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  9. #9

    Default Re: Alle geluiden gaan veel te snel

    Bedankt voor de tips.

    @ Knurpth:
    Tijdens Failsafe werkte het geluid goed, ook als ik met vensters ging slepen. In die init 3 modus was het testgeluid ook goed. In LXDE was het geluid bij stilstand normaal, maar zodra ik met vensters begon te slepen ging het weer versnelt. Ook in de KDE openSUSE is het geluid plots normaal bij stilstand, ik weet alleen niet door welke stap dit precies is gekomen.

    Bedoel je met het veranderen van de apparaat het verschil tussen Xine en GStreamer (de enige 2 die er staan)? Dat maakt voor het probleem geen verschil. Wel komen er dan een paar uitvoerapparaten bij: 'default', 'hw:0,0' en 'hw:0.6'. Maar als ik die laatste probeer te testen crasht het programma.

    En hoe moet ik zo'n ATI repo installeren? Ik kan wel wat van Nvidia vinden, maar dat is dan denk ik de verkeerde.

    @ flark:
    Als ik dat eerste commando invoer, krijg ik na mijn wachtwoord ingevoerd te hebben de volgende melding:
    'kwrite: cannot connect to X server'

  10. #10
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    14,084
    Blog Entries
    12

    Default Re: Alle geluiden gaan veel te snel

    Dan moeten we nu eens zien, welke van de Failsafe opties er voor zorgt dat het geluid het wel goed doet.


    Kun je, waar je eerder "init 3" hebt ingetypt, eens 'nomodeset" intypen op de optie regel en dan opstarten? Als het werkt, laten we wel weten hoe je dat permanent kunt maken.


    De ATI-drivers komen daarna wel.
    - Athlon X6 3.6 GHz, 16 GB DDR3, 64 GB SSD, 3 TB of disks, GT540, openSUSE Factory + KDE
    - ASUS A73SD, Intel + GT610M Optimus, 6 GB, 2 x 120 GB SSD, openSUSE Factory + KDE

    Anything that can go wrong.... will teach us

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •