Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: HAL: permission denied to automount external USB storage

  1. #1
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,556

    Default HAL: permission denied to automount external USB storage

    11.3 in use with KDE. When I plug in an USB stick or my HTC phone into the USB connector the device is recognised but can't be opened in dolphin. This is the error message:

    Code:
    org.freedesktop.Hal.Device.PermissionDeniedByPolicy:
    org.freedesktop.hal.storage.mount-removable
    auth_admin_keep_always <-- (action, result)
    but the device is shown in dolphin as a removable device and

    Code:
    # lsusb
    Bus 001 Device 005: ID 0bb4:0ff9 High Tech Computer Corp.
    What setting is wrong here?
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    37,100
    Blog Entries
    16

    Default Re: HAL: permission denied to automount external USB storage

    What format are they?
    If it's been used in windows, use it there again and make sure you safely remove it

    It's always worth formatting the drive to make sure it's clean.
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,556

    Default Re: HAL: permission denied to automount external USB storage

    What format are they?
    Code:
    # fdisk -l
    Disk /dev/sdi: 15.9 GB, 15931539456 bytes
    255 heads, 63 sectors/track, 1936 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x00000000
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdi1               1        1937    15554048    c  W95 FAT32 (LBA)
    If it's been used in windows, use it there again and make sure you safely remove it
    No, it has never ever been used in windows (I do not have windows on any of my computers).

    Well, I made another test, and plugged it into another desktop running 11.2. I got the usual pop up window, asking what I want to do. I clicked on "open with dolphin" and got another small pop up window saying that this needs root privileges and asks for the password. After that it mounts and opens the device and shows the contents.

    What now?
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    37,100
    Blog Entries
    16

    Default Re: HAL: permission denied to automount external USB storage

    Can you / Are you able to wipe the drive

    Code:
    dd if=/dev/urandom of=/dev/sdi
    Or use Parted Magic to delete the partition and remake again
    http://dl.dropbox.com/u/10573557/pmagic-4.5.iso
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,103

    Default Re: HAL: permission denied to automount external USB storage

    Did you try to add yourself to group disk?

  6. #6
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,556

    Default Re: HAL: permission denied to automount external USB storage

    Did you try to add yourself to group disk?
    Yes, I did. Same result as before.
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    22,742

    Default Re: HAL: permission denied to automount external USB storage

    On 2010-11-02 13:36, vodoo wrote:
    >
    > 11.3 in use with KDE. When I plug in an USB stick or my HTC phone into
    > the USB connector the device is recognised but can't be opened in
    > dolphin. This is the error message:
    >
    >
    > Code:
    > --------------------
    > org.freedesktop.Hal.Device.PermissionDeniedByPolicy:
    > org.freedesktop.hal.storage.mount-removable
    > auth_admin_keep_always <-- (action, result)
    > --------------------
    >
    >


    Try this:

    11.2

    Code:
    ---------------
    cer@Telcontar:~> polkit-action --action
    org.freedesktop.hal.storage.mount-removable
    action_id: org.freedesktop.hal.storage.mount-removable
    description: Mount file systems from removable drives.
    message: System policy prevents mounting removable media
    default_any: auth_admin_keep_always (factory default: no)
    default_inactive: auth_admin_keep_always (factory default: no)
    default_active: yes
    ---------------

    11.3

    Code:
    ---------------
    cer@Elanor:~> polkit-action --action
    org.freedesktop.hal.storage.mount-removable
    action_id: org.freedesktop.hal.storage.mount-removable
    description: Mount file systems from removable drives.
    message: System policy prevents mounting removable media
    default_any: no
    default_inactive: no
    default_active: yes
    -------------------

    This is unknown territory to me, but I think you have to change something
    there in your system to have access. Either that or dolphin is clueless.

    I wonder if there is a polkit for dummies howto somewhere... :-?
    I googled polkit and found just six entries, no docu. :-/


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  8. #8
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,556

    Default Re: HAL: permission denied to automount external USB storage

    robin_listas wrote:

    11.3

    Code:
    cer@Elanor:~> polkit-action --action org.freedesktop.hal.storage.mount-removable
    action_id:        org.freedesktop.hal.storage.mount-removable
    description:      Mount file systems from removable drives.
    message:          System policy prevents mounting removable media
    default_any:      no
    default_inactive: no
    default_active:   yes
    and I get (on 11.3):

    Code:
    vodoo@host:~> polkit-action --action org.freedesktop.hal.storage.mount-removable
    action_id:        org.freedesktop.hal.storage.mount-removable
    description:      Mount file systems from removable drives.
    message:          System policy prevents mounting removable media
    default_any:      auth_admin_keep_always (factory default: no)
    default_inactive: auth_admin_keep_always (factory default: no)
    default_active:   yes
    Slight differences, but I do not understand their significance. On my 11.2 system I get exactly the same as on 11.3. However, on 11.2 dolphin (I think it is dolphin) opens a window and asks for the root password; then it works. 11.3 opens dolphin right away and then fails with the error message.
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    22,742

    Default Re: HAL: permission denied to automount external USB storage

    On 2010-11-05 19:06, vodoo wrote:

    > and I get (on 11.3):
    >
    >
    > Code:
    > --------------------
    > vodoo@host:~> polkit-action --action org.freedesktop.hal.storage.mount-removable
    > action_id: org.freedesktop.hal.storage.mount-removable
    > description: Mount file systems from removable drives.
    > message: System policy prevents mounting removable media


    I think this has to be changed, but no idea how. However, I can mount
    devices (gnome), so there must be something else somewhere.

    > default_any: auth_admin_keep_always (factory default: no)
    > default_inactive: auth_admin_keep_always (factory default: no)
    > default_active: yes
    > --------------------


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    10,610

    Default Re: HAL: permission denied to automount external USB storage

    I'd be inclined to check the security settings in YaST:

    YaST > Security and Users > Local Security

    In particular, the 'Security Overview' settings include 'Use secure file permissions'. For reference, mine is set to 'Easy', but your's may be different (ie 'Secure', or 'Paranoid')

    There is also 'Predefined Security Configurations' which can be adjusted according to your system use - eg 'Home Workstation' vs 'Network Server'

    Hope this helps.
    Last edited by deano_ferrari; 06-Nov-2010 at 01:10. Reason: Additional clarification

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •