Results 1 to 5 of 5

Thread: virtualbox/vmware full screen problem in openSuSE 11.3

  1. #1

    Default virtualbox/vmware full screen problem in openSuSE 11.3

    I am using vmware and virtualbox for experimenting with different linux distros and for using windows... When I switch to full screen, the upper portion(about 50px from top) of system becomes unusable because I am not able to click with my mouse anywhere there. So ubuntu's top panel becomes unaccesible and for vmware, once it becomes full screen I am not able to minimize/restore/close it.

    In full screen mode, looking at the mouse cursor, it seems to be controlled by guest system when in full screen but as soon as I move it to top of the screen, the host machine takes control of it and then I cannot access any top panels or vmware toolbar.

    Is there any solution to this problem... Please let me know if more information is needed from my side.

    I am using opensuse 11.3, KDE4.4.4, vmware 3.1.2/virtualbox 3.2.10. The problem is for both vmware and virtualbox.

    Thanks in advance.
    --
    Vivek Bhat
    Linux User #496540
    Dell 620 S Desktop, 6GB, Intel(R) Core(TM) i5-2310 CPU @ 2.90GHz, openSuSE 13.1
    +KDE 4.11.5, Kernel 3.16.3-1.gd2bbe7f-desktop x86_64

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    3,503

    Default Re: virtualbox/vmware full screen problem in openSuSE 11.3

    If I were to hazard a wild guess, unless you have a real reason to use multiple desktops, disable that feature.

    Also, beware on a KDE desktop the top left corner and top right corners by default are assigned special functionality.

    Tony

  3. #3

    Default Re: virtualbox/vmware full screen problem in openSuSE 11.3

    Quote Originally Posted by tsu2 View Post
    If I were to hazard a wild guess, unless you have a real reason to use multiple desktops, disable that feature.

    Also, beware on a KDE desktop the top left corner and top right corners by default are assigned special functionality.

    Tony
    Tried but doesn't work I even disabled special functionality in System Settings --> Desktop --> Screen Edges ... But still giving this problem...
    --
    Vivek Bhat
    Linux User #496540
    Dell 620 S Desktop, 6GB, Intel(R) Core(TM) i5-2310 CPU @ 2.90GHz, openSuSE 13.1
    +KDE 4.11.5, Kernel 3.16.3-1.gd2bbe7f-desktop x86_64

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    3,503

    Default Re: virtualbox/vmware full screen problem in openSuSE 11.3

    Next, I might recommend you play around with the screen resolution in the GuestVM.
    If it's not calculated properly, I can guess how it might cause a problem like you describe. Set it maybe one step smaller than your Host screen resolution so that when it goes full screen it's clearly not slightly larger than the physical screen. A general rule of thumb of mine if it's what you're doing is that the GuestVM should never be equal to or larger than the Host's physical screen resolution or expect odd things like scrolling.

    I'm just grasping a bit at straws since I haven't seen exactly what you're describing, but on the other hand I configure all my GuestVMs at 10624x768 against a much larger desktop because I prefer to work with them only rarely in fulll screen mode.

    Tony

  5. #5

    Default Re: virtualbox/vmware full screen problem in openSuSE 11.3

    Quote Originally Posted by tsu2 View Post
    Next, I might recommend you play around with the screen resolution in the GuestVM.
    If it's not calculated properly, I can guess how it might cause a problem like you describe. Set it maybe one step smaller than your Host screen resolution so that when it goes full screen it's clearly not slightly larger than the physical screen. A general rule of thumb of mine if it's what you're doing is that the GuestVM should never be equal to or larger than the Host's physical screen resolution or expect odd things like scrolling.

    I'm just grasping a bit at straws since I haven't seen exactly what you're describing, but on the other hand I configure all my GuestVMs at 10624x768 against a much larger desktop because I prefer to work with them only rarely in fulll screen mode.

    Tony
    Thanks Tony for your help and patience... I finally found the problem. I was having one panel at the top which was set to auto hide. It never crossed my mind that it can cause the problem. I removed the panel and now it is working fine. Your pointers have been really great. Thanks again
    --
    Vivek Bhat
    Linux User #496540
    Dell 620 S Desktop, 6GB, Intel(R) Core(TM) i5-2310 CPU @ 2.90GHz, openSuSE 13.1
    +KDE 4.11.5, Kernel 3.16.3-1.gd2bbe7f-desktop x86_64

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •