Results 1 to 9 of 9

Thread: mysql wont start on xampp

  1. #1
    Join Date
    Oct 2010
    Location
    Sydney
    Posts
    14

    Default mysql wont start on xampp

    I've just executed /opt/lampp/lampp security and restarted lampp, now it shows as deactivated in status when I browse to http://localhost

    The default username lampp doesn't work with my new passwords, phpAdmin doesn't let me log in.... everything.

    No idea what's going on.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    14,085
    Blog Entries
    12

    Default Re: mysql wont start on xampp

    Looks like mysql does not run. Check Yast - System - Runlevel editor, Activate if needed.

    BTW, how did you install LAMP? According to the path to it, you used an external package. Most people simply install through Yast, that way packages would never end up in /opt
    - Athlon X6 3.6 GHz, 16 GB DDR3, 64 GB SSD, 3 TB of disks, GT540, openSUSE Factory + KDE
    - ASUS A73SD, Intel + GT610M Optimus, 6 GB, 2 x 120 GB SSD, openSUSE Factory + KDE

    Anything that can go wrong.... will teach us

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Oct 2010
    Location
    Sydney
    Posts
    14

    Default Re: mysql wont start on xampp

    Quote Originally Posted by Knurpht View Post
    Looks like mysql does not run. Check Yast - System - Runlevel editor, Activate if needed.

    BTW, how did you install LAMP? According to the path to it, you used an external package. Most people simply install through Yast, that way packages would never end up in /opt
    tar xvfz xampp-linux-1.7.3a.tar.gz -C /opt
    Should be alright though? You describe it like it shouldn't go into /opt

    Mysql fails to start through yast run level editor. Error is /etc/init.d/mysql start returned 1 (unspecified error):

    My guess is that it doesn't have permission to run?

  4. #4
    Join Date
    Oct 2010
    Location
    Sydney
    Posts
    14

    Default Re: mysql wont start on xampp

    payam@win7:/etc/init.d> sudo ./mysql restart
    root's password:
    Restarting service MySQL
    Shutting down service MySQL done
    Starting service MySQL warning: /var/run/mysql/mysql.sock didn't appear within 30 seconds
    chmod: cannot access `/var/run/mysql/mysqld.pid': No such file or directory
    payam@win7:/etc/init.d>

  5. #5
    Join Date
    Oct 2010
    Location
    Sydney
    Posts
    14

    Default Re: mysql wont start on xampp

    Quote Originally Posted by Knurpht View Post
    Looks like mysql does not run. Check Yast - System - Runlevel editor, Activate if needed.

    BTW, how did you install LAMP? According to the path to it, you used an external package. Most people simply install through Yast, that way packages would never end up in /opt
    Well I just rm -rf /opt and installed LAMP through yast and the mysql daemon still doesn't run... and now neither does apache2.

    (also, why can't I edit my posts?)

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    14,085
    Blog Entries
    12

    Default Re: mysql wont start on xampp

    You can edit your posts within a time window of 10 minutes.

    Installing/configuration attempts the xampp packages may very well have broken your install. I cannot see that. Simply removing /opt should not be done either. Specially since you ran some security script/program. Mysql not starting is no good.

    If this is not a production environment, which I thoroughly hope, reinstall. Always first check for openSUSE packages.

    My advice: reinstall openSUSE. Then install the Lamp pattern through the software installer. phpMyAdmin can be found through software.opensuse.org: Search Results . Activate mysql, apache2 in the runlevel editor, set a root password in mysql, create an admin user for phpMyAdmin, done.
    Extra tips: configure the webroot and mysql database to be out of the root filesystem, i.e. on an other partition.
    - Athlon X6 3.6 GHz, 16 GB DDR3, 64 GB SSD, 3 TB of disks, GT540, openSUSE Factory + KDE
    - ASUS A73SD, Intel + GT610M Optimus, 6 GB, 2 x 120 GB SSD, openSUSE Factory + KDE

    Anything that can go wrong.... will teach us

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    1,127

    Default Re: mysql wont start on xampp

    On Sun, 24 Oct 2010 19:06:02 +0530, spyazdani <spyazdani@no-mx.forums.opensuse.org> wrote:

    > Well I just rm -rf /opt and installed LAMP through yast and the mysql
    > daemon still doesn't run... and now neither does apache2.


    how did you start mysql after reinstalling via yast? by default, it doesn't start automatically. i use "rcmysql start" for this, or start it via runlevel editor if you want it always.

    apache2 needs to be started in the same way (rcapache2 start or runlevel), and configured (/etc/apache2/httpd.conf and, depending on what you're doing, other files in subdir.s thereunder).

    --
    phani.

  8. #8
    Join Date
    Oct 2010
    Location
    Sydney
    Posts
    14

    Default Re: mysql wont start on xampp

    Quote Originally Posted by Knurpht View Post
    You can edit your posts within a time window of 10 minutes.

    Installing/configuration attempts the xampp packages may very well have broken your install. I cannot see that. Simply removing /opt should not be done either. Specially since you ran some security script/program. Mysql not starting is no good.

    If this is not a production environment, which I thoroughly hope, reinstall. Always first check for openSUSE packages.

    My advice: reinstall openSUSE. Then install the Lamp pattern through the software installer. phpMyAdmin can be found through software.opensuse.org: Search Results . Activate mysql, apache2 in the runlevel editor, set a root password in mysql, create an admin user for phpMyAdmin, done.
    Extra tips: configure the webroot and mysql database to be out of the root filesystem, i.e. on an other partition.
    It's a test lab, so I don't mind reinstalling and starting again. A bit of a pain, but I can live with that.

    Thanks for the link and the advice.

    Quote Originally Posted by phanisvara View Post
    On Sun, 24 Oct 2010 19:06:02 +0530, spyazdani <spyazdani@no-mx.forums.opensuse.org> wrote:

    > Well I just rm -rf /opt and installed LAMP through yast and the mysql
    > daemon still doesn't run... and now neither does apache2.


    how did you start mysql after reinstalling via yast? by default, it doesn't start automatically. i use "rcmysql start" for this, or start it via runlevel editor if you want it always.

    apache2 needs to be started in the same way (rcapache2 start or runlevel), and configured (/etc/apache2/httpd.conf and, depending on what you're doing, other files in subdir.s thereunder).

    --
    phani.
    Through runlevel editor. Both apache2 and mysql failed with some error I cant remember anymore.

  9. #9
    Join Date
    Oct 2010
    Location
    Sydney
    Posts
    14

    Default Re: mysql wont start on xampp

    I've reinstalled the external package again back into /opt, and it appears to be working again. How do you remove the LAMP install that I installed through yast? it doesn't allow me to uncheck the box :S
    If I majorly stuff this up, then I'll reinstall openSUSE. I've still got some life left in me before I give in.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •