Results 1 to 5 of 5

Thread: Cannot Mount NFS export.

  1. #1

    Default Cannot Mount NFS export.

    Hello,

    I am running OpenSuSE 11.3.
    I cannot mount an export from a Redhat 9 NFS server.
    I am able to mount the export from RHEL5, Ubuntu, Fedora, Solaris but not OpenSuSE 11.3.

    This is the command I use from a Ubuntu Karmic box.
    mount server:/exportdir /mnt -o vers=3,proto=udp

    As I said it works from many other distros, but not sure why no go on this one. Can anyone explain this? Should I submit a bug? I noticed portmap is not used anymore and am wondering if thatmay have anything to do with it. The rpcbind is supposed to handle this from what I read..not sure if this is accurate.

    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    14,036
    Blog Entries
    12

    Default Re: Cannot Mount NFS export.

    So, you're the next one bitten by this. Don't worry, fixed in a moment:


    In /etc/nfsmount.conf look for
    Code:
    #Defaultvers=4
    change that to
    Code:
    Defaultvers=3

    Mind, you have to remove the "#", change the "4" into a "3".
    Then do
    Code:
    su -c 'rcnfs restart'

    I ran into the same problem, the solution was already on the forums. All fine now.
    - Athlon X6 3.6 GHz, 16 GB DDR3, 30 GB SSD, 3 TB of disks, GT540, openSUSE 12.2 x86_64 + KDE 4.10 + GNOME 3
    - ASUS A73SD, Intel + GT610M Optimus, 6 GB, 120 GB SSD, openSUSE Tumbleweed

    Anything that can go wrong.... will teach us

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Cannot Mount NFS export.

    Hello Knurpht,

    Thanks for the reply. I already have the Defaultvers set to 3 in the NFS mount.conf. Originally I could not mount anything via NFS and had to change this. However for this particular export, it will not allow me to mount it. I don't know why but I get this error below.

    mount.nfs: mount to NFS server 'server:/exportdir' failed: timed out, giving up

    The version of NFS server on RedHat 9 may be old but I cannot get it to mount with any options. I have tried vers=2,udp vers=3,udp

    Is this a bug? I can mount all other exports with no issues from the 11.3 box. I can also mount this Redhat 9 export from all my other distros. How can I trouble shoot?

    Thanks

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    14,036
    Blog Entries
    12

    Default Re: Cannot Mount NFS export.

    Have you compared the fstab line to that of other distros?
    Do you restart nfs after making changes, i.e. run 'su -c rcnfs restart' ?
    I ran some tests here, mounting NFS shares here, no problems. I have "Defaultvers=3" otherwise nothing mounts.
    - Athlon X6 3.6 GHz, 16 GB DDR3, 30 GB SSD, 3 TB of disks, GT540, openSUSE 12.2 x86_64 + KDE 4.10 + GNOME 3
    - ASUS A73SD, Intel + GT610M Optimus, 6 GB, 120 GB SSD, openSUSE Tumbleweed

    Anything that can go wrong.... will teach us

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: Cannot Mount NFS export.

    Hello again,

    Yes, the same mount command line that works on RHEL5 or Ubuntu to mount this RedHat 9 export fails on OpenSuSE 11.3 for whatever reason. I did do the su -c 'rcnfs restart' and it did not help. I also rebooted. It worked fine on SLED 10 and 10.2.

    I do mount about 12 NFS shares no problem from this 11.3 box, however mounting the shares from the RedHat 9 server I cannot. I appreciate your reply, do you know if this is bug worthy?

    Thank you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •