Page 1 of 8 123 ... LastLast
Results 1 to 10 of 74

Thread: possible partition error suse linux boot

  1. #1

    Default possible partition error suse linux boot

    We had a perfectly working SUSE OES netware server for some months, and wanted to create a new image backup. Using Acronis Backup and Recovery Advanced Server Software. This worked a treat on our SBS 2008 Server. We went to run it for Novell OES and a system lock up occured and services such as Iprint then disabled. A server restart recovered the server after a few attempts.

    We then learnt that the server could not write files to an NTFS formatted USB drive. This was the ideal destination to test the backup. However we could not even write a simple file to the drive without an error message about permissions.

    We then learnt that Linux needs a package called NTFS-3G to enable NTFS writing permissions. This did fix the writing issues. We attempted to run another back up which again failed, bringing down the server. We again attempted to reboot the server this time we fail to get to the graphical user login.

    At the suse Linux Enterprise boot screen we select "boot from hard disc". Which fails immediately with "GDM could not write a new authorisation entry to disk...Error no space left on drive". When the boot eventually continues, a number of things fail with the same message about "No space left on device".

    The next message starts "Could not start the X server due to some internal error."

    Further to the above, starting "recovery" instead, the checks of partition fail and it seems obvious that the partition definitions have become corrupted. In the expert partion manager the lines for partitions seem correct except that there are no entries for 'mount point' and 'mount by' columns. Trying to edit these lines does not appear to allow entries for mount point or mount by - they are disabled.

    It seems likely the server is not mounting some partitions at boot which is why the kernel thinks the server is full. Is there some simple way we can use say fdisk to repair the partition definition without loosing anything of the server OS and data ?

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    10,923
    Blog Entries
    2

    Default Re: possible partition error suse linux boot

    I don't understand what you're doing.

    I think you're doing somethong like this: you boot the Linux machine (using the acronis cd to boot it) and use the acronis software on the cd to copy an image of the Linux machine across to an attached USB NTFS drive. Then you restore the image to the Linux drive and it won't work.

    Is that right. If it's wrong, you will see my confusion and perhaps tell me what it is you're doing so I can visualise the operations better.

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    15,611

    Default Re: possible partition error suse linux boot

    You forgot to specify which operating system you use and it's version. But from a glance at your post I deduct that this is abouit SLES. You may get help here on the openSUSE Forums (we are not that xenophobe), but you mat be better serverd at SUSE Linux Enterprise Server (SLES)
    Henk van Velden

  4. #4

    Smile Re: possible partition error suse linux boot

    Swerdna - I'll have to come back to you on that, it was not me doing the running of the Acronis backup. All I can say is to the best of my knowledge, this is two failed efforts to copy an image of the linux machine to an attached USB storage, resulting in the Linix machine not booting (as described with possible partitioning error). I am virtually certain this is not a restored image we are discussing - this was a live server, now it is not - we dont know why.

    It may be possible the server drive is actually full if it was incorrectly used as a target and maybe the image would loop, getting bigger and bigger all the time. A pretty stupid thing to do, I cannot believe anyone would try to backup a server onto itself, but I can just understand it happenening by accident.

    Also hccv - this is SLES netware as I understand. I have posted in the netware forums without response. The very fact that I get two virtually instant responses on this forum is telling me something very important.

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    15,611

    Default Re: possible partition error suse linux boot

    Well, it is all nice that you like us answering, but that still does not give you a clue.

    In fact, personaly I do not understand your problem fully (understatement) and I do not know Acronis.

    Isn't there anything you can show us? Aren't there any error messages? And again it would be wise to tell us exactly which SLES you use. Also the output of
    Code:
    uname -a
    might tell us a bit of what you are running.
    Henk van Velden

  6. #6
    Carlos E. R. NNTP User

    Default Re: possible partition error suse linux boot

    On 2010-10-13 21:06, davidm01 wrote:
    >
    > We had a perfectly working SUSE OES netware server for some months, and
    > wanted to create a new image backup. Using Acronis Backup and Recovery
    > Advanced Server Software. This worked a treat on our SBS 2008 Server. We
    > went to run it for Novell OES and a system lock up occured and services
    > such as Iprint then disabled. A server restart recovered the server
    > after a few attempts.


    This is impossible to understand.

    First, specify exactly what operating system you are using. Then what exact operations you did, one
    by one, step by step, exact error messages and exact actions. Detailed and clearly explained.

    Please note that if this is SLES or SLED, as it seems, you have to ask in their specific forums, not
    here - as we are not familiar with their problems. We can try to help, if you are clear in the details.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  7. #7

    Default Re: possible partition error suse linux boot

    Ok, have talked to one of the two people who were doing this, and am getting a moderately good picture of what decisions have been made, and what has happened. I should emphasise right away that what caused us to get into the situation we are may or may not get us back to a working system, but here goes.

    This was an experienced and loyal Novell user. To move forward, it was wanted to continue with a familiar system if possible, and the nearest was SLES netware. We wanted simple user rights management, nothing much except file and iPrint services, NSS file system and Salvage. Extensive attempts to achieve this with SUSE 11.1 and 11.2 failed to support Netware. Success was achieved with SUSE 10.2.0.91, and there was a good system running tests for weeks. There are weeks of effort in this system concerning setting up users, data, facilities etc. All this is going to waste right now.

    Before going live, the final tests of imaging and daily backup were begun, using Acronis Backup & recovery 10 Advanced server. This needs to be installed under yast in order to be scheduled, which was done. Attempts were made to backup to a USB drive, one could set the drives to backup and set the drive to backup to, but execution failed with errors 'could not create archive'. Discovering a need to run linux software to enable writing to NTFS formatted drives, so this was installed.

    A successful write of a small test file was completed, so the main server drives backup was begun, resulting in the same sort of 'could not create archive' error as before, plus other critical errors such as 0x00000FF1 and 0x0000FF2. FF1 seems to have to to with permissions. FF2 is unknown. At this point the server was frozen, and after a hard reset could not be restarted. Which is where we are now. The server seems to be full, the partitions don't seem to be completely described.

    I know just enough to run a few listing commands. Here are the results.
    uname -a
    linux linux 2.6.16.60-0.54.5-default #1 .....

    fdisk -l
    Disk /dev/sda: 770.0Gb 7308....08 bytes
    255 heads, 63 sectors/track, 88849 cylinders
    Units = cylinders 0f 16065 * 512 = 8225208 bytes

    device boot start end blocks Id system
    /dev/sda1 * 1 9 72261 83 Linux
    /dev/sda2 19 1966 15719602+ 8e Linux LUM
    /dev/sda3 1967 88849 697887697+ 65 Novell Netware 386

    Disk /dev/dm-0: 10.7Gb 10737418240 bytes
    255 heads, 63 sectors/track. 1305 cylinders
    Units = cylinders of 16065 * 512 = 8225208 bytes

    Disk /dev/dm-0 doesn't contain a valid partition table

    Disk /dev/dm_1: 2147 Mb, 2147473648 bytes
    two more lines

    Disk /dev/dm-1 doesn't contain a valid partition table

    (my comment - no idea what the last two devices are, but the first three seem ok)

    df -h
    /dev/loop0 255M used 255M 100% mounted /mounts/instsys

    mounts
    rootfs on / type rootfs (rw)
    tmpfs on / type tmpfs (rw)
    tmpfs on / type tmpfs (rw)
    proc on /proc type proc (rw)
    sysfs on /sys type sysfs (rw)
    usbfs on /proc/bus/usb type usbfs (rw)
    /dev/loop0 on /mounts/instsys type cramfs (ro)
    devpts on /dev/pts type devpts (rw)

    Right now, the console screens say
    F1 screen
    about 30 lines ending
    Found a Linux console termial on /dev/console....
    *** Starting YAST2 ***

    F2 screen
    a command screen with the results shown about (oh my poor fingers)

    F3 screen
    some sort of install screen log probing hardware, finishing
    Loading image "/var/adm/mount/boot/x86_64/root"....
    mount /download/image0: we need a loop device
    mount: using /dev/loop0
    starting setctsid 'showconsole' inst_setup yast

    F4 screen
    some logging every 30 minutes all saying Oct 13 14:29:53 linux -- MARK --
    and other times, then
    Oct 14 09:44:49 linux kernel: Adding 2097144k swap on /dev/system/swap. Priority:-4 extents:1 across:2097144k
    and some more times

    F5,F6 screen empty

    F7 screen
    Yast repair Tool Box GUI screen

    F8 screen
    A panic screen, continuously refreshing lines
    ACPI: Trying to reopen
    ACPI: opening device

    (few million records, I suspect)
    need to be stopped.

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    15,611

    Default Re: possible partition error suse linux boot

    This is going to be a bit difficult I am afraid. Apparently you did not (or could not) copy/paste the computer output to your post, but wrote/typed it down. That means we have crippled output (I e.g. can not understand that there are three mounts on /). Also not putting computer text between CODE tags here on the Forums (like my uname -a statement in post #5) makes everything difficult to interprete.

    In any case there is one thing I am wondering about from your first post. It seems that you back up to a file system on a removable medium, but that you have a non Linux file system type there. When that is correct, how do you ever think that restoring from there will give you everything that does not exist (like ownership of user/group and access-bits) on an NTFS file system, back?

    For the rest of your post, I think some of us need some time to understand this, especialy as all the logical screens seem to have a differnet usage in SLES then in openSUSE.
    Henk van Velden

  9. #9

    Default Re: possible partition error suse linux boot

    So sorry, it is true I have no way of copy-paste the SUSE screens. Would it help to enclose in (if that is how you do it).

    Very grateful if you can have patience with me !!

    As to the NTFS formatted backups. You are probably right. So we would need to create a reiser-formatted partition on the USB attached device? Note one of the partitions is Netware NSS. Also the backup package blurb says you cannot restore particular files (meaning selected?) from ReiserFS3 upwards, only ext2/3/4 so this software probably won't be any use anyway....ho hum.

    Right, also just restarted the server, selected Rescue, tried and failed to mount the first partition temporarily, and ran fsck.reiserfs --check /dev/sda1
    This is what it says
    Code:
    resierfs_open: the reiserfs superblock cannot be found on /dev/sda1.
    Failed to open the filesystem
    If the parttition table has not been changed, and the partition is valid and it really contains a reiserfs, then the superblock is corrupted and you need to run this utility with --rebuild-sb
    I am not going to do that yet !

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    15,611

    Default Re: possible partition error suse linux boot

    On the fs type. As said, I do not know the backup utility you use, nor what it does, but I doubt (that is an understatement from me again) that using an fs type that is in fact completely strange to the OS will help in making good backups. And when you use Reiserfs in general, Reiserfs seems to me the correct choice. Reiserfs is still supported on openSUSE, but I think most of us have long converted to ext3 and because ext4 is the default from 11.2 (or earlier?) that is standard now. But as long as your SLES system is using Reiserfs as default, I would advice to stick to it. I do not know anything about Netware NSS, thus can not advicse on that.

    On the error from fsck. That makes me very pessimistic. OTOH, are you sure there must be a Reiserfs on it? /dev/sda1 is nowhere used in your earlier information (mounts). To me it is not clear what is there and how it is used.

    Most of us are no professionals (I was one), but the documentation your system manager made about how the system is installed, changed, working, etc. is scanty. Professional organisations are gone bancrupt on such lousy behaviour. When you by any change are trying to get this running within a reasonable amount of time for a commercial company, I would advice to hire a Linux/SLES prof from not to far away that can realy come to your site and see what this is all about. Not that we will not try to help you, but not being able laying hands on the system makes it realy difficult.
    Henk van Velden

Page 1 of 8 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •