Results 1 to 7 of 7

Thread: Staying logged in

  1. #1

    Default Staying logged in

    Currently this seems to be implemented in a slightly buggy manner.


    Sometimes I stay logged in across restarts of Firefox and even restarts of my computer. I can view my profile, start threads and respond to threads without re-logging in.

    Sometimes, after a restart, I go to the forum main page and it shows "My Profile" and I click it and can view my messages fine. but when I try to reply to a message, it asks me to log in.

    Sometimes it simply logs me out when I try to refresh the page after a restart.

    I'm not 100% certain why this seems to act this way, but I have one guess: could it possibly be that I log in sometimes on two different computers, and this case will cause the other computer to log me out?

  2. #2
    Join Date
    Aug 2007
    Location
    Utah, USA, Earth, Milky Way
    Posts
    5,798
    Blog Entries
    3

    Default Re: Staying logged in

    FYI the forums are tied to openSUSE/Novell login which has a default
    timeout of 60 minutes then cuts the connection. I suspect this is what
    you are running into.

    --
    Kim - 9/22/2010 12:45:42 PM

  3. #3

    Default Re: Staying logged in

    Quote Originally Posted by kgroneman View Post
    FYI the forums are tied to openSUSE/Novell login which has a default
    timeout of 60 minutes then cuts the connection. I suspect this is what
    you are running into.

    --
    Kim - 9/22/2010 12:45:42 PM
    No, that cannot be it because sometimes I am able to shut down for the night, come back the next day, restart the computer (9 hours later), startup the browser, go to forums.opensuse.org and reply to messages and post new ones without relogging in.

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    11,210

    Default Re: Staying logged in

    6tr6tr wrote:
    > No, that cannot be it because sometimes I am able to shut down for the
    > night, come back the next day, restart the computer (9 hours later),
    > startup the browser, go to forums.opensuse.org and reply to messages and
    > post new ones without relogging in.


    he is correct, the timed log-out is no longer assured, nor
    consistent...and, hasn't been for months..

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

  5. #5
    Join Date
    Aug 2007
    Location
    Utah, USA, Earth, Milky Way
    Posts
    5,798
    Blog Entries
    3

    Default Re: Staying logged in

    Hey 6tr6tr,

    >No, that cannot be it because sometimes I am able to shut down for the
    >night, come back the next day, restart the computer (9 hours later),
    >startup the browser, go to forums.opensuse.org and reply to messages
    >and post new ones without relogging in


    Then you are running into some kind of anomaly with the login system
    which we here in the forums aren't in control of. The login system has
    a 60 minute connection timeout (which I've tested) and the forums have
    an 8 hour connection timeout.

    --
    Kim - 9/22/2010 3:59:12 PM

  6. #6

    Default Re: Staying logged in

    There is a session timeout, I'm sure, or maybe its a per session cookie, either way its very annoying to have to login every time i come to the forum.

  7. #7
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,335

    Default Re: Staying logged in

    Quote Originally Posted by kgroneman View Post
    Hey 6tr6tr,

    >No, that cannot be it because sometimes I am able to shut down for the
    >night, come back the next day, restart the computer (9 hours later),
    >startup the browser, go to forums.opensuse.org and reply to messages
    >and post new ones without relogging in


    Then you are running into some kind of anomaly with the login system
    which we here in the forums aren't in control of. The login system has
    a 60 minute connection timeout (which I've tested) and the forums have
    an 8 hour connection timeout.
    Kim, thanks for that info re connection timeouts.

    I have had similar results to @6tr6tr, usually when I shutdown overnight without logging off forum. Next day boot, SeaMonkey (mainly) will restore my logged-in forum session. I can browse, and e.g. use New Posts. I can prepare a reply to a post, but on sending it I am also forced to re-login and then the system adds the post to the thread. At that point, browser back/forward buttons go nowhere, so I re-select forum home page and all works normally.

    The irritation comes when in a hurry I forget that process will happen.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •