Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: No sound in XBMC

  1. #1

    Default No sound in XBMC

    There is no sound when playing avi files in XBMC.

    The videos play fine & there is sounds in menu.

    When i switch to Root the movies have sound,so whats wrong here?

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,500
    Blog Entries
    48

    Smile Re: No sound in XBMC

    So anytime you can do something as root, but not as a standard user, perhaps it is a permissions thing. First, I might open up YaST / Security and Users / User and Group Management and find your name on the Users Tab and pick edit on the bottom left of the screen. Go to the details tab, Additional Groups window and I normally check: users, audio, cdrom, disk, floppy, games & video. Save these new selections, log out and then back in and try one more time and see if the problem is still present. The next thing I might do is to check the properties for the video files in question and see if they belong to root. As root, you can change the permissions back to users, but you should limit any activities in Linux as a root user.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: No sound in XBMC

    Cant change the permissions.

    By the way the movie folder is on Windows partition,maybe thats the problem.

    Should i move it to my Home folder?

  4. #4

    Default Re: No sound in XBMC

    I copied a few movies to my Home directory & the permissions were fine,but still no sound when playing them in XBMC.

    What is wrong here?

  5. #5
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,500
    Blog Entries
    48

    Smile Re: No sound in XBMC

    So if the movies do not work in your home area, that is kind of odd. However, you can change the permissions for your Windows partition while in Linux such that they do not need to be copied to your home area. You can edit your /etc/fstab file and change the options to just say defaults. To edit the file, use the run commend:

    Code:
    kdesu /etc/fstab
    You must enter the root user password. The format for each line is as follows:

    Code:
    /dev/disk/name /windows/c ntfs-3g options 0 0
    It is the options, which will be many entries you want to change to read only the single word defaults, this is located between ntfs-3g and the 0 0 at the end. You must restart your PC for this to go into effect. Did you successfully change your user groups as suggested in my first message?

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  6. #6

    Default Re: No sound in XBMC

    Yes i did what you said in the post above.

    It works fine when as root,but not when as user,no matter if the movies are on windows partition or in my home folder.

    Hey what should i type under name: /dev/disk/HERE?

  7. #7

    Default Re: No sound in XBMC

    I forgot so say that i installed Open SuSe 11.3 a few days ago.

    I had it a few years ago(think it was SuSe 9 or newer),but never had any issues like this.

  8. #8
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,500
    Blog Entries
    48

    Smile Re: No sound in XBMC

    So I installed XBMC just to test out how it works, but everything seems OK to me. Have you tried to play AVI files in any other audio player and get audio? And, you did not really respond to my user permissions question where I said:

    First, I might open up YaST / Security and Users / User and Group Management and find your name on the Users Tab and pick edit on the bottom left of the screen. Go to the details tab, Additional Groups window and I normally check: users, audio, cdrom, disk, floppy, games & video. Save these new selections, log out and then back in and try one more time and see if the problem is still present.
    What groups do you have selected for your user name?

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  9. #9

    Default Re: No sound in XBMC

    Avis play fine in all other players like Kaffeine,Mplayer,SMplayer,VLC.

    I selected these groups: users,audio,cdrom,disk,floppy,games & video,but its still the same when im not on root.

  10. #10
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,500
    Blog Entries
    48

    Smile Re: No sound in XBMC

    Tnlgg I am stumped as regards to XBMC playback of AVI files. I only have five such very old video files, but they all work properly. Their resolutions are very low, but the audio works fine. When I look at the file permissions, they all claim to belong to root, but they play just fine as can be. Have you thought about making a visit to the XBMC forum and asking about this issue in their forum? At least that is what I would consider doing, though the problem is permissions related to your PC. You might even try creating a new user, log in as this new person and try to play the same AVI files to see if this makes any difference. If it did, it would prove it is a setup issue in your default user setup that you created.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •