Results 1 to 6 of 6

Thread: OpenSuse Default Web Browser Problem...

  1. #1
    Join Date
    Sep 2010
    Location
    Woodstock, GA
    Posts
    13

    Default OpenSuse Default Web Browser Problem...

    Hey everyone, quick question for you guys. I've been using Google Chrome as my Default Web Browser ever since its launch, so as usual, it was one of the first things I downloaded and installed on my new OpenSuse 11.3 KDE 4.4 laptop.

    During the install, I selected to make it my Default Web Browser, but Mozilla Firefox keeps over writing my choice. Every time I open Chrome, it asks me to set it as the Default, and I do, but it never sticks. I also select to make it my Default Browser in Chrome's options, but every time I click the button to do so, it doesn't do anything.

    What can I do to officially change my Default Web Browser permanently to Chrome?

    Any help is much appreciated! Have a good one!
    Last edited by sgrayjr289; 03-Sep-2010 at 06:45. Reason: browser, firefox, chrome, mozilla, google

  2. #2
    Join Date
    Oct 2009
    Location
    Dhaka,Bangladesh
    Posts
    251

    Default Re: OpenSuse Default Web Browser Problem...

    Quote Originally Posted by sgrayjr289 View Post
    Hey everyone, quick question for you guys. I've been using Google Chrome as my Default Web Browser ever since its launch, so as usual, it was one of the first things I downloaded and installed on my new OpenSuse 11.3 KDE 4.4 laptop.

    During the install, I selected to make it my Default Web Browser, but Mozilla Firefox keeps over writing my choice. Every time I open Chrome, it asks me to set it as the Default, and I do, but it never sticks. I also select to make it my Default Browser in Chrome's options, but every time I click the button to do so, it doesn't do anything.

    What can I do to officially change my Default Web Browser permanently to Chrome?

    Any help is much appreciated! Have a good one!
    Remove firefox.
    zypper remove firefox

  3. #3

    Default Re: OpenSuse Default Web Browser Problem...

    Hello sgrayjr289,

    There is some information missing in your post.
    So could you tell us which version of openSUSE you use?
    If you use KDE or GNOME?
    Quote Originally Posted by sgrayjr289
    What can I do to officially change my Default Web Browser permanently to Chrome?
    If you use KDE you can start System Settings->General->Personal->Deafualt Applications.
    From there select "Web Browser".
    And fill in the command to start chrome.

    I think there's an option in GNOME to do it, but I don't know.

    Best of luck!
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

  4. #4
    Join Date
    Sep 2010
    Location
    Woodstock, GA
    Posts
    13

    Default Re: OpenSuse Default Web Browser Problem...

    Oops, thought I put my version in the post, I always try to specify since settings for each one are varied so vastly. I'm using OpenSuse 11.3, and KDE 4.4. Actually, I did post that information, in the first line

    I'd rather not remove Firefox because I have to use Selenium IDE at work in order to do testing, and not all of our Web Applications work properly on Chrome yet, so I can't remove it. I need to have both Firefox and Chrome, Fox for work, Chrome for everything else lol. At least until Firefox 4.0 Stable comes out.

    I'll check out the Settings that you mentioned Edward, and thanks for the suggestion colao

  5. #5
    Join Date
    Sep 2010
    Location
    Woodstock, GA
    Posts
    13

    Default Re: OpenSuse Default Web Browser Problem...

    Nice, the suggestion you gave me Edward worked perfectly. I've been Distro jumping a lot recently, but am going to stick to OpenSuse because my new Job, AdaptOne, runs their web servers on OpenSuse. My CTO has recognized my intense interest in Linux and suggested to learn OpenSuse so that I can be trained to be the company's Linux Admin, so learning everything about this distro is my goal right now lol. I learn many new things every day about it. Thanks for the help guys!

  6. #6

    Default Re: OpenSuse Default Web Browser Problem...

    You might also want to check in Firefox under Preferences/Advanced/General that the option "Always check to see if Firefox is the default browser on startup" is unchecked.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •