Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Something wrong with Yast...

  1. #1
    Join Date
    Dec 2009
    Location
    Mumbai, India
    Posts
    47

    Default Something wrong with Yast...

    I installed 11.3 today and after a few runs, I started getting errors from Yast. I don't have a clue how to rectify them though I do understand that the system is not able to find some file online...

    Please have a look at the yast screenshots below:




    Can somebody tell me how to stop these errors?

  2. #2

    Default Re: Something wrong with Yast...

    Hello,

    It looks to me as if the the SuSE repo yast wants to chat with is temporarily unavailable or you are getting a hiccup from your ISP. It does not appear to be an error in yast. Try again in 10 mins ... .

    Take care,


    cwight

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    37,097
    Blog Entries
    16

    Default Re: Something wrong with Yast...

    It's better if you post the URl rather than the image directly

    http://i34.tinypic.com/awrckp.jpg

    http://i35.tinypic.com/21amvyr.jpg
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

  4. #4
    Join Date
    Dec 2009
    Location
    Mumbai, India
    Posts
    47

    Default Re: Something wrong with Yast...

    Quote Originally Posted by caf4926 View Post
    It's better if you post the URl rather than the image directly

    http://i34.tinypic.com/awrckp.jpg

    http://i35.tinypic.com/21amvyr.jpg
    OK... Understood. But as oxala mentions, do you think my ISP is blocking Yast updates? I have previously updated 11.2 from my University Wi-Fi and things were fine... Why is there an issue now?

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    37,097
    Blog Entries
    16

    Default Re: Something wrong with Yast...

    Possibly try a local mirror or at least one you think should be OK
    Just disable the original and add one in
    openSUSE Download Mirrors - 11.3
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

  6. #6
    Join Date
    Dec 2009
    Location
    Mumbai, India
    Posts
    47

    Default Re: Something wrong with Yast...

    Quote Originally Posted by caf4926 View Post
    Possibly try a local mirror or at least one you think should be OK
    Just disable the original and add one in
    openSUSE Download Mirrors - 11.3
    Could you please elaborate on this? I mean I tried to add one URL from the list but it did not work for me. Probably I am entering a wrong URL...

  7. #7

    Default Re: Something wrong with Yast...

    Hello again,

    Are you trying to change the repository with yast ( the nice graphical interface ) or zypper ( the easy, but potentially confusing linux command line program )?


    Could you be more specific than "but it did not work for me"? Did you receive an error message? If so, what did it say? ... etc.

    If you are comfortable with linux command line programs, use zypper, as it is easy to copy and paste exactly what you are doing into a forum message.

    If you are not ... don't sweat it ... the Yast repo management tool is very solid .... just requires some extra English to describe EXACTLY what you are doing for the purpose of telling us ...

    Whether you are using yast or zypper, it is not more complicated than feeding the app a url, such as "http://77.88.19.68/opensuse/distribution/11.3/repo/oss/" which I just randomly choose from the list of repo mirrors here: openSUSE Download Mirrors - 11.3. Try to add the same url: "http://77.88.19.68/opensuse/distribution/11.3/repo/oss/", assuming Russia is not too far to travel ...

    But let me back up just a little bit ... the mirror list contains bunches of links, organized by geographical region. For now, just look at those labelled http. If you click on any of these, your browser will take you to that url. That may or may not be the actual url for the repo you want to add. In the example I gave above, I clicked "http" on the fourth item in the list "Asia" with a Russina flag next to it. It took me to "http://77.88.19.68/opensuse/" ... from there I clicked on "distribution", then "11.3", then "repo", then "oss". So I arrive at the url I stated a few sentances back "http://77.88.19.68/opensuse/distribution/11.3/repo/oss/".

    I know this is a valid url to give yast or zypper only because I am familiar with the directory layout of SuSE repositories ... I see the directories "boot" and "docu" and files like directory.yast. I've simply seen the directory layout enough times to recognize that I've clicked my way a valid repo directory.

    Sorry if this was more detail than you actually needed ... I'm not sure exactly what you are missing based on your post ... so excuse me if I erred on the side of overkill.

    When a repo is successfully added, both yast and zypper will display a little info while adding it ... ask you if you want to trust the key, etc. If adding the repo fails ... they will give an error, hopefully telling you why it failed.

    Good luck!

    cwight

  8. #8
    Join Date
    Dec 2009
    Location
    Mumbai, India
    Posts
    47

    Default Re: Something wrong with Yast...

    Hi oxala, thank you for your feedback... I was able to get the repositories sorted out.
    And thanks for the elaborate post... I have learned some new things here...

  9. #9
    upscope NNTP User

    Default Re: Something wrong with Yast...

    star scream wrote:

    >
    > caf4926;2200885 Wrote:
    >> It's better if you post the URl rather than the image directly
    >>
    >> http://i34.tinypic.com/awrckp.jpg
    >>
    >> http://i35.tinypic.com/21amvyr.jpg

    >
    > OK... Understood. But as oxala mentions, do you think my ISP is
    > blocking Yast updates? I have previously updated 11.2 from my University
    > Wi-Fi and things were fine... Why is there an issue now?
    >

    I been getting errors like this in the last week from different repo's also.

    --
    Russ
    openSUSE 11.3 (2.6.34-12-desktop)|KDE4.4.4 (KDE 4.4.4) "release 5")|
    Intel core2duo 2.5 MHZ, 4 GB|GeForce 8400GS


  10. #10
    upscope NNTP User

    Default Re: Something wrong with Yast...

    upscope wrote:

    > star scream wrote:
    >
    >>
    >> caf4926;2200885 Wrote:
    >>> It's better if you post the URl rather than the image directly
    >>>
    >>> http://i34.tinypic.com/awrckp.jpg
    >>>
    >>> http://i35.tinypic.com/21amvyr.jpg

    >>
    >> OK... Understood. But as oxala mentions, do you think my ISP is
    >> blocking Yast updates? I have previously updated 11.2 from my University
    >> Wi-Fi and things were fine... Why is there an issue now?
    >>

    > I been getting errors like this in the last week from different repo's
    > also.
    >

    here's the error I get when I try to enter the Repos's

    Error
    Download failed
    failed to download /rep0/repoindex.xml from
    http://download.opensuse.org/reposit..._11.3?cookie=0

    If I answer OK I get:
    There were errors while restoring the repository configuration.
    Error refreshing service KDE Factory
    (http://download.opensuse.org/reposit...penSUSE_11.3):
    Failed to download ./repo/repoindex.xml from
    http://download.opensuse.org/reposit...11.3?cookies=0

    I do not have a Factory repo defined.

    zypper lr
    # | Alias | Name
    | Enabled | Refresh
    --+-------------------------------------+-------------------------------------+---------+--------
    1 | KDE-4.4.4_-Stable | KDE-4.4.4 -Stable
    | Yes | No
    2 | Updates for openSUSE 11.3 11.3-1.82 | Updates for openSUSE 11.3
    11.3-1.82 | Yes | No
    3 | openSUSE-11.3 11.3-1.82 | openSUSE-11.3 11.3-1.82
    | No | No
    4 | openSUSE_-KDE_Extra | KDE4.4.4 - Extra
    | Yes | No
    5 | openSUSE_11.3 | KDE4.4.4 - UpdateApps
    | No | No
    6 | repo-debug | openSUSE-11.3-Debug
    | Yes | No
    7 | repo-non-oss | openSUSE-11.3-Non-Oss
    | Yes | No
    8 | repo-oss | openSUSE-11.3-Oss
    | Yes | No
    9 | repo-source | openSUSE-11.3-Source
    | No | No

    Not sure why I'm getting the %3f in first error message instead of the /.
    Will report as bug.
    --
    Russ
    openSUSE 11.3 (2.6.34-12-desktop)|KDE4.4.4 (KDE 4.4.4) "release 5")|
    Intel core2duo 2.5 MHZ, 4 GB|GeForce 8400GS


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •