Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: How to get "play DVD" option when inserting a disk?

  1. #1

    Default How to get "play DVD" option when inserting a disk?

    Hello. I installed VLC along with some other stuff suggested (i think it was called libdvd.. or something?). Whenever I insert a DVD, I still get the popup that gives me the options of:

    Open with File Manager
    Rip Video DVD Titles with k3b
    Download Photos with digiKam
    Copy with k3b
    Download Photos with Gwenview

    I don't get anything like "Play DVD," "Play with vlc," "run auto play," etc etc ... is there any way to enable that or are those more of a windows thing? I can still play the dvd by manually opening vlc player and clicking media -> open dvd.

    thanks

  2. #2
    Join Date
    Jun 2010
    Location
    London
    Posts
    572

    Default Re: How to get "play DVD" option when inserting a disk?

    I guess you can do that with MPlayer, check if you got that.

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    37,113
    Blog Entries
    16

    Default Re: How to get "play DVD" option when inserting a disk?

    Try this:
    System Settings > Advanced tab
    File associations >
    Type: dvd in the filter bar
    x-content > video-dvd
    what shows in the application pref box
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

  4. #4

    Default Re: How to get "play DVD" option when inserting a disk?

    thnx, caf4926. It says "VLC media player" ... this is what it looks like when I toss a DVD in:




  5. #5

    Default Re: How to get "play DVD" option when inserting a disk?

    I don't know how up to date this is with the new SUSE, but I followed the instructions in post #4 here: OpenSUSE.us - View topic - Aid with autoplay

    Neither of the things he say ("KDED media manger" and "Media notifier daemon") are check or running. I actually can't find them at all (or how to add them).

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    37,113
    Blog Entries
    16

    Default Re: How to get "play DVD" option when inserting a disk?

    Quote Originally Posted by NewbieLLP View Post
    I don't know how up to date this is with the new SUSE, but I followed the instructions in post #4 here: OpenSUSE.us - View topic - Aid with autoplay

    Neither of the things he say ("KDED media manger" and "Media notifier daemon") are check or running. I actually can't find them at all (or how to add them).
    Because that post is talking about KDE3...

    Try going to: System Settings > Advanced > Device Actions
    In there you can set applications and their actions (Or add them if necessary)
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

  7. #7

    Default Re: How to get "play DVD" option when inserting a disk?

    I went there and noticed some stuff.

    1) There is already something called "Play DVD with Kaffeine" ... however this choice never shows up when I toss a DVD in (as you can see from the earlier post).

    2) There are 3 seperate entries for "Open with VLC media player":

    1st one says "Storage Volume, Optical Disc." When I click edit, it looks like it's for playing CD's. The command is "vlc cdda://" and one of the parameters is "Content must equal Audio." So I assume VLC installed right for playing CD's.

    The 2nd and 3rd ones say "Open with VLC media player" but say nothing else next to that. When I try to click "edit" it gives me the error "It appears the predicate for this action is not valid."

    3) The option to "Rip Video DVD Titles with K3b" always shows up in the dropdown when I toss a DVD in. So I looked inside it. The parameters are exactly the same as the "Play DVD with Kaffeine" which never shows up in the dropdown.

    I tried uninstalling vlc (YaST -> Software Management) then re-installing it and still have this problem ... so it plays DVDs fine when I manually open vlc and go through the trouble of clicking the menus to open a DVD
    openSUSE 11.3 (KDE)

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    37,113
    Blog Entries
    16

    Default Re: How to get "play DVD" option when inserting a disk?

    Try clicking ADD
    In the Box 'Action Name' that opens type: Play DVD with VLC
    In the command line put: vlc --dvd %f
    Configure the icon by clicking it and select the vlc cone

    Apply it

    Does that help?
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

  9. #9

    Default Re: How to get "play DVD" option when inserting a disk?

    thnx for all your help. I got it to work by doing this:

    Add -> Play DVD

    Command: vlc dvd://

    Parameters: Property ignored = false + device must be of type Optical Disk

    Seems to be working now

    I tried various stuff ... for instance content must contain VideoDvd like how the "Rip DVD titles with K3b" uses and oddly enough, it worked for that one but not vlc. This is so frustratingly inconsistent (makes it hard to learn) ... but at least it's working now. I appreciate your willingness to help!

    Just an example of how inconsistent it is ... used the same exact settings that now work for VLC with the "Play DVD with Kaffeine" entry and that still doesn't work LOL.
    openSUSE 11.3 (KDE)

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    37,113
    Blog Entries
    16

    Default Re: How to get "play DVD" option when inserting a disk?

    Well done
    It sure is a pain in the rear.
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •