Page 1 of 5 123 ... LastLast
Results 1 to 10 of 42

Thread: Error while compiling

  1. #1
    Join Date
    Jun 2010
    Location
    London
    Posts
    572

    Lightbulb Error while compiling

    Hi,

    I am trying to install a software but I get error as under -

    Code:
    linux-lst5:/usr/share/man/arpd # ./configure --with-libdnet=/usr/local/libdnet --with-libevent=/usr/local/libevent
    checking for a BSD compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking whether make sets ${MAKE}... yes
    checking for working aclocal... missing
    checking for working autoconf... missing
    checking for working automake... missing
    checking for working autoheader... missing
    checking for working makeinfo... missing
    checking for mawk... no
    checking for gawk... gawk
    checking for gcc... no
    checking for cc... no
    checking for cc... no
    checking for cl... no
    configure: error: no acceptable cc found in $PATH

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    16,172
    Blog Entries
    14

    Default Re: Error while compiling

    Quote Originally Posted by avenuemax
    Hi,

    I am trying to install a software but I get error as under -


    Code:
    --------------------
    linux-lst5:/usr/share/man/arpd # ./configure
    --with-libdnet=/usr/local/libdnet --with-libevent=/usr/local/libevent
    checking for a BSD compatible install... /usr/bin/install -c checking
    whether build environment is sane... yes checking whether make sets
    ${MAKE}... yes checking for working aclocal... missing
    checking for working autoconf... missing
    checking for working automake... missing
    checking for working autoheader... missing
    checking for working makeinfo... missing
    checking for mawk... no
    checking for gawk... gawk
    checking for gcc... no
    checking for cc... no
    checking for cc... no
    checking for cl... no
    configure: error: no acceptable cc found in $PATH

    --------------------

    Hi
    Please don't compile as root user, I'm sure if you look at the readme,
    it will tell you to use sudo to install and your compiling in the
    bowels of the system......

    Setup a directory as your user and build form there, you need to
    install the basic build tools gcc, gcc-c++, make, automake, autoconf
    etc.

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.12-0.7-default
    up 1:50, 2 users, load average: 0.16, 0.06, 0.02
    GPU GeForce 8600 GTS Silent - Driver Version: 256.35


  3. #3
    Join Date
    Jun 2010
    Location
    London
    Posts
    572

    Lightbulb Re: Error while compiling

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Please don't compile as root user, I'm sure if you look at the readme,
    it will tell you to use sudo to install and your compiling in the
    bowels of the system......

    Setup a directory as your user and build form there, you need to
    install the basic build tools gcc, gcc-c++, make, automake, autoconf
    etc.

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.12-0.7-default
    up 1:50, 2 users, load average: 0.16, 0.06, 0.02
    GPU GeForce 8600 GTS Silent - Driver Version: 256.35
    Hi,

    I have all the build tools in place already. Let me check 32 bit ones or this has got to do with libpcap. Anyway I will try again.

  4. #4
    Join Date
    Jun 2010
    Location
    London
    Posts
    572

    Lightbulb Re: Error while compiling

    Hi, got all 32 bit ones and made some progress with sudo but still no luck.

    HTML Code:
    david@linux-lst5:~> cd arpd
    david@linux-lst5:~/arpd> sudo ./configure --with-libdnet=/usr/local/libdnet --with-libevent=/usr/local/libevent
    root's password:
    checking for a BSD compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking whether make sets ${MAKE}... yes
    checking for working aclocal... found
    checking for working autoconf... found
    checking for working automake... found
    checking for working autoheader... found
    checking for working makeinfo... missing
    checking for mawk... no
    checking for gawk... gawk
    checking for gcc... gcc
    checking for C compiler default output... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for executable suffix...
    checking for object suffix... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for a BSD compatible install... /usr/bin/install -c
    checking whether ln -s works... yes
    checking for socket in -lsocket... no
    checking for gethostbyname in -lnsl... yes
    checking for libdnet... /usr/local/libdnet
    configure: error: dnet-config not found in /usr/local/libdnet/bin
    Tried:
    david@linux-lst5:~> dnet-config --libs
    -L/usr/lib64 -ldnet

    That is there but it is x64, where i can get i386 ones.
    Last edited by avenuemax; 25-Jun-2010 at 09:19. Reason: additional info

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    16,172
    Blog Entries
    14

    Default Re: Error while compiling

    Quote Originally Posted by avenuemax
    Hi, got all 32 bit ones and made some progress with sudo but still no
    luck.

    david@linux-lst5:~/arpd> sudo ./configure
    --with-libdnet=/usr/local/libdnet --with-libevent=/usr/local/libevent
    checking for libdnet... /usr/local/libdnet
    configure: error: dnet-config not found in /usr/local/libdnet/bin
    Hi
    No only use sudo when installing not for either the configure or make
    commands

    Why not just install libnet-devel from the normal oss repository???
    Then you don't need to use /usr/local

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.12-0.7-default
    up 2:35, 2 users, load average: 0.16, 0.13, 0.06
    GPU GeForce 8600 GTS Silent - Driver Version: 256.35


  6. #6
    Join Date
    Jun 2010
    Location
    London
    Posts
    572

    Default Re: Error while compiling

    Quote Originally Posted by malcolmlewis View Post
    Hi
    No only use sudo when installing not for either the configure or make
    commands

    Why not just install libnet-devel from the normal oss repository???
    Then you don't need to use /usr/local

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.12-0.7-default
    up 2:35, 2 users, load average: 0.16, 0.13, 0.06
    GPU GeForce 8600 GTS Silent - Driver Version: 256.35
    Yup, that is what I am doing right now.

  7. #7
    Join Date
    Jun 2010
    Location
    London
    Posts
    572

    Lightbulb Re: Error while compiling

    Mate, not able to find it. Is it the right name in suse repos, in deb it is called something libdumbnet-dev.

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    16,172
    Blog Entries
    14

    Default Re: Error while compiling

    Quote Originally Posted by avenuemax
    Mate, not able to find it.
    Hi
    It's on the dvd or the oss repository? What openSUSE release are you
    running? Do you have the oss repository enabled?

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.12-0.7-default
    up 0:36, 2 users, load average: 0.06, 0.04, 0.06
    GPU GeForce 8600 GTS Silent - Driver Version: 256.35


  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    16,172
    Blog Entries
    14

    Default Re: Error while compiling

    Quote Originally Posted by malcolmlewis
    Quote Originally Posted by avenuemax
    Mate, not able to find it.
    Hi
    It's on the dvd or the oss repository? What openSUSE release are you
    running? Do you have the oss repository enabled?
    Hi
    In your system do you have a local install source enable in the
    software repositories (eg DVD, liveCD) also how is your internet
    connection to the openSUSE repositories, maybe defining a local mirror
    may help, because you seem to have difficulty finding files?
    http://en.opensuse.org/Mirror_Selection

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.12-0.7-default
    up 8:07, 2 users, load average: 0.06, 0.06, 0.01
    GPU GeForce 8600 GTS Silent - Driver Version: 256.35


  10. #10
    Join Date
    Jun 2010
    Location
    London
    Posts
    572

    Lightbulb Re: Error while compiling

    Quote Originally Posted by malcolmlewis View Post
    Hi
    It's on the dvd or the oss repository? What openSUSE release are you
    running? Do you have the oss repository enabled?

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.12-0.7-default
    up 0:36, 2 users, load average: 0.06, 0.04, 0.06
    GPU GeForce 8600 GTS Silent - Driver Version: 256.35
    Hi,

    I have dvd, will try it when I get in suse. I run 11.2 x64. I've oss repo enabled.

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •