Results 1 to 6 of 6

Thread: Disable ipw3945 and enable zd1211rw

  1. #1

    Exclamation Disable ipw3945 and enable zd1211rw

    I have a HP laptop with an onboard wifi that uses ipw3945 driver. It gets configured on boot and I can use knetworkmanager to connect to a wifi network.
    But I want to use an usb wifi adapter that works with the zd1211rw driver, I had use it in the past but I don't use linux since like 1 year, I forgot how to do it.

    What I want is to disable the board that uses ipw3945 and use the usb adapter.

    I remember I used modprobe zd1211rw before, I tried it and it doesn't show any warning/error so I think I have the module, should I remove ipw3945 before loading zd1211rw?

    After using modprobe zd1211rw, can I use Yast or how do I configure it so I can use it with knetworkmanager?

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,347

    Default Re: Disable ipw3945 and enable zd1211rw

    On 06/04/2010 12:06 PM, trogster wrote:
    >
    > I have a HP laptop with an onboard wifi that uses ipw3945 driver. It
    > gets configured on boot and I can use knetworkmanager to connect to a
    > wifi network.
    > But I want to use an usb wifi adapter that works with the zd1211rw
    > driver, I had use it in the past but I don't use linux since like 1
    > year, I forgot how to do it.
    >
    > What I want is to disable the board that uses ipw3945 and use the usb
    > adapter.
    >
    > I remember I used modprobe zd1211rw before, I tried it and it doesn't
    > show any warning/error so I think I have the module, should I remove
    > ipw3945 before loading zd1211rw?
    >
    > After using modprobe zd1211rw, can I use Yast or how do I configure it
    > so I can use it with knetworkmanager?


    If you add ipw3945 to the blacklisted modules in
    /etc/modprobe.d/50-blacklist.conf (for 11.2 or later) or
    /etc/modprobe.d/blacklist.conf (for 11.1), then that driver will never
    be loaded. Once the zd1211rw is loaded, creates a wireless device that
    you can see with /usr/sbin/iwconfig, and is able to scan as with 'sudo
    /usr/sbin/iwlist scan', then kNM will find it and use the same
    connection as did the ipw3945.

  3. #3

    Default Re: Disable ipw3945 and enable zd1211rw

    Quote Originally Posted by lwfinger View Post
    On 06/04/2010 12:06 PM, trogster wrote:
    >
    > I have a HP laptop with an onboard wifi that uses ipw3945 driver. It
    > gets configured on boot and I can use knetworkmanager to connect to a
    > wifi network.
    > But I want to use an usb wifi adapter that works with the zd1211rw
    > driver, I had use it in the past but I don't use linux since like 1
    > year, I forgot how to do it.
    >
    > What I want is to disable the board that uses ipw3945 and use the usb
    > adapter.
    >
    > I remember I used modprobe zd1211rw before, I tried it and it doesn't
    > show any warning/error so I think I have the module, should I remove
    > ipw3945 before loading zd1211rw?
    >
    > After using modprobe zd1211rw, can I use Yast or how do I configure it
    > so I can use it with knetworkmanager?


    If you add ipw3945 to the blacklisted modules in
    /etc/modprobe.d/50-blacklist.conf (for 11.2 or later) or
    /etc/modprobe.d/blacklist.conf (for 11.1), then that driver will never
    be loaded. Once the zd1211rw is loaded, creates a wireless device that
    you can see with /usr/sbin/iwconfig, and is able to scan as with 'sudo
    /usr/sbin/iwlist scan', then kNM will find it and use the same
    connection as did the ipw3945.
    Awesome, thank you very much.

  4. #4

    Default Re: Disable ipw3945 and enable zd1211rw

    I added "blacklist ipw3945" and restarted but the module still appears in lsmod, anyway I can do a modprobe -r ipw3945.
    But when I do modprobe zd1211rw the wireless device doesn't appear in iwconfig, if I use iwlist scan I see: "lo, eth0 doesn't support scanning", iwconfig show "no wireless extensions", and lsmod show zd1211rw loaded.

    Do I need to do something else after modprobe zd1211rw to get the wireless device in eth1?

  5. #5

    Default Re: Disable ipw3945 and enable zd1211rw

    I found with dmesg that the firmware cant be found, I will try reinstalling it.

  6. #6

    Default Re: Disable ipw3945 and enable zd1211rw

    I reinstalled it from opensuse cd and it worked, i will try patching it later.

    Thank you very much for your help lwfinger.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •