Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Flash problem in non-GTK browsers

  1. #1
    Join Date
    May 2009
    Location
    Poland
    Posts
    30

    Unhappy Flash problem in non-GTK browsers

    Hello everybody!
    This bug is terrifying me from some time (about two weeks).
    Simple - After updating my whole openSUSE Flash player isn't working in any browser that isn't written in GTK. In some browsers(Arora, Konqueror, Opera 10.10) it works for some time, but crashes very often. In Opera 10.5x it isn't working at all. I must use Firefox or Chrome for Flash to work, but I don't like these browsers. Is anybody here with the same problem? Or are you all using FF and Chrome?

    I'm using GTK2 version 2.20.0-1.7 and it happens to any version of Flash.
    Here is output from Arora:
    Code:
    (process:3121): Gtk-CRITICAL **: gtk_clipboard_get_for_display: assertion `display != NULL' failed
    Adobe Flash Player: gtk_clipboard_get(GDK_SELECTION_PRIMARY); failed. Trying to call gtk_init(0,0);
    
    (<unknown>:3121): Gdk-CRITICAL **: gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed
    
    (<unknown>:3121): Gdk-CRITICAL **: gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed
    I hope that somebody will help me.

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,381

    Default Re: Flash problem in non-GTK browsers

    On 04/24/2010 11:26 AM, miki100 wrote:
    >
    > Hello everybody!
    > This bug is terrifying me from some time (about two weeks).
    > Simple - After updating my whole openSUSE Flash player isn't working in
    > any browser that isn't written in GTK. In some browsers(Arora,
    > Konqueror, Opera 10.10) it works for some time, but crashes very often.
    > In Opera 10.5x it isn't working at all. I must use Firefox or Chrome for
    > Flash to work, but I don't like these browsers. Is anybody here with the
    > same problem? Or are you all using FF and Chrome?
    >
    > I'm using GTK2 version 2.20.0-1.7 and it happens to any version of
    > Flash.
    > Here is output from Arora:
    >
    > Code:
    > --------------------
    >
    > (process:3121): Gtk-CRITICAL **: gtk_clipboard_get_for_display: assertion `display != NULL' failed
    > Adobe Flash Player: gtk_clipboard_get(GDK_SELECTION_PRIMARY); failed. Trying to call gtk_init(0,0);
    >
    > (<unknown>:3121): Gdk-CRITICAL **: gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed
    >
    > (<unknown>:3121): Gdk-CRITICAL **: gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed
    >
    > --------------------
    >
    >
    > I hope that somebody will help me.


    Have you reported the bug in the Bugzilla?

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    16,734
    Blog Entries
    15

    Default Re: Flash problem in non-GTK browsers

    Quote Originally Posted by Larry Finger
    Have you reported the bug in the Bugzilla?
    Also noted on Arora bug tracker...
    http://code.google.com/p/arora/issue...ummary%20Stars

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.45-0.1-default
    up 9 days 4:32, 4 users, load average: 0.31, 0.29, 0.35
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 195.36.15


  4. #4
    Join Date
    May 2009
    Location
    Poland
    Posts
    30

    Default Re: Flash problem in non-GTK browsers

    Quote Originally Posted by lwfinger View Post
    Have you reported the bug in the Bugzilla?
    I haven't, because I would like somebody to confirm that. So, is there anybody with the same problem?

  5. #5
    Join Date
    May 2009
    Location
    Poland
    Posts
    30

    Arrow Re: Flash problem in non-GTK browsers

    Sorry for bumping topic, but two days ago I freshly installed Milestone 6 and now Flash isn't working only in Opera 10.5x. So now I would be happy if somebody could install (or maybe somebody already has?) Opera 10.5x and test Flash, so we would know is it my comp only, or maybe we (openSUSE users) have too bleeding edge packages, because for everybody at Opera blog Flash works. I really hope that it isn't only my problem... Please somebody help

  6. #6
    Join Date
    May 2009
    Location
    Poland
    Posts
    30

    Arrow Re: Flash problem in non-GTK browsers

    Sorry for triple posting, but today somebody filled a bug report about this - https://bugzilla.novell.com/show_bug.cgi?id=613843. I hope that this bug will be fixed very soon!

  7. #7

    Default Re: Flash problem in non-GTK browsers

    Did you tested with flash 10.1 (final version ?)

    This version is proposed as an update to 11.2, and should be available at 11.3 too
    (i'm currently doing an update, I might confirm that soon).

    "Traditionnaly" is flash optimised for gtk browser (because firefox does use gtk), so work under qt browser may be quite erratic...

    Currently on 11.3 I have some bug, even with gtk browser like firefox or chrome : some site (deezer.com) does not works well. Search Feature is broken...

  8. #8
    Join Date
    May 2009
    Location
    Poland
    Posts
    30

    Default Re: Flash problem in non-GTK browsers

    Yes, I tested it with Flash 10.1. I know that Flash is written in GTK, but in 11.2 it was working and we (openSUSE 11.3 users) are the only ones at Opera blog to report this issue, so... Please somebody, have a look at this issue

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    16,734
    Blog Entries
    15

    Default Re: Flash problem in non-GTK browsers

    Quote Originally Posted by miki100
    Yes, I tested it with Flash 10.1. I know that Flash is written in GTK,
    but in 11.2 it was working and we (openSUSE 11.3 users) are the only
    ones at Opera blog to report this issue, so... Please somebody, have a
    look at this issue
    Hi
    Since the bug has be raised, you need to be patient and wait for it to
    be assigned to someone. We are only volunteers (not developers) here
    helping on the forum and have no influence aside from adding a
    confirmation that it's seen if someone uses the application.

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.12-0.7-default
    up 1 day 1:42, 2 users, load average: 0.00, 0.01, 0.00
    GPU GeForce 8600 GTS Silent - Driver Version: 195.36.31


  10. #10
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    14,168
    Blog Entries
    12

    Default Re: Flash problem in non-GTK browsers

    Can confirm. Flash does not work in Opera 10.5x and 10.60 beta.
    - Athlon X6 3.6 GHz, 16 GB DDR3, 64 GB SSD, 3 TB of disks, GT540, openSUSE Factory + KDE
    - ASUS A73SD, Intel + GT610M Optimus, 6 GB, 2 x 120 GB SSD, openSUSE Factory + KDE

    Anything that can go wrong.... will teach us

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •