Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Browsers wont play flash SOUND

  1. #1

    Default Browsers wont play flash SOUND

    Hello,

    I suspect this is the appropriete section for my post:

    I'm having a problem with opera (the same happens with FF and konqueror).

    The browsers will open and play flash content fine.
    BUT NO SOUND.

    Sound works with audio players like XMMS and Amarok.

    I've reinstalled Alsa plugins, KDEmultimedia, and the only libsound package I have in repos, to no avail.

    Anyone have any ideas?
    Also - can someone direct me to selecting ALSA to be used, vs..(anything else).


    Thanks.
    http://www.youtube.com/watch?v=dOZUYxwhduE
    The Absence of Evidence is not the Evidence of Absence

  2. #2
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,867
    Blog Entries
    30

    Default Re: Browsers wont play flash SOUND

    For a lack of sound in flash in openSUSE-11.1 the solution for some is to remove libflash-support (but keep flash-player).

    The solution in 11.2 is typically different.

    In 11.2 instead check
    • check your PCM volume control in our mixer. Sometimes that will dynamically move to zero by itself when a flash video starts
    • in KDE take a look at your sound card device order in YaST > Hardware > Sound and confirm the order of your sound devices in KDE's Kick Off Application Launcher > Configure Desktop > Multimedia is similar
    • ensure you have appropriate codecs installed. Do this by ensuring you have libffmpeg0 from packman packagers installed (which will pick up many codecs with its dependencies).

  3. #3

    Default Re: Browsers wont play flash SOUND

    Honestly - I swore I wrote up a response for this thread!

    Anywho - thanks very much for your help oldcpu.

    The Issue was resolved by having my currently plugged up sound card as the main (in this case, ONLY) soundcard.

    Went YaST > Hardware > Sound but I couldnt find the way to change the priority of the device in, so I uninstalled the other sound card ^_~.

    I also installed libffmpeg0.
    You have been very helpfull ^_^.

    Btw - what codecs / packages do you reccomend to get my system playing the typical video file thats out there?
    (whether by caffine, or what have you).

    Im currently not able to...

    (thanks!)
    http://www.youtube.com/watch?v=dOZUYxwhduE
    The Absence of Evidence is not the Evidence of Absence

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    37,097
    Blog Entries
    16

    Default Re: Browsers wont play flash SOUND

    Follow this if 11.2, scroll up for earlier versions

    Multi-media and Restricted Format Installation Guide - openSUSE Forums
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,867
    Blog Entries
    30

    Default Re: Browsers wont play flash SOUND

    Quote Originally Posted by Rayja20 View Post
    I also installed libffmpeg0.
    You have been very helpfull ^_^.
    The dependencies that come with libffmpeg0 provide most of the codecs that you will need.

    Quote Originally Posted by Rayja20 View Post
    Btw - what codecs / packages do you reccomend to get my system playing the typical video file thats out there?
    (whether by caffine, or what have you).

    Im currently not able to...
    Please note the link caf4926 provided in his post.

    In part because of the tremendous flexibility offered with openSUSE Linux, it has also meant there is tremendous room for a misconfiguration that causes the appearance of non-functionality.

    Wrt codecs, there is no 100% agreed standard (unfortunately) and hence not all packagers put codecs in the same place that the various multimedia applications can find them. Hence if you were to install codecs from videolan/libdvdcss reopsitories, there may be various Packman packaged (and Novell packaged) applications may not find them, and hence no sound or possibly no video with an application, even though the codecs are in place.

    Thus to avoid this risk (and also for other reasons) I always recommend new users stick to having only the 3 official Novell/SuSE-GmbH repositories (OSS, Non-OSS, and Update) and one and only one 3rd party repository, Packman. No others. Just those 4: OSS, Non-OSS, Update and Packman. There is guidance here for that: Repositories/11.2 - openSUSE-Community Avoid the temptation to add more than those 4 !! Users with lots of openSUSE experience under their belt can add and keep in place more than those 4. New/average users can not. So just those 4. IF you need an application from a 5th repository which is not one of those 4, then add the 5th repository, add the application, and disable or remove the 5th repository. Keep your repositories LEAN and MEAN.

    Now typically the desktops and multimedia applications in openSUSE give one the choice of choosing a different sound engine. I prefer to use xine as my sound engine. Hence I always install the Packman packaged version of libxine1 (provides the sound engine) and xine-ui (provides the user interface for tuning the engine). Then in KDE I ensure under Configure Desktop > Multimedia I have the xine back end selected.

    Good media players that I like to use are vlc and smplayer. Other players such as kaffeine and of course xine (with xine-ui) can be used.

    Note in each media player, one can go and tune the audio backend.

    In cases where a user has already installed a bunch of videolan packaged apps, to avoid the compatibility problems that I noted, I typically recommend users then switch all of those videolan packaged apps to Novell packaged apps. This is very easy to do in openSUSE-11.2 with the qt version of YaST.

  6. #6

    Default Re: Browsers wont play flash SOUND

    Quick
    Curteous
    Effective

    Where's the Rep button!? ;p

    (my Vids work great now)
    http://www.youtube.com/watch?v=dOZUYxwhduE
    The Absence of Evidence is not the Evidence of Absence

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    37,097
    Blog Entries
    16

    Default Re: Browsers wont play flash SOUND

    Quote Originally Posted by Rayja20 View Post
    Quick
    Curteous
    Effective

    Where's the Rep button!? ;p

    (my Vids work great now)
    We would be interested to know if any particular aspect of our help worked. It helps us advise others.
    Happy it's working now.

    'rep' button= is along the top right of each post in the thread. Just hover over them and it should reveal.
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

  8. #8

    Default Re: Browsers wont play flash SOUND

    That multimedia Guide Got me quite on the road.
    I havent checked - but CERTAINLY it is stickied?

    I installed the reccomended packages, and now I have a comprehensive set of FUNCTIONAL decoders on my system.
    Thanks much Caf, and you too oldcpu.
    http://www.youtube.com/watch?v=dOZUYxwhduE
    The Absence of Evidence is not the Evidence of Absence

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    37,097
    Blog Entries
    16

    Default Re: Browsers wont play flash SOUND

    Good to hear. Take you time getting familiar with things before jumping in at the deep end
    My openSUSE 13.1 KDE Box
    My Articles
    Was I any help? If yes: Click the star below

  10. #10

    Default Re: Browsers wont play flash SOUND

    But its soo deep and pretty

    Im quite pleased with suse.
    My intention, while learning suse linux, is to create a fully functional opensuse desktop, with all the functionality of my past windoze desktop.

    How long have you been using suse ^_^ ?
    http://www.youtube.com/watch?v=dOZUYxwhduE
    The Absence of Evidence is not the Evidence of Absence

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •