Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Access denied for user 'root'@'localhost' (using password: NO)

  1. #1

    Default Access denied for user 'root'@'localhost' (using password: NO)

    Please help as I am pulling my hair out once again after trying for over 15 months off and on to get a tv tuner working under linux. I have just received my new tuner card which I thought was supposed to be easy to run, a HVR-950Q, no luck yet.

    But first I am trying to use something called mysql (new to me), for mythtv and [I] keep getting

    # mysqladmin -u root password ma
    mysqladmin: connect to server at 'localhost' failed
    error: 'Access denied for user 'root'@'localhost' (using password: NO)'


    I screwed something up .... help please
    A Newbie to SUSE, thank goodness, and thank you, these forums make the difference
    and I will always leave a thread "SOLVED" with noobies in mind, like I would like!

  2. #2

    Default Re: Access denied for user 'root'@'localhost' (using password: NO)

    and to make things worse, and while trying an alternative (Kaffeine in gnome), it gives me this error when I run it, and I don't see a simple solution for it?!!!!!!

    please install Qt SQLite plugin,

    and where can i find this now????
    Last edited by ack0329; 13-Mar-2010 at 04:28. Reason: typing error
    A Newbie to SUSE, thank goodness, and thank you, these forums make the difference
    and I will always leave a thread "SOLVED" with noobies in mind, like I would like!

  3. #3
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,941
    Blog Entries
    4

    Default Re: Access denied for user 'root'@'localhost' (using password: NO)

    The correct way to specify the password to mysql is:

    mysqladmin -u root -p

    and it will be prompted for. Otherwise, put the password right after the -p, but this is less secure as somebody using ps could spot your password.

    mysqladmin -u root -p'topsecret'

    This pattern applies to all the mysql utilities.

  4. #4

    Default Re: Access denied for user 'root'@'localhost' (using password: NO)

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Try tvtime

    - --
    VampirD
    No in elenath hlar nan hd gn
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.12 (GNU/Linux)
    Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org/

    iEYEARECAAYFAkubp7YACgkQJQ+0ABWtaVmSuQCgy4mbL18LW8OVmw4VAB8JLRiB
    v0gAnRZ5e0WOQ96yff6soFvz+CCLR1e7
    =cqb0
    -----END PGP SIGNATURE-----

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    14,054
    Blog Entries
    12

    Default Re: Access denied for user 'root'@'localhost' (using password: NO)

    Read this first, then look for instructions to get some basic scanfiles for where you live, then scan with kaffeine.

    Hauppauge WinTV-HVR-950Q - LinuxTVWiki

    Did you do all it says here?
    - Athlon X6 3.6 GHz, 16 GB DDR3, 30 GB SSD, 3 TB of disks, GT540, openSUSE 12.2 x86_64 + KDE 4.10 + GNOME 3
    - ASUS A73SD, Intel + GT610M Optimus, 6 GB, 120 GB SSD, openSUSE Tumbleweed

    Anything that can go wrong.... will teach us

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6

    Default Re: Access denied for user 'root'@'localhost' (using password: NO)

    Quote Originally Posted by VampirD View Post
    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Try tvtime

    - --
    VampirD

    =cqb0
    -----END PGP SIGNATURE-----
    TVTime just uses my CAM at video source camera 1, with no option to change its location, arghhhhhh
    A Newbie to SUSE, thank goodness, and thank you, these forums make the difference
    and I will always leave a thread "SOLVED" with noobies in mind, like I would like!

  7. #7

    Default Re: Access denied for user 'root'@'localhost' (using password: NO)

    Quote Originally Posted by ken_yap View Post
    The correct way to specify the password to mysql is:

    mysqladmin -u root -p and it will be prompted for.

    Otherwise, put the password right after the -p, but this is less secure as somebody using ps could spot your password.

    mysqladmin -u root -p'topsecret'
    ok this is a new learning curve for sure, nothing makes sense at this point so I am sure I am making a lot of silly mistakes, here is what I get when i use the above method

    linux-26yx:~ # mysqladmin -u root -pma
    mysqladmin Ver 8.42 Distrib 5.1.36, for suse-linux-gnu on x86_64
    Copyright 2000-2008 MySQL AB, 2008 Sun Microsystems, Inc.
    This software comes with ABSOLUTELY NO WARRANTY. This is free software,
    and you are welcome to modify and redistribute it under the GPL license
    .... and a lot of help suggestions
    and when I try to setup the backend of mythtv, it says cannot connect to the data base and I have tried
    Hostname -localhost
    Database name - mythconverg
    user/password - root/ma, and tried mythtv/mythtv, and tried ack/ma
    and always unable to connect to database
    I am sure it is not set up right!
    A Newbie to SUSE, thank goodness, and thank you, these forums make the difference
    and I will always leave a thread "SOLVED" with noobies in mind, like I would like!

  8. #8
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,941
    Blog Entries
    4

    Default Re: Access denied for user 'root'@'localhost' (using password: NO)

    Have you created the database for mythtv and given it a user and password to access it? Where do your instructions come from? Your starting point may depend on whether you have already set a root password for mysql (the root in mysql, or in fact any mysql accounts, is not the same as root in Linux and has a separate password).

  9. #9

    Default Re: Access denied for user 'root'@'localhost' (using password: NO)

    Thanks tha make sthings clearer and I like how you are assuming I know nothing (It is quite true about this anyway). So when trying to setup mythtv backend should I be using
    1/ my own user name/password, ex ack@localhost/psswrd, or
    2/ mythtv/mythtv, or
    3/ root/psswrd,
    and how do I set them up without getting the help menu(that is all I get from...#mysqladmin -u root -p, or
    #mysqladmin -u root -p'topsecret'

    and for anything that tries to connect I get for example

    linux-26yx:~ # mysql -u root mythconverg
    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)

    I will try to uninstall mysql and start from scratch
    A Newbie to SUSE, thank goodness, and thank you, these forums make the difference
    and I will always leave a thread "SOLVED" with noobies in mind, like I would like!

  10. #10
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,941
    Blog Entries
    4

    Default Re: Access denied for user 'root'@'localhost' (using password: NO)

    If you don't have any recollection of setting up a mysql root password, then there is none. You should be able to get a mysql prompt by

    Code:
    mysql -u root
    And exit with quit or ctrl-d.

    If that is the case, here's how you create a database for mythtv and account to access it. The mysql> is the prompt you see, not for you to type in.

    Code:
    mysql> create database mythtv;
    mysql> grant all on mythtv.* to mythtv@localhost identified by 'mythtv';
    The first mythtv is the database name, the second the account name, and the third the password. This is in case you want to use other values.

    You can then exit mysql as root and login as mythtv to test:

    Code:
    mysql -u mysql -p mythtv
    Password: 
    mysql>
    The first mythtv is the account name, the second the database to use.

    Then you can proceed with the mythtv setup.

    If you did set up a root password for mysql (would not be the same as your Linux root password), then I hope you remember it. The only difference would be adding -p to the command line when connecting as root in the first invocation:

    Code:
    mysql -u root -p
    Password:
    mysql>

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •