Results 1 to 7 of 7

Thread: Open SUSE 11.2 - PPPOE - Need help

  1. #1

    Default Open SUSE 11.2 - PPPOE - Need help

    So here is what I am trying to do. I want to connect my Open Suse 11 machine to the internet. I am almost there.

    1. I configured my network card and eth0 is up.
    2. I configured my DSL with user name and password and I am authenticated.
    3. An IP address is assigned to me and the DNS servers are retrieved.

    However I cannot ping or visit any website

    I use the YAST automatic configuration and kinternet to connect. Here are the gritty details

    192.168.1.1 - My router IP
    192.168.1.10 - IP on the internal network

    Route:
    Before connecting to the internet

    /sbin/route
    Code:
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
    link-local      *               255.255.0.0     U     0      0        0 eth0
    loopback        *               255.0.0.0       U     0      0        0 lo
    default         192.168.1.1     0.0.0.0         UG    0      0        0 eth0
    After connecting to the internet
    /sbin/route
    Code:
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    XX.XX.XX.XX     *               255.255.255.255 UH    0      0        0 ppp0
    192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
    link-local      *               255.255.0.0     U     0      0        0 eth0
    loopback        *               255.0.0.0       U     0      0        0 lo
    default         192.168.1.1     0.0.0.0         UG    0      0        0 eth0
    Interface config:
    /sbin/ifconfig
    Code:
    eth0      Link encap:Ethernet  HWaddr XXXXXX
              inet addr:192.168.1.10  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: XXXXXX Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:755 errors:0 dropped:0 overruns:0 frame:0
              TX packets:603 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:64121 (62.6 Kb)  TX bytes:46833 (45.7 Kb)
              Interrupt:16
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:196 errors:0 dropped:0 overruns:0 frame:0
              TX packets:196 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:13720 (13.3 Kb)  TX bytes:13720 (13.3 Kb)
    
    ppp0      Link encap:Point-to-Point Protocol
              inet addr:XXXXXXXX  P-t-P:XXXXXXXX  Mask:255.255.255.255
              UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
              RX packets:17 errors:0 dropped:0 overruns:0 frame:0
              TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:3
              RX bytes:1627 (1.5 Kb)  TX bytes:54 (54.0 b)
    Ping fails:
    ping google.com
    ping: unknown host google.com

    Netcat fails:
    netcat google.com 80
    google.com: forward host lookup failed:

    Name servers are as expected. I am able to verify that they are valid.
    cat /etc/resolv.conf
    nameserver 218.248.240.179
    nameserver 218.248.240.134

    I do see that kinternet has trouble reading /etc/resolv.conf. It says 'permission denied' although read permissions are set on both /sbin/route and the path that it links to. This should not matter however since the existing entries are already there and valid. I also tried to turn off the firewall suspecting it could be a problem.

    So I am being authenticated successfully ( verified with the logs ); assigned an IP; the route seems ok; firewall seems ok. But I cannot browse or do internet things

    I have been tweaking settings for 3 days now and all seems in vain. Do enlighten me on what I am doing wrong. I bet its something silly that I overlooked. I have had success configuring the same thing in red hat linux and browsing the internet without trouble. Is there something OpenSuse specific that I am missing ?

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,270

    Default Re: Open SUSE 11.2 - PPPOE - Need help

    On 02/25/2010 12:06 AM, DeepakBala wrote:
    >
    > So here is what I am trying to do. I want to connect my Open Suse 11
    > machine to the internet. I am almost there.
    >
    > 1. I configured my network card and eth0 is up.
    > 2. I configured my DSL with user name and password and I am
    > authenticated.
    > 3. An IP address is assigned to me and the DNS servers are retrieved.
    >
    > However I cannot ping or visit any website
    >
    > I use the YAST automatic configuration and kinternet to connect. Here
    > are the gritty details
    >
    > 192.168.1.1 - My router IP
    > 192.168.1.10 - IP on the internal network
    >
    > ROUTE:
    > Before connecting to the internet
    >
    > /sbin/route
    >
    > Code:
    > --------------------
    >
    > Kernel IP routing table
    > Destination Gateway Genmask Flags Metric Ref Use Iface
    > 192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
    > link-local * 255.255.0.0 U 0 0 0 eth0
    > loopback * 255.0.0.0 U 0 0 0 lo
    > default 192.168.1.1 0.0.0.0 UG 0 0 0 eth0
    >
    > --------------------
    >
    >
    > After connecting to the internet
    > /sbin/route
    >
    > Code:
    > --------------------
    >
    > Kernel IP routing table
    > Destination Gateway Genmask Flags Metric Ref Use Iface
    > XX.XX.XX.XX * 255.255.255.255 UH 0 0 0 ppp0
    > 192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
    > link-local * 255.255.0.0 U 0 0 0 eth0
    > loopback * 255.0.0.0 U 0 0 0 lo
    > default 192.168.1.1 0.0.0.0 UG 0 0 0 eth0
    >
    > --------------------
    >
    >
    > Interface config:
    > /sbin/ifconfig
    >
    > Code:
    > --------------------
    >
    > eth0 Link encap:Ethernet HWaddr XXXXXX
    > inet addr:192.168.1.10 Bcast:192.168.1.255 Mask:255.255.255.0
    > inet6 addr: XXXXXX Scope:Link
    > UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    > RX packets:755 errors:0 dropped:0 overruns:0 frame:0
    > TX packets:603 errors:0 dropped:0 overruns:0 carrier:0
    > collisions:0 txqueuelen:1000
    > RX bytes:64121 (62.6 Kb) TX bytes:46833 (45.7 Kb)
    > Interrupt:16
    >
    > lo Link encap:Local Loopback
    > inet addr:127.0.0.1 Mask:255.0.0.0
    > inet6 addr: ::1/128 Scope:Host
    > UP LOOPBACK RUNNING MTU:16436 Metric:1
    > RX packets:196 errors:0 dropped:0 overruns:0 frame:0
    > TX packets:196 errors:0 dropped:0 overruns:0 carrier:0
    > collisions:0 txqueuelen:0
    > RX bytes:13720 (13.3 Kb) TX bytes:13720 (13.3 Kb)
    >
    > ppp0 Link encapoint-to-Point Protocol
    > inet addrXXXXXXX P-t-PXXXXXXX Mask:255.255.255.255
    > UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
    > RX packets:17 errors:0 dropped:0 overruns:0 frame:0
    > TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
    > collisions:0 txqueuelen:3
    > RX bytes:1627 (1.5 Kb) TX bytes:54 (54.0 b)
    >
    > --------------------
    >
    >
    > PING FAILS:
    > ping google.com
    > ping: unknown host google.com
    >
    > NETCAT FAILS:
    > netcat google.com 80
    > google.com: forward host lookup failed:
    >
    > Name servers are as expected. I am able to verify that they are valid.
    > cat /etc/resolv.conf
    > nameserver 218.248.240.179
    > nameserver 218.248.240.134
    >
    > I do see that kinternet has trouble reading /etc/resolv.conf. It says
    > 'permission denied' although read permissions are set on both
    > /sbin/route and the path that it links to. This should not matter
    > however since the existing entries are already there and valid. I also
    > tried to turn off the firewall suspecting it could be a problem.
    >
    > So I am being authenticated successfully ( verified with the logs );
    > assigned an IP; the route seems ok; firewall seems ok. But I cannot
    > browse or do internet things
    >
    > I have been tweaking settings for 3 days now and all seems in vain. Do
    > enlighten me on what I am doing wrong. I bet its something silly that I
    > overlooked. I have had success configuring the same thing in red hat
    > linux and browsing the internet without trouble. Is there something
    > OpenSuse specific that I am missing ?


    Delete /etc/resolv.conf and reboot.

  3. #3

    Default Re: Open SUSE 11.2 - PPPOE - Need help

    I tried deleting resolv.conf and then rebooted. I reconnected to the internet using kinternet and a resolv.conf file was created with the following content, but I am still unable to ping websites or IP addresses.

    Code:
    ### /etc/resolv.conf file autogenerated by netconfig!
    #
    # Before you change this file manually, consider to define the
    # static DNS configuration using the following variables in the
    # /etc/sysconfig/network/config file:
    #     NETCONFIG_DNS_STATIC_SEARCHLIST
    #     NETCONFIG_DNS_STATIC_SERVERS
    #     NETCONFIG_DNS_FORWARDER
    # or disable DNS configuration updates via netconfig by setting:
    #     NETCONFIG_DNS_POLICY=''
    #
    # See also the netconfig(8) manual page and other documentation.
    #
    # Note: Manual change of this file disables netconfig too, but
    # may get lost when this file contains comments or empty lines
    # only, the netconfig settings are same with settings in this
    # file and in case of a "netconfig update -f" call.
    #
    ### Please remove (at least) this line when you modify the file!
    nameserver 192.168.1.1
    nameserver 218.248.240.179
    nameserver 218.248.240.134
    Typing the IP address of google.com inside firefox also did not help. So looks like the problem goes beyond DNS resolution.

    Any thoughts ?

  4. #4
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,270

    Default Re: Open SUSE 11.2 - PPPOE - Need help

    On 02/25/2010 09:36 AM, DeepakBala wrote:
    >
    > I tried deleting resolv.conf and then rebooted. I reconnected to the
    > internet using kinternet and a resolv.conf file was created with the
    > following content, but I am still unable to ping websites or IP
    > addresses.


    Baby steps first. Can you ping 192.168.1.1 (your router)?

  5. #5

    Default Re: Open SUSE 11.2 - PPPOE - Need help

    Just gave that a try and I am able to ping 192.168.1.1.

    Tried to ping my DNS servers and they did not give any response

  6. #6
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,270

    Default Re: Open SUSE 11.2 - PPPOE - Need help

    On 02/25/2010 11:06 AM, DeepakBala wrote:
    >
    > Just gave that a try and I am able to ping 192.168.1.1.
    >
    > Tried to ping my DNS servers and they did not give any response


    I have not used ppp so I am guessing, but it looks as if you are tunneling
    through the router, thus your default route needs to be set to the ISP's router,
    not yours. As you obscured your IP, I cannot even guess what it's IP might be,
    but it should be the address in this line:

    XX.XX.XX.XX * 255.255.255.255 UH 0 0 0 ppp0

    Use the command "sudo route add default gw xx.xx.xx.xx" so that your default
    gateway for ppp0 is established.

  7. #7

    Default Re: Open SUSE 11.2 - PPPOE - Need help

    Thanks for all the help. This is what I did.

    I went to Yast -> Network devices
    My DSL setting has a default route option that is not checked. I checked this.

    When I do this, kinternet adjusts the default gateway by itself when it connects and there is no need for me to add the gateway. This is what route looks like after the connection

    Code:
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    XX.XX.XX.XX     *               255.255.255.255 UH    0      0        0 dsl0
    192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
    link-local      *               255.255.0.0     U     0      0        0 eth0
    loopback        *               255.0.0.0       U     0      0        0 lo
    default         *               0.0.0.0         U     0      0        0 dsl0
    I am now able to connect to the net. Using Suse to reply now

    I still have to explore the modes in my router to fully understand all the possibilities.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •