Page 1 of 6 123 ... LastLast
Results 1 to 10 of 59

Thread: Dolphin losing files when copying many files or large folders

  1. #1
    Join Date
    May 2009
    Location
    EU
    Posts
    1,009

    Default Dolphin losing files when copying many files or large folders

    I've discovered that Dolphin seems to lose random files when copying many large folders.

    I first noticed this a few months ago when I tried to copy my music library from one folder to another on the same HDD. It consisted of around 600 folders and 6500 files. During the copy there were no errors but after the copy I found that some of the newly copied folders were missing files. I put it down to human error or a glitch.

    Yesterday I tried to copy 13 folders containing rips of some of my DVDs. Each folder basically had one film of either 700MB or 1.4GB. Again no errors showed up during the copy but I found 3 of the newly copied folders were empty.

    This is very worrying. It's not so critical with music or films but I can't afford to lose work data like this.

    Has anyone experienced or seen a similar problem with Dolphin? I'm going to have to do some more extensive testing but this is not good.

    The first time I noticed the problem I was running KDE4.3.4 (I think) and now the latest was with KDE4.4.0.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE 12.3 | KDE4.10.1
    ASUS M3N78 | AMD 64x2 5400+ | nvidia 8200+ | 2GB | openSUSE 12.3 | KDE4.10.1
    Acer Aspire Revo R3610 | Atom 330 | nvidia ION | 2GB | openSUSE 12.3 | KDE4.10.1

  2. #2
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,903

    Default Re: Dolphin losing files when copying many files or large folders

    This is bad news. Have you filed any bug?

    Personally, I never use GUI for copying large number of files. Still can't get mentally adjusted with those little GUI windows that show the status of the copy process.
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    13,978
    Blog Entries
    12

    Default Re: Dolphin losing files when copying many files or large folders

    Did a test, copied entire music collection to USB disk (731 folders, 15781 files) with Dolphin. No trouble at all.

    But it is scary. Can you reproduce this? Or could it be, that a HDD is degrading?
    - Athlon X6 3.6 GHz, 16 GB DDR3, 30 GB SSD, 3 TB of disks, GT540, openSUSE 12.2 x86_64 + KDE 4.10 + GNOME 3
    - ASUS A73SD, Intel + GT610M Optimus, 6 GB, 120 GB SSD, openSUSE Tumbleweed

    Anything that can go wrong.... will teach us

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,099

    Default Re: Dolphin losing files when copying many files or large folders

    Starting dolphin via command line and copying some large folders could give us some interesting output.

  5. #5
    Join Date
    May 2009
    Location
    EU
    Posts
    1,009

    Default Re: Dolphin losing files when copying many files or large folders

    I'll start doing some tests during the week. I haven't filed any bug yet as I want to try reproduce it reliably if possible. I'm sure I saw a bug for something similar when I first came to openSUSE last year but I cannot find anything in bugzilla. It may just have been a rant by someone who didn't like KDE4 I can't really remember any more.

    Good suggestion gropiuskalle. Hopefully I'll see something useful in the output.

    Can someone suggest an app / script which can do a compare of the original and copied directories to verify the copied folders and files are all present and correct?
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE 12.3 | KDE4.10.1
    ASUS M3N78 | AMD 64x2 5400+ | nvidia 8200+ | 2GB | openSUSE 12.3 | KDE4.10.1
    Acer Aspire Revo R3610 | Atom 330 | nvidia ION | 2GB | openSUSE 12.3 | KDE4.10.1

  6. #6
    Join Date
    Jul 2009
    Location
    Calgary Alberta Canada
    Posts
    1,188

    Lightbulb Re: Dolphin losing files when copying many files or large folders

    Quote Originally Posted by suse_tpx60s View Post
    I've discovered that Dolphin seems to lose random files when copying many large folders.

    I first noticed this a few months ago when I tried to copy my music library from one folder to another on the same HDD. It consisted of around 600 folders and 6500 files. During the copy there were no errors but after the copy I found that some of the newly copied folders were missing files. I put it down to human error or a glitch.

    Yesterday I tried to copy 13 folders containing rips of some of my DVDs. Each folder basically had one film of either 700MB or 1.4GB. Again no errors showed up during the copy but I found 3 of the newly copied folders were empty.

    This is very worrying. It's not so critical with music or films but I can't afford to lose work data like this.

    Has anyone experienced or seen a similar problem with Dolphin? I'm going to have to do some more extensive testing but this is not good.

    The first time I noticed the problem I was running KDE4.3.4 (I think) and now the latest was with KDE4.4.0.
    This is both good and bad. Good that I finally have validation for problems I had encountered with dolphin which some in the community had called me troll/FUD for stating and bad that another is experiencing the problem. Here is what I have found with my system and my workarounds:
    1) Dolphin does not always show the files which were moved, copied or changed in real time.
    Thusly, if you copy files or folders as groups, not all will appear at the destination right away. Close Dolphin and reopen and sometimes they will now show. other times it takes a reboot before they show. Other times you have to re-copy the files
    When you change a file a back-up is normally created but does not show up immediately all the time. If you immediately try to open another file for editing (and the back-up hasn't shown) you will at times suddenly get a box asking how the backup should be opened instead of the file you requested. You simply cancel the open and re-select the file you want.
    When you move files Dolphin will on occasion delete the file from the source location and fail to add it in the destination resulting in a lost file(s). Resolve, use CLI or midnight commander or another file manager at all times for moves!!
    IMHO someone has dropped the ball here. Dolphin did not exhibit this behavior before when using 11.1 32bit/KDE 4.3.1 but does when using 11.1 64bit/KDE 4.3.1, 11.2 32/64bit/KDE >=4.3.1.
    When your up to your a** in Alligators it's pretty hard to remember you intended to drain the swamp (author unknown)

  7. #7
    Join Date
    Nov 2009
    Location
    West by God Virginia
    Posts
    6,261

    Default Re: Dolphin losing files when copying many files or large folders

    Do they show up if you hit the reload?

  8. #8
    Join Date
    May 2009
    Location
    EU
    Posts
    1,009

    Default Re: Dolphin losing files when copying many files or large folders

    Quote Originally Posted by techwiz03 View Post
    This is both good and bad. Good that I finally have validation for problems I had encountered with dolphin which some in the community had called me troll/FUD for stating and bad that another is experiencing the problem. Here is what I have found with my system and my workarounds:
    1) Dolphin does not always show the files which were moved, copied or changed in real time.
    Thusly, if you copy files or folders as groups, not all will appear at the destination right away. Close Dolphin and reopen and sometimes they will now show. other times it takes a reboot before they show. Other times you have to re-copy the files
    When you change a file a back-up is normally created but does not show up immediately all the time. If you immediately try to open another file for editing (and the back-up hasn't shown) you will at times suddenly get a box asking how the backup should be opened instead of the file you requested. You simply cancel the open and re-select the file you want.
    When you move files Dolphin will on occasion delete the file from the source location and fail to add it in the destination resulting in a lost file(s). Resolve, use CLI or midnight commander or another file manager at all times for moves!!
    IMHO someone has dropped the ball here. Dolphin did not exhibit this behavior before when using 11.1 32bit/KDE 4.3.1 but does when using 11.1 64bit/KDE 4.3.1, 11.2 32/64bit/KDE >=4.3.1.
    I can't say that I ever experienced what you describe. In my case the files were definitely missing. The problem is that it seems to be random when the files get missed. I just tried copying a the same 13 folders containing the dvd rips and they all copied properly this time.

    I wonder if it has anything to do with what other activities are being performed on the PC or file system at the time. I'll set up a few test during the week and see if I can reproduce the problem.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE 12.3 | KDE4.10.1
    ASUS M3N78 | AMD 64x2 5400+ | nvidia 8200+ | 2GB | openSUSE 12.3 | KDE4.10.1
    Acer Aspire Revo R3610 | Atom 330 | nvidia ION | 2GB | openSUSE 12.3 | KDE4.10.1

  9. #9

    Default Re: Dolphin losing files when copying many files or large folders

    Quote Originally Posted by suse_tpx60s View Post
    I can't say that I ever experienced what you describe. In my case the files were definitely missing. The problem is that it seems to be random when the files get missed. I just tried copying a the same 13 folders containing the dvd rips and they all copied properly this time.

    I wonder if it has anything to do with what other activities are being performed on the PC or file system at the time. I'll set up a few test during the week and see if I can reproduce the problem.
    I thought I'd better sign up and chime in on this one as I believe the problem goes deeper than Dolphin and openSUSE (I'm a Linux Mint user.) I lost some files months ago when I copied and pasted folders to a backup drive and failed to notice that all the files hadn't made it across. I figured I'd screwed up. But I've verified the copies since and I just saw it happen again. Not a matter of the file count not updating immediately -- the files and folders were definitely not written. So I tried the same operation in Krusader (in root mode, too.) It happened again! The number of files and folders that were missing changed, so I don't see a pattern. So this isn't limited to Dolphin. But I should also mention that in all cases I was writing to an external USB Seagate drive. I haven't tried duplicating folders on the same hard drive. Oh, I'm using EXT4. I wonder if it could be some weird journaling goof or something.

  10. #10

    Default Re: Dolphin losing files when copying many files or large folders

    I have also experienced the same problem suse_tpx60s et al have described, when using either Dolphin or Konqueror on suse 11.2. I had the impression that neither could handle complex directory trees but I have not done any hard analysis.

    It is a little sad, since Konqueror (under KDE 3.5.9) on suse 11.0 did not appear to have this problem and was a godsend. When I now copy large complex directories, I always ask Dolphin to calculate the total directory size (down to the last byte) and the number of files and directories for both input and output before relaxing.

    Strangely, a number of well know third party apps on Windows seem to exhibit the same behaviour such as e.g. Ipswich (?) FTP LE.

    I use ReiserFS for most of my Linux file systems so it is nothing to do with Ext4.

Page 1 of 6 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •