Results 1 to 10 of 10

Thread: Loading console keymap on boot

  1. #1

    Default Loading console keymap on boot

    Bon appetit folks,

    During boot-up of openSUSE 11.2 (dup'd from 11.1; default runlevel 3) the following message appears:

    Code:
    Loading keymap assuming iso-8859-15 euro
    I remember changing the keymap to be loaded from 'de-latin1-nodeadkeys' to 'de-latin1' back in 11.1, and I believe that's when the message started appearing. And before changing this in, iirc, /etc/sysconfig/language, I for a while had set the keymap manually using an UTF-8 option.

    My question now: Is there a way to tell SUSE to set the above mentioned keymap using UTF-8 encoding instead of assuming ISO-8859-15?

    The few Google search results (~7) on this topic also seem to indicate that this is a 'German-only' problem because it only seems to appear when setting German keymaps.

    Greetings

    vzduch a.k.a. szal

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    14,036
    Blog Entries
    12

    Default Re: Loading console keymap on boot

    Yast - System - /etc/sysconfig editor. Use the search function to look for LC, keymap, or 8859. AFAIK utf-8 is the standard now.
    - Athlon X6 3.6 GHz, 16 GB DDR3, 30 GB SSD, 3 TB of disks, GT540, openSUSE 12.2 x86_64 + KDE 4.10 + GNOME 3
    - ASUS A73SD, Intel + GT610M Optimus, 6 GB, 120 GB SSD, openSUSE Tumbleweed

    Anything that can go wrong.... will teach us

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Loading console keymap on boot

    Searching for LC delivers the following values in /etc/sysconfig/language:

    Code:
    AUTO_DETECT_UTF8   no
    RC_LANG            en_US.UTF-8
    RC_LC_ALL          <not set>
    RC_LC_COLLATE      <not set>
    RC_LC_CTYPE        <not set>
    RC_LC_MESSAGES     <not set>
    RC_LC_MONETARY     <not set>
    RC_LC_NUMERIC      <not set>
    RC_LC_PAPER        de_DE.UTF-8
    RC_LC_TIME         <not set>
    ROOT_USES_LANG     ctype
    I guess I can safely omit search results in /etc/sysconfig/suseconfig and /etc/sysconfig/postfix.

    Searching for keymap delivers 2 results from /etc/sysconfig/keyboard:

    Code:
    COMPOSETABLE   clear utf8  # I changed it to that from the latin1.add compose table.
    KEYTABLE       de-latin1.map.gz
    I believe both of these are irrelevant to my question.

    Searching for 8859 delivers no results.

    As I see it, there is nothing in there pointing towards an ISO-8859 encoding. So the question remains: Why does SUSE assume that it should be used for the keymap?

  4. #4

    Default Re: Loading console keymap on boot

    *bump* Still no ideas?

  5. #5
    palladium NNTP User

    Default Re: Loading console keymap on boot

    vzduch wrote:
    > Searching for "LC" delivers the following values in
    > /etc/sysconfig/language:
    >
    > Code:
    > --------------------
    > AUTO_DETECT_UTF8 no
    > RC_LANG en_US.UTF-8
    > [snip]
    > --------------------


    CAUTION: i freely admit i don't know what i'm doing, and what i'm
    about to type may be all wrong, but:

    shouldn't that RC_LANG en_US.UTF-8
    be RC_LANG de_DE.UTF-8

    note: before doing anything, read this: http://tinyurl.com/6aagco

    --
    palladium

  6. #6
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,941
    Blog Entries
    4

    Default Re: Loading console keymap on boot

    Quote Originally Posted by vzduch View Post
    My question now: Is there a way to tell SUSE to set the above mentioned keymap using UTF-8 encoding instead of assuming ISO-8859-15?
    It seems to me that UTF-8 is irrelevant to a keymap. UTF-8 specifies an encoding for transmission and storage, whereas a keymap specifies what character is generated by each position on your keyboard. Whether it generates a Latin-1 encoding or a UTF-8 encoding is handled elsewhere. For example my keymap is US even though I'm in Australia because that's the keyboard we use here (we have $ not ). 8859-15 contains the sign.

  7. #7
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,090

    Default Re: Loading console keymap on boot

    Quote Originally Posted by palladium View Post
    shouldn't that RC_LANG en_US.UTF-8
    be RC_LANG de_DE.UTF-8
    palladium
    According to this SUSE Linux Enterprise Server (SLES 10) - Installation and Administration - Language and Country-Specific Settings it sets the fallback language, english.

  8. #8
    palladium NNTP User

    Default Re: Loading console keymap on boot

    ah...thank you!

    --
    palladium

  9. #9

    Default Re: Loading console keymap on boot

    Quote Originally Posted by palladium View Post
    vzduch wrote:
    > Searching for "LC" delivers the following values in
    > /etc/sysconfig/language:
    >
    > Code:
    > --------------------
    > AUTO_DETECT_UTF8 no
    > RC_LANG en_US.UTF-8
    > [snip]
    > --------------------


    CAUTION: i freely admit i don't know what i'm doing, and what i'm
    about to type may be all wrong, but:

    shouldn't that RC_LANG en_US.UTF-8
    be RC_LANG de_DE.UTF-8
    I set the system-wide language to en_US, so I assume this to be correct. What made you think of de_DE? The 'RC_PAPER' value? That is just so the system knows I don't have any US paper formats available here, thus sparing me some hassle when printing.

  10. #10
    palladium NNTP User

    Default Re: Loading console keymap on boot

    obviously i didn't know what i was talking about...a fact i warned
    before hand...sorry for confusing.. (sometimes i get lucky when
    imagining what _might_ work)

    --
    palladium

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •