Results 1 to 5 of 5

Thread: Can't use repo unless I specify the server by IP

  1. #1
    Join Date
    Dec 2008
    Location
    Houston
    Posts
    57

    Default Can't use repo unless I specify the server by IP

    I am currently using 11.2 with KDE but I have had this problem with Gnome and 11.2 RC 1 & 2.

    This started as an inability to use the internet but I found a way to disable ipv6 in /etc/fstab and I disable it in firefox and that has got me 99% functional. My only issue left is not being able to use any repos unless I can specify a server by IP.

    I have the opensuse repos working by looking at the mirror list and found one that did not use a DNS name and that was the end of that, but I cannot access packman or any others yet.

    Any ideas?

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,381

    Default Re: Can't use repo unless I specify the server by IP

    On 01/10/2010 05:06 PM, speretz wrote:
    >
    > I am currently using 11.2 with KDE but I have had this problem with
    > Gnome and 11.2 RC 1 & 2.
    >
    > This started as an inability to use the internet but I found a way to
    > disable ipv6 in /etc/fstab and I disable it in firefox and that has got
    > me 99% functional. My only issue left is not being able to use any
    > repos unless I can specify a server by IP.
    >
    > I have the opensuse repos working by looking at the mirror list and
    > found one that did not use a DNS name and that was the end of that, but
    > I cannot access packman or any others yet.


    If you delete /etc/resolv.conf and remake the network connection, does that help?

  3. #3
    Join Date
    Dec 2008
    Location
    Houston
    Posts
    57

    Default Re: Can't use repo unless I specify the server by IP

    Nope. No change.

  4. #4
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,381

    Default Re: Can't use repo unless I specify the server by IP

    On 01/10/2010 09:56 PM, speretz wrote:
    >
    > Nope. No change.


    How about if you

    sudo echo "nameserver 8.8.8.8" >> /etc/resolv.conf


  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    14,085
    Blog Entries
    12

    Default Re: Can't use repo unless I specify the server by IP

    That's Google's nameserver FYI
    - Athlon X6 3.6 GHz, 16 GB DDR3, 64 GB SSD, 3 TB of disks, GT540, openSUSE Factory + KDE
    - ASUS A73SD, Intel + GT610M Optimus, 6 GB, 2 x 120 GB SSD, openSUSE Factory + KDE

    Anything that can go wrong.... will teach us

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •