Results 1 to 8 of 8

Thread: Skype has no sound

  1. #1
    btian NNTP User

    Default Skype has no sound

    There's no sound from the test call (echo123).

    I'm a new OpenSUSE user with a fresh installation of OpenSUSE 11.2 and with restricted format installed.

    There is sound for other applications such as JuK and Youtube via Firefox.

    Is there anything in particular that I should check?

    Sounds under Skype Options only has PulseAudio as option.

  2. #2

    Default Re: Skype has no sound

    Hi

    When you say there's no sound from the test call, does that mean you can't hear the voice inviting you to talk? Or does it mean that when it plays back your chatter there's silence?

    Either way, click bottom left on main menu -> Option -> Sound devices and select your microphone, speakers and ring device.

    Mine are Generic USB Audio device for microphone and speakers and default device for ringing. BTW, I do NOT get a ring-ring when people want to talk to me, which is convenient since I use it for work.

    I am running Skype Beta 2.1.0.47


    Cheers
    Rich

  3. #3
    btian NNTP User

    Default Re: Skype has no sound

    Both...I managed to hear some sound from Skype after installing lots of libraries, but the microphone still doesn't work. I'm using Logitech QuickCam Pro 9000. Microphone works in Krecord...

    Regarding the suggestion to change sound device setting in Skype, pls refer to the last line in my initial post.

  4. #4
    Join Date
    Nov 2009
    Location
    West by God Virginia
    Posts
    6,678

    Default Re: Skype has no sound

    What sound card do you have? Did you install pulseaudio? It was not in the default install here. Have you configured your sound in Yast? How is the microphone connected, is it USB or straight pulg to the sound card?

  5. #5

    Default Re: Skype has no sound

    Hello,
    I have the same cam and the same problem with Skype (However I am on 11.1 64 bit). Skype works with my old mic but not with the Quickcam mic.
    The microphone is part of the camera and shows up as a USB sound device:
    Code:
    cat /proc/asound/cards
     0 [Intel          ]: HDA-Intel - HDA Intel
                          HDA Intel at 0xf9ff8000 irq 22
     1 [U0x46d0x990    ]: USB-Audio - USB Device 0x46d:0x990
                          USB Device 0x46d:0x990 at usb-0000:00:1a.7-5, high speed
    in Skype - Options - Sound devices the only options are PulseAudio Server (local) for all three devices.

    in Pulse - Volume control - Input devices, I selected "USB Device 0x46d:0x990" as default and you can see that it is picking up sound on the "VU meter" but the Skype test call records only silence.
    The USB Audio device also shows in
    Code:
    alsamixer -c1
    but doesn't show up as a card in Yast sound configuration. Should it?
    Code:
     lsusb
    Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 005: ID 046d:0990 Logitech, Inc. QuickCam Pro 9000
    Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 004: ID 045e:009d Microsoft Corp. 
    Bus 002 Device 005: ID 03f0:1204 Hewlett-Packard DeskJet 930c
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 003: ID 04a9:220e Canon, Inc. CanoScan N1240U/LiDE 30
    Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    I installed the quickcam kernel module but it doesn't load automatically. What next?

  6. #6

    Default Re: Skype has no sound

    I remember having to uninstalling all pulseaudio related files except libpulse0 and libpulse-browse0. Skype worked after that.
    This is true for both 11.1 and 11.2. I believe default 11.2 doesn't install pulseaudio.

  7. #7

    Default Re: Skype has no sound

    Hello,
    after several attempts at getting the quickcam mic working, mostly to do with messing with pulseaudio, I finally managed to kill the kernel completely and it wouldn't load any network modules any more. Don't ask me how, even safe mode wouldn't work.
    Anyway I took the opportunity to install Opensuse 11.2 64bit and the webcam and it's microphone are now working with Skype.
    This is the new list of sound cards
    Code:
    cat /proc/asound/cards
     0 [Intel          ]: HDA-Intel - HDA Intel
                          HDA Intel at 0xf9ff8000 irq 22
     1 [Q9000          ]: USB-Audio - QuickCam Pro 9000
                          Logitech, Inc. QuickCam Pro 9000 at usb-0000:00:1a.7-5, high speed
    but still nothing in Yast Sound Configuration. Long as it works.
    A standard 11.2 install does appear to include pulseaudio by the way. I had to choose QuickCam Pro 9000 Analog Mono as the default Input source. I right-clicked the volume control on the Gnome panel and clicked Sound Preferences.

  8. #8
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,701
    Blog Entries
    29

    Default Re: Skype has no sound

    Quote Originally Posted by Robertple4 View Post
    A standard 11.2 install does appear to include pulseaudio by the way.
    My understanding is a standard 11.2 install for Gnome includes Pulse, and a standard install of 11.2 for KDE does NOT include Pulse. The Gnome developers have committed much more to using Pulse than the KDE developers, so IMHO that approach adopted by the SuSE-GmbH packagers is likely the best one for now.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •