Results 1 to 7 of 7

Thread: Updating my KDE form 3.5.9 to 4.5 in Suse 11.0?

  1. #1
    Jackrabbit123 NNTP User

    Default Updating my KDE form 3.5.9 to 4.5 in Suse 11.0?

    I'm a newbie, real new to Susie,I need some help/feedback...

    I was in Kview and downloaded a picture off the internet and let a bug in error. The message says: This application on Kview crashed and cause a signal 11 in SIGSEGV. I went to Bugzilla and tried to report the bug, and for a message stating the my 3.5.9 KDE is outdated and if I down load KDE 4.0 that it most likely will take care of the bug.

    I did find on the KDE website in the repository I found Respository/KDE:43/open/suse_Factory that is suppose to support Suse 11.0.

    I heard that 4.3 KDE is slower? I know that I have enough memory to do the download. Do I download in Yast Adm settings? Will this disrupt my Desktop environment any? Any help with this issue will be helpful....

  2. #2
    Join Date
    Jun 2008
    Location
    Natchez, MS, USA
    Posts
    550

    Default Re: Updating my KDE form 3.5.9 to 4.5 in Suse 11.0?

    Please see the following page.

    KDE/Repositories - openSUSE

    If you are a newbie, please do not install from Factory Repos. 4.3.4 is the latest current release. Get it from the Stable repos. You will have far fewer problems and less wailing and gnashing of teeth.
    Free Fractal Wallpapers
    http://wilsonephillips.smugmug.com

  3. #3
    Join Date
    Jun 2008
    Location
    Frisco, TX
    Posts
    1,185

    Default Re: Updating my KDE form 3.5.9 to 4.5 in Suse 11.0?

    Jackrabbit123 wrote:
    > I'm a newbie, real new to Susie,I need some help/feedback...
    >
    > I was in Kview and downloaded a picture off the internet and let a bug
    > in error. The message says: This application on Kview crashed and cause
    > a signal 11 in SIGSEGV. I went to Bugzilla and tried to report the bug,
    > and for a message stating the my 3.5.9 KDE is outdated and if I down
    > load KDE 4.0 that it most likely will take care of the bug.
    >
    > I did find on the KDE website in the repository I found
    > Respository/KDE:43/open/suse_Factory that is suppose to support Suse
    > 11.0.
    >
    > I heard that 4.3 KDE is slower? I know that I have enough memory to do
    > the download. Do I download in Yast Adm settings? Will this disrupt my
    > Desktop environment any? Any help with this issue will be helpful....
    >
    >


    While it is VERY true that the KDE team abandoned the fantastic
    KDE 3.5 line, IMHO, switching from a working 3.5 to ANY version
    of KDE 4 at this time is a mistake.

    I do have a relatively good working KDE 4.2.4, but not matter which
    version of KDE4 you have, there are issues (including crashes, etc).

    So... switch if you must, but PLEASE be prepared for a BAD experience.

  4. #4
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    25,870
    Blog Entries
    30

    Default Re: Updating my KDE form 3.5.9 to 4.5 in Suse 11.0?

    I have installed openSUSE-11.1 from the communtion KDE-4.3.2 live CD "KDE Four Live" CD and then updated to KDE-4.3.4. It worked well for me.

    But going from openSUSE-11.0 KDE-3.5.9 is a massive leap. Massive. I would not try it myself.

    IMHO you are better to install openSUSE-11.1 or 11.2 and then update to KDE-4.3.4. Plan on a clean /home in addition to a clean / (root) .

    Note one's experience with KDE3 and KDE4 is very subjective and invokes incredible rants and emotions from all sorts of users. Some users swear by KDE3 and claim KDE4 is unuseable. Others claim KDE3 provides features that KDE4 does not have. Others (myself for example) note that KDE4 provides features that KDE3 does not have (where in my case the feature I want in KDE4 (not in KDE3) is essential for where I work). I would never go back to KDE3.

    If you are not an average-to-advanced user, then IMHO you should run the openSUSE-11.2 live CD, check to see if it runs ok, and if does, then install openSUSE-11.2 KDE-4.3.1 and then update to KDE-4.3.4.

    If that fails, then try the openSUSE-11.1 KDE-4.3.2 live CD I referenced above, and check to see if it runs OK. If it does (where openSUSE-11.2 live CD did not) then install the openSUSE-11.1 KDE-4.3.2 live CD, and then update to KDE-4.3.4.

    I have done both approaches and both work. No bad experiences on my part.

  5. #5
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,070

    Default Re: Updating my KDE form 3.5.9 to 4.5 in Suse 11.0?

    I would agree with oldcpu; I was running 11.1 with KDE4.2 but there were so many conflicts involved in upgrading to KDE4.3 that I decided to wait until 11.2 on my production machine.

    KDE4.3 is a definite improvement just as KDE4.2 was over KDE4.1.

  6. #6

    Default Re: Updating my KDE form 3.5.9 to 4.5 in Suse 11.0?

    Quote Originally Posted by john_hudson View Post
    .
    KDE4.3 is a definite improvement just as KDE4.2 was over KDE4.1.
    That is very clearly true, but it may not be enough. As far as robustness and freedom from crashes is concerned, I have not yet seen a KDE 4.x that is close to the end of the KDE 3.5 series. OTOH, having used kde 4.x for some time, I'm not going back to kde 3.x willingly.

    If you are happy to cope with a few rough edges and maybe some out-and-out crashes to be on the bleeding edge, go for it. If you think that stability is the only worthwhile virtue, probably wait a bit yet.

    Trouble is, most of us are somewhere in between.

  7. #7
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    10,968
    Blog Entries
    2

    Default Re: Updating my KDE form 3.5.9 to 4.5 in Suse 11.0?

    I have deleted a post that is contra the Terms and Conditions and apologise to markone for any discomfort.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •